LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Current bug: netlink error: failed to retrieve link setting/No such device (https://www.linuxquestions.org/questions/slackware-14/current-bug-netlink-error-failed-to-retrieve-link-setting-no-such-device-4175693345/)

upnort 04-08-2021 12:56 PM

Current bug: netlink error: failed to retrieve link setting/No such device
 
The NIC is Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet using the r8169 module.

On a test partition with the latest Current packages, when booting directly to init 1 the network link is not initialized. Running ethtool results in stderr spew as seen in the title. I did not find any clues online or in the logs.

The bug does not manifest when booting to init 3.

Originally this test partition was 14.2. I restored the partition to a clone of 14.2 and repeated the update to Current. Same error on init 1. I have not yet tried a fresh install from scratch on this system. No such bug in 14.2.

While networking usually is not used in runlevel 1, I never have seen this behavior. I discovered the bug because my rc.local[_shutdown] scripts use ethtool to ensure WOL is enabled.

I cannot say when the bug started. I had not updated this specific test partition since about March 11 (5.10.23). While in my testing of Current I commonly boot to init 1, I cannot offer any memory of previous behavior other than I would have noticed this bug.

I have only a VM and a laptop for additional testing and I cannot replicate. Different NICs of course.

I tested the 5.11.12 and 5.10.27 kernels as they are the only packages I still had copies.

I do not have any previous kernel firmware packages. I'll test if anybody provides links. Likewise with previous kernel packages.

Any ideas?

Edit: Additional testing shows ethtool is working fine in runlevel 1 with different NICs. While there is no detected link in runlevel 1 because networking has not been initialized, ethtool does not falter on other NICs. Seems ethtool is affected only with this specific NIC or perhaps NIC module.

Alien Bob 04-08-2021 01:49 PM

The runlevel 1 never initializes (-ed) the network. Not now, not in earlier releases.
But rc.K (the script that brings you to runlevel 1) does not assume anything and will bring down all kinds of network services if they would be running (like, if you started in runlevel 3 and then dropped to 1). Expect error messages, if they bother you, my answer from the previous thread stays: close your eyes for a sec and wait for the errors to stop.

upnort 04-08-2021 01:58 PM

Sometimes Eric your replies are really obtuse. And useless.


All times are GMT -5. The time now is 10:48 AM.