-   Slackware (
-   -   -current, amarok 2 and mysql support (

metalface 07-09-2009 02:05 PM

-current, amarok 2 and mysql support

I'm trying to get amarok 2 to use mysql on Slackware-current. I've done a few searches and it seems it needs re-compilation, as I can find some people saying "I just used the slackbuild script" which I have tried, only for it to bomb out with errors regarding mysql, as so:

tar: /downloads/amarok/../../../../../source/ap/mysql/mysql*.tar.?z*: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
ERROR: No libmysqld.a. Strongly advised to put a MySQL source .tar.bz2 in
this directory and try again...

I thought I might have the incorrect mysql package, so I downloaded a few more, converted one from a tar.gz to a bz2, and still I get the same error.

Has anyone got this to work successfully? I'm at a loss at present for new ideas and would welcome any support!


bgeddy 07-09-2009 02:47 PM

Looking at the Slackbuild it looks like amarok needs the mysql source. Download it - you can find it here - and put it under the amarok source code directory in a directory called "mysql/". Then change the relevant line in the Slackbuild from this :

to this :

Then try running it.

There may be other directories coded into the Slackbuild which you'll have to change. I've not examined it too closely.

ppr:kut 07-10-2009 01:58 AM

amarok2 is solely using mysql, *BUT* only as embedded db. There is currently no way of getting amarok2 < 2.2 to work with a mysql server.

metalface 07-10-2009 10:37 AM

Thanks for your reply, much appreciated.

I attempted what you've suggested and indeed it did appear that mysql was found - there was a whole screen of what appeared to be the archive unpacking - I still come up with this error at the end:

ERROR: No libmysqld.a. Strongly advised to put a MySQL source .tar.bz2 in this directory and try again...

Any ideas? :s

ppr:kut 07-10-2009 10:56 AM

what are you trying to get through re-compiling amarok?
There's no more mysql available in amarok than the packaged one already has...

metalface 07-10-2009 11:25 AM


Originally Posted by ppr:kut (Post 3603444)
what are you trying to get through re-compiling amarok?
There's no more mysql available in amarok than the packaged one already has...

Maybe in 12.x when amarok was not version 2?

The new one isn't compiled with mysql support, there are no options in the menus to use a mysql database - which is what I want to enable.

ppr:kut 07-10-2009 11:33 AM

No. Amarok-2.1.1 (as of 13.0rc1) *is* definitely compiled with support for mysql.
BUT, you are *not* able to select a mysql server, because amarok2 currently has only support for Mysql Embedded (which is libmysqld.a).
If you really want to use a mysql server with amarok you will either need <=1.4.x or >2.1.x

Recompiling amarok 2.1.1 will not magically get you a feature that's simply not there in the code.

metalface 07-10-2009 12:05 PM

I know that Amarok 2 uses an embedded version of mysql, but I think I must have misunderstood something somewhere. I could have sworn I read a blog on the Amarok site where the dev's talked about using one database and sharing that amongst multiple computers (which is what I am aiming to achieve) - and surely at the moment in the current state, that can't be possible? I mean, unless there's some way to share out that embedded version so I can connect to it from other computers in rooms in my house, the only result I can see is that each time I started a machine/Amarok, it'd have to re-scan a network share rather than just use a central database.

I've seen screens (and how-to's) with this using previous versions of Amarok, so I guess I'll use one of those or just wait until the functionality is implemented in a newer build of the app, because I can't believe they'd take out such great functionality.

Thanks for your help, ppr:kut - appreciated! :)

ppr:kut 07-10-2009 12:25 PM

I think you read the same blog I read, but it's talking about amarok 2.2.
I don't know if you can share an embedded db, but if it is, it's probably not that easy.

bgeddy 07-10-2009 01:03 PM

1 Attachment(s)
Oh well - glad you got it sorted. Sorry I should have paid more attention to what you where trying to actually achieve rather than just helping with the build ! I'm not really that familiar with amarok anyway.

Anyway - for anyone wishing to rebuild amarok and in the interests of completion I have attached an altered amarok.Slackbuild(.txt) that takes account of the suggested directories and builds the package without the stock Slackware build directories being present. It also adjusts for the source being in a .tar.xz file. It may help someone with a new build. Note that this has the Slackware configuration options in place so the resulting application will be the same as the stock Slackware one.

All times are GMT -5. The time now is 05:23 PM.