LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-27-2004, 05:47 AM   #1
hraposo
Member
 
Registered: Aug 2004
Posts: 370

Rep: Reputation: 30
cups with no parallel port????


Hello
I tried configure my printer with http://localhost:631/admin in slackware 10, but cups don't have the paralell port where is my printer... just serial ports...
What can I do?
Which port I chose?
 
Old 09-27-2004, 06:13 AM   #2
TheBman
Member
 
Registered: Nov 2003
Location: Rural Indiana
Distribution: Debian (etch)
Posts: 78

Rep: Reputation: 15
edit the /etc/rc.d/rc.modules file uncomment the following line in *parallel printer* section

/sbin/modprobe parport_pc io=0x387 irq=7
 
Old 09-27-2004, 06:35 AM   #3
mixtr
Member
 
Registered: Jul 2004
Location: Ottawa
Distribution: Arch, OpenBSD
Posts: 123

Rep: Reputation: 17
I had the very same problem and I got my answer here (tanx again people) but you don't have to uncomment the whole section only these 2 lines in the /etc/rc.d/rc.modules file:

/sbin/modprobe parport_pc in the "PC parrallel port support" section and
/sbin/modprobe lp in the "Parrallel printer support" section

That did it for me, uncommenting the whole section made some error message at boot time.
 
Old 09-27-2004, 08:46 AM   #4
hraposo
Member
 
Registered: Aug 2004
Posts: 370

Original Poster
Rep: Reputation: 30
thank you.Now I can configure the printer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to load parallel port drivers for cups bipins1979 Linux - Hardware 3 09-03-2005 04:19 PM
CUPS printing, parallel port not found in lpinfo beajedi Linux - Hardware 26 10-23-2004 05:44 PM
CUPS doesn't see my parallel port mixtr Slackware 3 07-27-2004 09:51 PM
Missing Parallel Port and CUPS KaptinKABOOM Slackware 14 07-02-2004 12:52 PM
CUPS Parallel Port Busy Problem kbcnetau Linux - Hardware 0 06-16-2004 06:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration