LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   CUPS + Router (DI-704P) + Print Server (https://www.linuxquestions.org/questions/slackware-14/cups-router-di-704p-print-server-345332/)

oxblood 07-21-2005 08:45 AM

CUPS + Router (DI-704P) + Print Server
 
So here's my story: I'm trying to share my printer (hpdeskjet 940c) which is connected to my router's print server (DI-704p) among all my machines (1 XP, 1 XP server, 1 Slackware, 1 debain, 1 Solaris, 1 XP laptop). Of course, D-link has provided print server drivers for Windows machines but Linux/Unix as usual are neglected.

I tried to use CUPS to make my Linux machines take advantage of shared printer. I've set my printer on Linux as following:

/usr/sbin/lpadmin -p printername -E -v socket://192.168.0.1 -m deskjet.ppd

Now, everytime I try to print a page I get the following message from http://localhost:631/

"Network host '192.168.0.1' is busy; will retry in 5/1/5/30 seconds..." but nothing happens. I have tried to set the network interface to:

socket://192.168.0.1:515

As I have witnessed that the printer and LAN machine are exchanging packets through destination port (on the router) of 515 when I ran Ethereal. No luck! I switched the protocol to LDP (ldp://192.168.0.1(:515) but that kept shutting down the printer as soon as a job was submitted. For some reason I get this message, "One byte of data was received" and the printer needs to be restarted. The content of Ethereal shows the LDP protocol keeps failing by issuing incorrect message or something but TCP packet exchange goes ok (Ethereal was run under Windows machine by the way).

So now I don't know what else I can do. Any ideas?

Hangdog42 07-22-2005 08:16 AM

Please don't post in more than one forum.

There is a more active discussion here

XavierP 07-23-2005 06:51 AM

Closed as per Hangdog42's comment.


All times are GMT -5. The time now is 11:43 AM.