-   Slackware (
-   -   cups printer install (http://localhost:631/) has root/pw issues (

Asinine 09-10-2009 06:08 AM

cups printer install (http://localhost:631/) has root/pw issues
I managed to "install" my HP 3930 in Slack 13.0 with a combo of hp-setup and localhost:631. I had to run the localhost thing to get the proper .ppd (the DJ3920's; I found posts to ensure that this driver works great for the 3930) to show up in hp-setup; I could not finish the installation in localhost because it continually prompted for my username/pw even though I *know* I was imputing my root info correctly.

Afterwards, the printer showed up in cups, but not in the Xfce print manager. So I ran hp-setup again and ran the install again, thinking it'd copy over it (honestly, I don't know why I did this, except just trying everything to get the printer to show up in places where I can print with it, not just the cups thing).

But now two printers show up in cups' web thingy, and I cannot remove/alter/do anything in cups because my root/pw continually get this:

A username and password are being requested by http://localhost:631. The site says: "CUPS"
until I cancel out. Then I just get

401 Unauthorized

Enter your username and password or the root username and password to access this page. If you are using Kerberos authentication, make sure you have a valid Kerberos ticket.

I did a slackpkg search for kerberos and everything it pulls up is installed.

# slackpkg search kerberos

The list below shows all packages with the selected pattern.

[ installed ] - cups-1.3.11-i486-1
[ installed ] - gcc-g++-4.3.3-i486-3
[ installed ] - samba-3.2.13-i486-1

I'm a newb and am now genuinely lost and confused. Any ideas as to what's going on?

gegechris99 09-10-2009 07:33 AM

Does your user belong to group "lp"?



HP multifunction printer/scanners require that your user account be a member
of the "lp" group for hp-toolbox to work properly, and to use the scanner
portion of some (all?) units, you'll need to be a member of the "lp" group.
This is because hplip's udev rules set the device with group "lp" ownership.

Asinine 09-10-2009 07:39 AM

Erm... I assume so. I'm logged in as root.
How do I check/ensure root belongs to the lp group?

gegechris99 09-10-2009 07:57 AM

Run the following command to check to which groups a user (here root) belongs to


cat /etc/group | grep root
To add a user to a group, type in:


gpasswd -a username group
So in your case:


gpasswd -a root lp

Asinine 09-10-2009 09:19 AM

Worked like a charm. Thanks!

All times are GMT -5. The time now is 04:47 PM.