-   Slackware (
-   -   CUPS not printing (HP LaserJet 5P) (

killerbob 05-30-2005 11:39 PM

CUPS not printing (HP LaserJet 5P)
Ordinarily, I'd do a little more research before asking this. Starting with a forensic on the computer that worked. It's 11:30, I'm tired, I have a headache, and I'm hoping that if I post this question somebody will have a quick answer in the morning.

I got my shiny new server today, and did a ground-up reinstall. Surprisingly, most of it went well. I had no problems getting any of the server software compiled/installed, or migrating my configuration files from the old system. I got the fileserver up and running with minimal hassle, migrated the IMAP mailboxes without any headaches at all. All in all, it was a peachy process, and much less irritating than the last time I did this.

However, I think I didn't install something that I need for CUPS. I'm using exactly the same foomatic PPD from that I was using yesterday with the old server, and all indications CUPS-side indicate that it works. I install the printer, no complaints. I tell CUPS to print the test page, and it doesn't gripe. It doesn't say Aborted, or give any error codes. In fact, CUPS says that the job completed just fine, and doesn't give any errors that I can see in the error_log.

Only one problem, then. Nothing comes out of the printer. There's plenty of paper in the tray, and there's plenty of toner, but nothing at all comes out. I know the system *can* talk to the printer, however, because "ls > /dev/lp0" prints a page. (I love not having a win-printer :))

I'm using a stock /etc/cups/cupsd.conf file (from the 10.1 install package). The only changes are the loglevel (currently on debug2), and allowing remote web connections. (Allow From All).

Here's what I think is the relevant section of the error log:

d [30/May/2005:23:20:23 -0400] POST /
d [30/May/2005:23:20:23 -0400] CONTENT_TYPE = application/ipp
d [30/May/2005:23:20:23 -0400] ReadClient: 7 con->data_encoding = length, con->data_remaining = 859, con->file = -1
d [30/May/2005:23:20:23 -0400] ProcessIPPRequest(0xb7bb1c3c[7]): operation_id = 000b
d [30/May/2005:23:20:23 -0400] ProcessIPPRequest: URI="ipp://alice/printers/LaserJet"
d [30/May/2005:23:20:23 -0400] get_printer_attrs(0xb7bb1c3c[7], ipp://alice/printers/LaserJet)
d [30/May/2005:23:20:23 -0400] add_printer_state_reasons(0xb7bb1c3c[7], 0x8092f88[LaserJet])
d [30/May/2005:23:20:23 -0400] add_queued_job_count(0xb7bb1c3c[7], 0x8092f88[LaserJet])
d [30/May/2005:23:20:23 -0400] copy_attrs(0x80c6448, 0x80dc9a0, 0x80c60d8, 0)
d [30/May/2005:23:20:23 -0400] copy_attribute(0x80c6448, 0x808fb28[printer-uri-supported,4,45])
d [30/May/2005:23:20:23 -0400] copy_attribute(0x80c6448, 0x80e6508[printer-name,4,42])
d [30/May/2005:23:20:23 -0400] copy_attribute(0x80c6448, 0x80ea1a0[printer-location,4,41])
d [30/May/2005:23:20:23 -0400] copy_attribute(0x80c6448, 0x80da3d0[printer-info,4,41])
d [30/May/2005:23:20:23 -0400] copy_attribute(0x80c6448, 0x80e80e8[device-uri,4,45])
d [30/May/2005:23:20:23 -0400] copy_attribute(0x80c6448, 0x80e1550[printer-make-and-model,4,41])
d [30/May/2005:23:20:23 -0400] copy_attrs(0x80c6448, 0x8094880, 0x80c60d8, 0)
D [30/May/2005:23:20:23 -0400] ProcessIPPRequest: 7 status_code=1
d [30/May/2005:23:20:23 -0400] ProcessIPPRequest: Adding fd 7 to OutputSet...
d [30/May/2005:23:20:23 -0400] WriteClient: Removing fd 7 from OutputSet...
d [30/May/2005:23:20:23 -0400] WriteClient: 5 1811 bytes
d [30/May/2005:23:20:23 -0400] ReadClient: 7, used=0, file=-1
D [30/May/2005:23:20:23 -0400] ReadClient: 7 POST / HTTP/1.1
d [30/May/2005:23:20:23 -0400] decode_auth(0xb7bb1c3c): Authorization string = ""
d [30/May/2005:23:20:23 -0400] decode_auth: 7 username=""
d [30/May/2005:23:20:23 -0400] IsAuthorized: con->uri = "/"
d [30/May/2005:23:20:23 -0400] FindBest: uri = "/"...
d [30/May/2005:23:20:23 -0400] FindBest: Location CUPS_INTERNAL_BROWSE_ACL Limit 0
d [30/May/2005:23:20:23 -0400] FindBest: Location / Limit 7f
d [30/May/2005:23:20:23 -0400] FindBest: Location /admin Limit 7f
d [30/May/2005:23:20:23 -0400] FindBest: best = "/"

Near as I can tell, there's nothing wrong. I'm guessing I forgot to install something important like ghostscript, but I can't for the life of me figure out what. From the CD, I've done "upgradepkg --install-new *.tgz" in the A, AP, L, T, and TEX directories, just in case I've missed something. (that command will install every package in the directory, skipping the ones that're already installed).

I've also tried uninstalling/reinstalling CUPS.

Any suggestions? TIA

Jerre Cope 05-31-2005 01:17 AM

I'm still on 10, rather than 10.1, but this sounds like the old lprng conflict to me. If you have the lprng package installed, uninstall it, then reinstall CUPS. Alternately, you can relink all the /usr/bin/lp* files

killerbob 05-31-2005 07:50 AM

Right, I got it working, but the method I used is akin to swatting a fly with a train.

I installed every package from CD1. I'm guessing it's something I'd missed in X or XAP, so I went in there and installed all of 'em. My server with no sound card is going to have a great lot of use out of xine... :)

Could somebody give me a list of exactly which packages are needed, so I don't have to do this again? If my server's install HDD wasn't 10gb, I'd be pissed about now.

allend 06-03-2005 12:12 PM

Did you make /etc/rc.d/rc.cups executable so that the cups server would start on reboot?

killerbob 06-03-2005 12:40 PM

Yeah... CUPS was starting just fine, and I could see the page. I'm just wondering what the other required packages are for running a print server. :/

gbonvehi 06-03-2005 12:55 PM

As far as I remember you need at least this packages:

You could try starting removing packages until you spot it :P

allend 06-04-2005 10:02 AM

When I did a bare metal install of 10.1, I lost printing via CUPS to HP LaserJet4 series printers. The problem went away away when I downloaded the hpijs driver from I note that there is an hpijs-1.7-i486-1.tgz package under /ap in slackware-current. Perhaps you could check whether installing this package is the answer.

All times are GMT -5. The time now is 04:47 PM.