LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-08-2014, 03:48 PM   #1
Zwergele
Member
 
Registered: Dec 2012
Location: Southern California
Distribution: Slackware
Posts: 86

Rep: Reputation: Disabled
CUPS in Slack 14.1: "No default destination available"


USB printer.

1. Kyocera driver is in /etc/cups/ppd

2. /etc/cups/cupsd.conf has proper permissions

3. Using the default cupsd.conf -- tried Alien Bob's, too.

4. Started /etc/rc.d/rc.cups

5. Checked and ruled out the blacklist in /lib/modprobe.d

6. CUPS (http://localhost:631) shows my printer: Kyocera FS-920 CUPS + Gutenprint v.5.2.9.

7. The USB connection on the box works.

Both lp and lpr return "No default destination available"

TIA!
 
Old 05-08-2014, 04:22 PM   #2
kikinovak
MLED Founder
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: CentOS, OpenSUSE
Posts: 3,453

Rep: Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154Reputation: 2154
Connect to your CUPS interface on http://ip_of_cups_server:631, select your printer and then "Set As Default". Then open a terminal on a client machine, and you should see something like this:

Code:
[kikinovak@alphamule:~] $ lpstat -t
$scheduler is running
system default destination: Officejet_Pro_8600
Cheers,

Niki
 
1 members found this post helpful.
Old 05-08-2014, 04:23 PM   #3
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,541

Rep: Reputation: 1065Reputation: 1065Reputation: 1065Reputation: 1065Reputation: 1065Reputation: 1065Reputation: 1065Reputation: 1065
Get into CUPS: click this link: http://localhost:631.

Get into Printers (top row).

Click on your printer.

Click on Administration

Click on Set as Server Default.

That'll doe 'er.

Hope this helps some.
 
1 members found this post helpful.
Old 05-08-2014, 05:27 PM   #4
Zwergele
Member
 
Registered: Dec 2012
Location: Southern California
Distribution: Slackware
Posts: 86

Original Poster
Rep: Reputation: Disabled
Aahhh, blessed relief!

Thank you both very much. I shall prepare a personal HOWTO for my use in the future -- and it's about time, because I always stumble over CUPS.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CUPS - no default destination available acampbell Linux - Hardware 2 08-04-2011 11:44 AM
".config" and ".kde" folders are being created under root directory (Slack Current) piratesmack Slackware 8 03-12-2011 11:06 PM
Chromium doesn't save "default browser"+ Desktop isn't "snappy" ohadbasan Arch 1 01-25-2010 08:07 PM
[SOLVED] Torrent clients using the incorrect default programs for "Open destination folder" indubitableness Linux - Desktop 8 12-20-2009 02:42 PM
CUPS gives sporadic "no default destination" AndyCanfield Linux - General 2 03-25-2004 01:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration