-   Slackware (
-   -   cups failing backend (

toedoe 09-08-2007 04:21 AM

cups failing backend
I am reinstalling Slack 12.0 to accomodate XP (-useless). I am having problems defining my printer via cups on this install and have run out of ideas. I see too that others have a similar problem i.e. /backend/socket failed. I have not seen a resolutions. My cups is 1.2. When I get to the "Device:" entry there are several options: 1) AppSocket/Hp JetDirect, 2) Bluetooth Printer, 3) Internet Printint Protocol (http), 4) same as 3) but for (ipp), 5) LPD/LPR host or Printer, 6) SCSI Printer, 7) Serial Port #1, 8) same as 7) but #2, 8) Windows Printer via Samba. I rule out 8 and 2 as the printer is a USB Canon iP1800. My hypothesis is that my problem is here. When I try serial and a couple of others I get the error about "socket failed".

A) Can soneone explain this entry and the Device URI which follows with "socket" in the entry window?
B) Is this socket failing resolved in 1.3?
C) I cannot use the initial offer to add the Canon printer to the parallel port, so where is the USB option? It worked the last time GGggrRRRR!

If anyone wonders if I have the correct software for the iP1800, the answer is yes. See and follow the links for the ip1880.

BTW after configuring printer in CUPS, I kill the running cupsd, restart the rc.cups, execute: lpadmin -E -p <printername>, lp -d <printername> /etc/motd, then run:
lpq -al and lpstat -t. lpstat shows the error.

Alien Bob 09-08-2007 05:20 AM

Does the information in this link help you out?


toedoe 09-08-2007 03:33 PM

cups failing backend
Thanks, Alien Bob, but NO that is similar to the info I mentioned about where one gets the iP1800 drivers from canon. Wonder why Canon US does not supply a link?
The problem comes in CUPS. It is difficult to know what to enter for device as there is NO USB entry to use and some entries have no meaning, as far as I can tell. BUT! on my 1st install it all went tickety-boo well (except I did not write down how I did it- 1st law of *nix) with CUPS and was able to print via CUPS.
Any help in that area?

BCarey 09-08-2007 03:49 PM

In this most recent version of cups it seems that you only get "usb" as an option if cups _recognizes_ a printer connected to a usb port (in older versions you got a dozen or so "usb" entries in devices regardless of what you had attached). So that means cups is not recognizing the printer (assuming it is connected), which means the driver is probably not installed correctly.


toedoe 09-09-2007 01:28 AM

cups failing backend
I am confused about the driver not recognizing the connected usb printer.
At times when trying to configure the printer, cups does initially recognize the printer not only as a Canon but thinks it is on the parallel printer port.

toedoe 09-10-2007 01:03 AM

cups failing backend
I gave up and went back to command line input. Now it thinks the printer is not connected. I shut down and immediately brought up XP which prints.
Here is my lpstat -t:

scheduler is running
system default destination: IP1800
device for IP1800: usb:/dev/usb/lp0
IP1800 accepting requests since Sun 09 Sep 2007 10:42:49 PM PDT
printer IP1800 now printing IP1800-8. enabled since Sun 09 Sep 2007 10:42:49 PM PDT
Printer not connected; will retry in 30 seconds...
IP1800-8 root 1024 Sun 09 Sep 2007 10:42:49 PM PDT
Help would be appreciated!

toedoe 09-10-2007 01:29 AM

cups failing backend
Ooops! Just learned that this is endemic to cups 1.2 released with Slackware 12.0
Apparently, this should have been known to the Slackware distribution team as it is a bug report on Debian #383092 (should have written that down when I found it so number may be inaccurate). This effects Epsons and has also effected Canon 4300.
Two solutions are available: 1) Release 1.3 of cups is supposed to have corrected this (promises promises, sorry just bitter I think) or 2) some have had luck purging the info and redoing the adding of the printer. I will try 2) and respond if I am successful.

toedoe 09-10-2007 02:12 AM

cups failing backend
YAHHHOOoooooooooooo))))))))))!!!! SUCCESS!
Here is what I did. Remember this is for Cups 1.2.
I removed the printer via Cups at http://localhost:631/admin
I re-installed the printer with the same features as previous unsuccessful attempt used.
That had NO effect still got the printer not connected.
Changed the resolution from the 600 dpi to 300 dpi as I have learned this sometimes works. It did not. lpoptions command was accepted but the lpoptions -l did not display any 300 dpi indication, i.e. I still got *600 for resolution which I take to be the optimal setting and the * to indicate the current value.
On a whim! I used the localhost:631 and modified the settings (did not make any changes) (at least they are there now where some (like usb device) was not when I tried to use this directly).
Then out of desperation I requested a test page to be printed. When the printer came alive I nearly wet myself. Imagine my glee when it printed a page! Then I printed the motd and it too worked. HAPPY CAMPER!!

Alien Bob 09-10-2007 04:14 AM


Apparently, this should have been known to the Slackware distribution team as it is a bug report on Debian #383092
Just curious here... how should the Slackware team have known about this bug which was reported in Debian?


toedoe 09-10-2007 04:19 PM

Alien Bob,
The bug is not unique to Debian but to CUPS. My reference to Debian was for reference only as I had no CUPS number.

BTW further probing has revealed that when defining the first printer the device "usb:/dev/usb/lp0" via command line it will "apparently" autoconvert it to: cnij_usb:/dev/usb/lp0 but not on subsequent printers such as bwhigh bwlow. This was frustrating until I stumbled onto it as it produced the "Printer not connected" error.
Also know that one is defined the "Device" input via http://localhost:631 now has 2 canon USB options but only one can be effectively used, the one with readback in it.

Also discovered much to my dismay that there are 2 types of options when using lpoptions.
lpoptions -p myprinter -l produces a ":" separated name: value|value|value while
lpoptions -p myprinter produces a "=" speparated name=value list of a different set.
While experimenting I defined a name string with the -o using = and now cannot get rid of it even after deleting the printer. if I re-use the printer name that string is still there and is preventing me from creating a usable printer/queue
Do you know how to remove such strings? I tried using a null value but it did not work.
It is probably obvious I am trying to provide options unique to a printer that are not supplied in CUPS.

slackcracker 03-09-2010 01:15 PM

Canon PIXMA MP540 and CUPS
2 Attachment(s)

Originally Posted by toedoe (Post 2885317)
B) Is this socket failing resolved in 1.3?

It seems to me, cups-1.3.11 resoled my problems for Canon PIXMA MP540 :)

I don't no why,cups-1.4.2 won't work for me.

First check if usb device is available:
root@slack64:~# ls -al /dev/usblp0
lrwxrwxrwx 1 root root 7 2010-03-09 18:12 /dev/usblp0 -> usb/lp0

I use a repackaged form (rpm2tgz) of MP540_RPM_drivers.tar from this site:

cups packages on my system:
root@slack64:~# ls -1 /var/log/packages/cups*

canon packages on my systen:
root@slack64:~# ls -1 /var/log/packages/*rpm2txz*

root@slack64:~# lpinfo -v
network socket
network beh
direct usb://Canon/MP540%20series
direct hpfax
direct hp
network http
network ipp
network lpd
direct scsi
network smb

All works fine now :)

willysr 03-09-2010 06:02 PM

when i wrote that article, it was in 2007, which means the CUPS is still 1.2 or probably older and it worked :)

by the way, if you are using CUPS 1.4, then you will have to upgrade your cnijfilter-common package, which i described here

slackcracker 10-21-2011 11:31 PM


Originally Posted by slackcracker (Post 3891887)
It seems to me, cups-1.3.11 resoled my problems for Canon PIXMA MP540 :)

I don't no why,cups-1.4.2 won't work for me.

I had a similar problem with my Canon PIXMA MP 540 again but now i resolve this.

1. i have slackware64-current 13.37 above

2. i installed multilib packages from alien, because canon driver are i386
be sure you have
cups-1.4.6-x86_64-1 cups-compat32-1.4.6-x86_64-1

3. i get the Version 3.0 from

4. unpack it with: tar xvf MP540_RPM_drivers.tar

5. convert the rpm with: rpm2txz

6- install with installpkg these packages

7. if you now try to print you get this error:
E [22/Oct/2011:04:40:34 +0200] Unable to execute /usr/lib64/cups/filter/pstocanonij: No such file or directory
because cups try to find this filter in lib64 but it is in lib (i386)

8. Now you have to edit /etc/cups/cupsd.conf and add the line

ServerBin /usr/lib/cups

9. restart cups with: /etc/rc.d/rc.cups restart ,now you should be ready to print, enjoy slackware ;-)

If there are anyway problems see the log with: tail -f /var/log/cups/error_log
If you want to see more output change the log level in /etc/cups/cupsd.conf to LogLevel debug or LogLevel debug2

All times are GMT -5. The time now is 06:11 AM.