-   Slackware (
-   -   creating /dev/dvb in slack-12-rc1 (

justwantin 06-20-2007 05:39 PM

creating /dev/dvb in slack-12-rc1
I had no problem in slack-11 with stock 2.6 kernel off install disk nor with an install of current 2-3 months ago but I just installed 12-rc1 to see what I'll need to do on the home lan and...

It seems that while my dvb-t card is recognised and correct modules are being loaded at boot, there is no /dev/dvb/adapter0 and devices therein being created.

As it was not necessary to do anything in /etc/udev in slack-11 or the last current install, I am a bit puzzeled. I had a look around on google last night but I'm not really sure what I should be looking for.

The udev rules look the same from 11 to rc1. Im booting with vmlinuz -> vmlinuz-huge-smp-

Has anyone had a dvb card recognised with /dev/dvb etc. being created in rc-1?

justwantin 06-20-2007 06:30 PM

I've had a look at a slack-11 box with /dvb/devices and there is a difference compared to the rc1 box

cat /proc/devices on the 11.0 box indicates a dvb character device, e.g.
128 ptm
136 pts
180 usb
189 usb_device
195 nvidia
212 DVB

and the rc1 box does not, e.g.
128 ptm
136 pts
171 ieee1394
180 usb
189 usb_device
250 usb_endpoint

Can anyone suggest where I should be looking to make a change/fix?

justwantin 07-01-2007 08:23 PM

Since my last post I have had a bit of a play. Booting the and (current in April) kernels compiled in rc-1 I get my /dev/dvb/adaper0 and dvb devices.

Compiling the kernel in slack-11 does the same.

I still have not figured out what the difference is with and why the devices are not created. It appears udev does the job with the previous kernels on the same box.

rkelsen 07-01-2007 08:33 PM


Originally Posted by justwantin
I still have not figured out what the difference is with and why the devices are not created. It appears udev does the job with the previous kernels on the same box.

Dumb question, but have you tried compiling a custom kernel?

According to the documentation, the "huge" kernels are not intended for every day use. They're more for emergency situations. It is possible that they don't have the support necessary for your DVB card compiled in by default.

justwantin 07-01-2007 11:26 PM

The huge smp from current in April ( worked OK when recompiled in both slack-11 and rc-1.

I compiled 7 or 8 kernels this weekend and checked to make sure all dvb IMHO options were correct each time

Probably have to compare the configs against each other next. I could also just keep compiling kernel versions up from until I find the next one that don't work and see what changed at that point. Seems silly though.

Fallback would be to just compile and use when Slack-12.0 is released though it's nice to just have things work out of the box.

titopoquito 07-02-2007 05:35 AM

You asked about anyone having got the right dev parts with a dvb-t device in 12RC1 (or now RC2): Yes, without any problem. Only thing I had to do (like before, like with any distro) was to copy the firmware to /lib/firmware, then it was picked up like it should.

I tested it with kaffeine and it worked nicely.

I forgot: kernel is vmlinuz-huge-smp-, the same you started with. I didn't recompile it until now.

justwantin 07-02-2007 06:45 AM

Thanks for the input but I am a bit confused after reading your post

I have never needed to do anything with firmware. I have a dvico fusion hdtv dvb-t on this box and a winfast dtv1000 T dvb-t card on another box. Both running slack-11 and I didn't do anything to get the devices created. Udev rules/scripts do that. Both use a Conexant CX23880 chip.

In slack-10.1 I had to fiddle with compiling modules with 2.4.X kernels and with udev when I started using 2.6. kernels but I did not have to do anything special in slack-11 or in the current I downloaded in April with a kernel.

Why do I now need to install firmware and where do I find this firmware that I never had to use before?

titopoquito 07-02-2007 06:55 AM

I think this has to do with my dvb-t device. It's not a pci card but a yakumo dvb-t usb stick and it won't work without firmware -- and I don't think all devices need that.

I got the info about my device from

justwantin 07-02-2007 07:05 AM

Quite different creatures :^)

...but thanks anyway.

justwantin 07-05-2007 03:15 PM

I have sorted this problem out on a new slack-12 install.

After booting a fresh install with the default huge kernel and the generic not huge kernel without having my devices recognised as dvb at boot and later by udev, I installed v4l-dvb from and compiled and installed it.

This has remdied the problem, dmesg indicates recognition as a dvb device, /proc/devices has a DVB 212 entry, and udev creates the requisit devices.

I still have not figured out why I have to compile and install modules on that were already compiled with that kernel and which worked perfectly on the and 2.6 18.8 slack kernels off the shelf.

.... but in any case, above is how I resolved the problem and I thought I'd best put it here as google was already serving up this thread when I looked for a solution.

All times are GMT -5. The time now is 02:10 PM.