-   Slackware (
-   -   Crash! (

paddeo 03-24-2013 12:48 PM

Updated /Current this morning and when I started 'X' it crashed with the following error:
ck-launch-session: /lib/libc.So.6: version 'GLIBC_2.17' not found (required by /usr/lib/libglib-2.0.So.0).

Also, during the upgrade, I keep seeing this message:
/sbin/installpkg: line 314: xxxx segmentation fault /sbin/ldconfig

The xxxx, of course, is a four or five digit number.

Any help would be appreciated. Thanks

fskmh 03-24-2013 12:59 PM

Did you last update before or after March 12?

If the answer is before, then you should have first upgraded the linker (upgradepkg glibc-solibs-*.t?z) before anything else.

Bazzaah 03-24-2013 01:05 PM

Do you have a multilib system? If yes, you should look at this page

paddeo 03-24-2013 01:11 PM

I have been following the /Current upgrades all month. If the linker was included then I should have it. Should I redownload and reinstall it?


comfree 03-24-2013 05:10 PM

I ran into the same problem like you.
By downloading and installing the updated multilib glibc of alienBOBs repository my system works now as it did before.

gabytf 03-25-2013 02:43 AM

After upgradepkg-all in my slackeare-current on 23March,

i am crash with the following message:


Loading extension GLX
ck-launch-session: /lib64/libc.SO.6: version "GLIBC_2.17' not found(required by /usr/lib64/

Xinit:connection to X server lost

i have a multilib system, so i download the multilib current from alienBOB and run"upgradepkg --reinstall --install-new *.t?z", just like reinstall the multilib package. It still crash showing the above message.

i also unable to boot from the USB boodisc.

My kernal is 3.2.26(i didn't upgrade it to 3.7.10), is this also another reason?

Bazzaah 03-25-2013 04:41 AM

I encountered both these problems before I saw that AlienBob had updated his blog and packages.

The update should go something like this;


rsync -av rsync:// multilib-current
cd multilib-current
upgradepkg --install-new *.t?z
upgradepkg --install-new slackware64-compat32/*-compat32/*.t?z

gabytf 03-28-2013 12:04 PM

i think i had messed up. i still having the same problem.

Another fatal message i noticed is that "kernels too old". i am with 3.2.26


FATAL:kernel too old
Kernel panic-not syncing:Attempted to kill init
it can't boot till the prompt for me to type "startx".

i can't log-in the Slackware Current thru "startx" but can access my files thru other Slackware14.0 from other partition.

Can i "pkgtool" or "installpkg" to upgrade the kernels in Slackware current from Slackware14.0?

All times are GMT -5. The time now is 10:20 PM.