LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-14-2014, 08:36 AM   #1
freakTux
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 26

Rep: Reputation: Disabled
"Couldn't get an RGB" Error trying to run glxgears


Hi all guys...I have slackware64-current, kernel 3.10.17 and NVIDIA driver installed...when I try to run glxgears for testing my glx I have got this error:
Code:
Error: couldn't get an RGB, Double-buffered visual
...Now, I think that I have some installation problem with glx because even some screensaver (xscreensaver's GLPlanet for example, that needs glx I think) doesn't work...

I searched for the glx and Nvidia on linux and I found something about bumblebee (and I found an installation guide on this page: http://docs.slackware.com/howtos:har...nvidia_optimus)...it seems like that with bumblebee I can resolve this glx problem...
It is real?I have to uninstall my nvidia driver before install bumblebee (because it seems like during the download of the needed dependencies it download even a nvidia driver) ?
Please, help me...I'm a little bit confused about this...
 
Old 02-14-2014, 02:43 PM   #2
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Arch/Knoppix
Posts: 1,823
Blog Entries: 14

Rep: Reputation: 282Reputation: 282Reputation: 282
Quote:
Error: couldn't get an RGB, Double-buffered visual
is actually nonspecific for glx problems.

Bumblebee is for optimus systems. Probably it would be helpful if you gave details of your hardware (processor, system, card) and which NVIDIA driver and how you installed it. Perhaps the output of glxinfo (if there is any and it doesn't error out) dmesg and or Xorg.log might help diagnose the problem as well.
 
Old 02-15-2014, 02:07 AM   #3
freakTux
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 26

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mostlyharmless View Post
is actually nonspecific for glx problems.

Bumblebee is for optimus systems. Probably it would be helpful if you gave details of your hardware (processor, system, card) and which NVIDIA driver and how you installed it. Perhaps the output of glxinfo (if there is any and it doesn't error out) dmesg and or Xorg.log might help diagnose the problem as well.
my NVidia card is a GeForce GT520M, my processor is an Intel Core i3 2310M and I have a 64 bit system. My NVidia driver is the 331.20 installed with sbopkg...

I think that is a glx problem because if I choose a screensaver (like hypnoweel or gltext or many others) from xscreensaver and I try to "preview it" I have a black screen with this error massage:
Code:
gltext: root window's visual 0x2bf does not support the GLX extension.
xscreensaver: signal: 0: child pid 3792 (<unknow>) exited abnormally (code 0).

Anyway, the output of glxinfo is:
Code:
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig
Error: couldn't find RGB GLX visual or fbconfig



Segmentation fault
 
Old 02-15-2014, 09:26 AM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
The glx problem is a mesa problem. and you really need to reinstall mesa when uninstalling your nvidia model and and installer. well from one installer to another may break the links you need. If your going to use bumblebee it would be good to start it as a default system.
I make it a practice of reinstalling mesa when upgrading the nvidia module and installer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with nvidia drivers in 12.2 - glxinfo "couldn't find RGB GLX visual" yossarian42 SUSE / openSUSE 7 01-27-2013 08:50 PM
[SOLVED] glxgears, fgl_glxgears run, but no "picture" or "stagnant" picture almcneill Linux - Software 1 01-27-2013 01:45 AM
when program run at ARM broad, error "couldn't set console screen info" occur yuechun Linux - Software 1 12-16-2009 12:50 PM
glxinfo "couldn't find rgb glx visual or fbconfig" on nvidia drivers MikeyCarter Linux - Software 3 10-13-2009 09:15 AM
glxgears: Error: couldn't get an RGB, Double-buffered visual. koodoo Linux - Newbie 10 08-15-2008 11:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration