Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 09-03-2011, 12:10 AM   #1
Registered: Apr 2011
Distribution: slackware64-current
Posts: 316

Rep: Reputation: 35
Unhappy Could not open library ksmserver...

After upgrading everything possible with gslapt, I realized that gslapt totally messed up my libraries situation. E.g., glpapt no longer runs because it is looking for, which certainly exists where it thinks it does not...

Even after clearing my /tmp folder, clearing ~/.kde, running "slackpkg clean-system" and, in the slackware64/kde directory of my install drive, "upgradepkg --reinstall --install-new *.t?z", I still get the following errors when running startx with xwmconfig set to KDE. The important part is (see whole snippet: out.txt):

Could not open library ksmserver: Cannot load library /usr/lib64/ ( error while loading shared libraries: No such file or directory)
ksmserver: error while loading shared libraries: cannot open shared object file: No such file or directory
And those files are indeed where it says they're not... This is not the first time gslapt has messed up my libs, but the first time only affected my video driver; this time it affected many libraries.

What's going on? Thanks
Old 09-04-2011, 09:05 AM   #2
Alien Bob
Slackware Contributor
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,853

Rep: Reputation: Disabled
So, where is this file "" located on your system then? And what is the output of the command "file" if you run that in the directory where you located "" ?
It is possible that you let gslapt update your 64bit originals with packages from a 32bit Slackware repository.



gslapt, kde, slackware 13.37, slaptget, startx

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 13 ksmserver crashes when I disconnecting ppp n03x3c Fedora 1 06-30-2010 05:56 AM
[SOLVED] xsane/sane crashes ksmserver? JamesGT Slackware 3 06-28-2010 12:46 AM
where is the open ssl library B-Boy Linux - Software 1 03-16-2009 05:45 AM
KDE 3.5.2 cannot load, Z038 Slackware 7 04-20-2006 09:10 AM
could not start Ksmserver (kde dont boot) master Linux - Software 3 12-24-2005 08:40 PM

All times are GMT -5. The time now is 05:40 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration