-   Slackware (
-   -   Copying files from a cell phone (

Woodsman 11-25-2012 09:47 PM

Copying files from a cell phone
This is all new to me so I appreciate any help.

All I want to do at the moment is copy a camera photo from a cell phone to my desktop.

The phone is an LG 440G. The phone does not have an micro SD card or slot.

Although the phone is bluetooth capable, I don't yet have a bluetooth dongle. I have a micro USB cable.

Connecting the phone when powered off results in the device being assigned the /dev/ttyACM0 device node with ownership of 660 and root:dialout.

Connecting the phone when powered on results in no device node assignment.

Powering on the phone while connected results in the device node being removed.

First hurdle is I need a udev rule to force the device to belong to the plugdev group rather than dialout. I thought I had a rule but the device keeps being assigned to dialout:


KERNEL=="ttyACM0",SUBSYSTEM=="tty",ATTRS{manufacturer}=="LG",ATTRS{product}=="LG 440G", GROUP="plugdev", MODE="0660"

The rule is not working.

When I manually change the device node group to plugdev, or I add my user account to the dialout group, gammu --identify can access the device. I receive some sane information. I tried several gammu commands but am told the function is not supported. So after getting past the udev rule, how do transfer files from the phone?

Thanks. :)

Daedra 11-25-2012 11:40 PM

If its a CMDA (verizon) phone then maybe try bitpim.

markush 11-26-2012 01:07 AM

I don't know if this helps. Normally you'll have to select on the device if it should act as a modem or USB-memory.


mlangdn 11-26-2012 04:27 AM

My phone is Android, and I downloaded an app called AirDroid that allows me to connect to the phone through my home wireless network and Firefox. I download my pictures that way.

markush 11-26-2012 04:33 AM


Originally Posted by mlangdn (Post 4837118)
My phone is Android, and I downloaded an app called AirDroid that allows me to connect to the phone through my home wireless network and Firefox. I download my pictures that way.

The OP's cellphone seems not to have wifi.

BTW: I use AndFTP with my smartphone (an FTP-client) and I have vsftp configured on Slackware, it's very convenient for up- and download).


mlangdn 11-26-2012 04:38 AM

I also found this just now and it works great!

Scroll down to the update section to read more. It is in italics.

mlangdn 11-26-2012 04:45 AM

I just looked up his phone and see that I am barking up the wrong tree. Sorry Woodsman.

mrclisdue 11-26-2012 05:30 AM

+1 for bitpim.

I have pre-smartphone LG, and bitpim works for it.


Woodsman 11-26-2012 02:12 PM

More information:

The LG 440G is not a smart phone. Just a plain flip phone. Tracfone. Not Verizon. Not Android. To the best of my knowledge, Tracfone uses GSM and piggy-backs on the AT&T network. No micro SD card.

Being just a basic phone, I have not found any menu option to select on the device whether to act as a modem or USB-memory.

The phone works well enough as a phone. No complaints because that is all I really want. I haven't used the camera in any serious manner, but if I did I need a way to transfer the files.

The phone has bluetooth capabilities but as I don't (yet) have a bluetooth dongle I can't test that. Possibly bluetooth will resolve the problem, but I'm curious how to access the phone with the mini USB cable.

For the moment I ask for help with the udev rule to force the device node to be assigned to the plugdev group and not the dialout group.

Thanks. :)

xj25vm 11-27-2012 01:26 PM


For the moment I ask for help with the udev rule to force the device node to be assigned to the plugdev group and not the dialout group.
I'm not sure you are heading in the right direction by trying to alter the group assignment. If the phone gets detected as /dev/ttyACM0 device - it means that it is presenting it's modem/serial interface to the computer over usb. To my knowledge, that is of no use if you are trying to download pictures from it. It is of use, however, if you are trying to use it as a GSM dial-up modem to connect your computer to the Internet through the mobile phone connection (if your phone is on a suitable data plan).

Back to your problem, all devices I've encountered can only present one interface at a time through USB (either modem or storage), so your best chance is to find somewhere in the phone menus an option for switching the USB connection to data storage mode (or a similar name). This will expose a mass storage device over the USB cable to the computer - which will detect it accordingly as (hopefully) /dev/sdX. Even S40 series Nokia's (the feature phone variety) have been able to do this since forever - so hopefully the LG has a similar option. However, I'm not familiar with this model, so can't give more precise guidance.

Hope the above helps

Woodsman 01-27-2013 12:17 AM

A note to future readers: I resolved the problem using bluetooth. The LG440G supports "File transfers." I bought a USB bluetooth adapter for the computer and can transfer photos from the phone to my computer.

Lystraomoore 07-02-2014 01:56 AM

"file transfer"

Originally Posted by Woodsman (Post 4878312)
A note to future readers: I resolved the problem using bluetooth. The LG440G supports "File transfers." I bought a USB bluetooth adapter for the computer and can transfer photos from the phone to my computer.

Exactly how did you do that? I have the same phone and found the blue tooth settings in the phone, but when it says "file transfer" and click it, it goes back to previous menu..been trying to figure this out for 3 days..very frustrating! Could you tell me how you did that stap by step? Please~ :)

Woodsman 07-02-2014 11:50 PM


Exactly how did you do that?
Woof! Good question! I have not done this in a long time, probably since my last post in this thread. I had to experiment quite a bit this afternoon, and painfully so, before I could provide details.

Short answer is on Slackware 14.0/14.1 I can pull files from the phone to the computer using obexfs, or blueman-applet and a web browser or file manager. I cannot push files from the phone to the computer, but I can send files from the computer to the phone. In LMDE Mate I cannot push files from the phone. In SolydX Xfce I can push files from the phone and browse files from the computer, but I cannot send files to the phone. Short conclusion is I am unable to get everything to "just work" in any environment. In all, horribly frustrating.

Now for the long grueling story.

I am not a cell phone wizard by any stretch of anybody's imagination. Possibly there are several ways to read basic flip phones and manually transfer files. Please realize I am describing only the phones I own and not all cell phones. :)

After my last post in this thread I learned that being Bluetooth capable does not mean a phone supports direct file transfers. I have two Tracfone flip phones, one for GSM and one for CDMA. The GSM phone is an LG440G and the CDMA is an LG235C. Both phones support Bluetooth. That is, I can pair both phones to my Panasonic phone system in my home, to each other, or to my computer.

Pairing devices does not guarantee doing anything useful. While the LG440G supports direct file transfers with another similarly enabled Bluetooth device, the LG235C does not. Both phones support sending files through email, but that has nothing to do with Bluetooth. Using Bluetooth I can sync address books between the two phones and my Panasonic phone system.

For both phones the differences are seen in the Bluetooth submenus, specifically the "My Bluetooth Info" submenu. For the LG440G, there is a "Supported Services" submenu that looks like this:

Object Push
File Transfer
Advanced audio distribution
AV remote control
Basic printing
Phonebook access

The LG235C has no further submenus and the informational display looks like this:

[Supported Profiles]
Phonebook Access

The LG235C does not support file transfers and other features.

There are two ways to get a file from the LG440G to a paired Bluetooth device supporting file transfers. Basically, either push or pull from the phone.

First thing to do is pair the devices.

Pairing the two phones is more or less straightforward with some caveats. One prerequisite is providing device names to each device. One warning is devices have limited visibility. This is the period in which other devices can discover the phones. The LG440G will remain visible for up to three minutes and the LG235C for only one minute. This is frustrating when trying to learn because the visibility is a manual option. When the visibility period ends the user has to again manually enable visibility. A security feature but mildly frustrating.

In my case I named both phones before enabling visibility. Then each phone found the other and I could accept the pairing. If unfamiliar with pairing, both devices prompt the user with confirmation requests and the same random pass code. The two random pass codes should match and then the user accepts the pairing.

What I am able to do between the two phones is limited. Mostly send vCards and sync address books.

I get mildly confused using the two phones because the common features are in different menus. Icons are not the same between the two phones. The menu options buttons often are reversed --- on the left side for one phone and on the right side for the other. Confusing. I do not understand why the LG folks cannot be consistent and do not make equivalent GSM and CDMA model phones with the same exact features. Probably because marketing idiots control product releases rather than engineers.

The next post is about connecting either phone to my computer.

Woodsman 07-02-2014 11:55 PM

Getting my Slackware 14.1 system connected to my phones was frustrating. First there is the limited visibility period of the phones. Second is the blueman applet is not intuitive to me.

The USB Bluetooth adapter I bought for my computer is an Azio BTD-V201. Can't say much other than "just works."

First thing is insert my Azio device. Then start the bluetooth rc.d script. Or vice-versa, does not make a difference.

Start the blueman applet. The applet runs in the system tray. There is no true menu option to quit the applet. There is a Quit option but the applet only minimizes to the system tray. I have to open a terminal to terminate.

My first many attempts to connect to either phone always failed.

The problem was blueman-applet never prompted me with the same pass code confirmation. The blueman-applet man page is a joke and selecting the Help menu opens my browser to a blank web page.

In the process of working with blueman-applet, I stumbled across the following information.

Verify a user account is a member of the lp group.

A web search reveals using obexfs in a terminal window. I need to know the MAC address of my LG440G phone. From there I do this:

mkdir $HOME/obexfs/XX:XX:XX:XX:XX:XX

Where XX:XX:XX:XX:XX:XX is the MAC address of the phone. Then I "mount" the device:

obexfs -b XX:XX:XX:XX:XX:XX $HOME/obexfs/XX:XX:XX:XX:XX:XX

From that point I could browse personal files. On the LG440G I saw the following:

ls $HOME/obexfs/XX:XX:XX:XX:XX:XX

Audio Other Files Pictures Video

The camera files are in the Pictures directory:

ls $HOME/obexfs/XX:XX:XX:XX:XX:XX/Pictures/Camera\ Album


At this point I verify I can browse the LG440G using obexfs and a file manager.

I am unable to use obexfs to mount the LG235C phone.

Although the LG235C supports Object Push, the following command fails:

sdptool browse XX:XX:XX:XX:XX:XX
Failed to connect to SDP server on XX:XX:XX:XX:XX:XX Host is down

The command works fine with the LG440G with a long list of details.

The following command reveals information about the Azio adapter.

hcitool dev

I see the MAC address of the Azio adapter and a device ID of hci0. Next I try this:

hciconfig -a hci0

Reveals a short chunk of information about the Azio device. I notice the device name I previously assigned the computer. At this point I do not know where this device name is being stored. Searching /etc reveals no related config files. Searching /var reveals a config file in /var/lib/bluetooth/XX:XX:XX:XX:XX:XX/config, where XX:XX:XX:XX:XX:XX is the MAC address of the Azio device.

I stop the bluetooth service, unplug the adapter, and delete /var/lib/bluetooth/XX:XX:XX:XX:XX:XX. I start the service and insert the adapter. A new config file is created with a default name of $HOSTNAME-0.

* I start blueman-applet.
* I click on the system tray icon to open the applet.
* From the menu I selected Adapter->Preferences.
* I assigned a Bluetooth device name to my computer.
* I enable permanent visibility.

/var/lib/bluetooth/XX:XX:XX:XX:XX:XX/config is updated with the new name.

Yet I remain unable to pair the Azio adapter with the phones.

Woodsman 07-02-2014 11:59 PM

With much weeping and gnashing of teeth I finally discover the core of the problem with blueman-applet. The confirmation dialog for the pass code from blueman-applet always appeared behind the applet window. I never saw the confirmation dialog. In hindsight, several hours later I tested blueman-applet in KDE and the confirmation dialog appeared in the front of all other dialogs. Likewise in LMDE and SolydX. Earlier today I was using Trinity and blueman-applet might be coded only to work with certain environments. I don't know. I wasted a lot of time and anger on this SNAFU.

That nonsense out of the way, almost every time thereafter I tried to pair the devices the authentication failed.

The process was hit and miss. I repeated the process many, many times. Each time I might successfully pair but most times I did not. I was unable to predict when I succeed and when I fail to pair.

Finally I settled on the following sequence of steps.

* Stop the bluetooth service.
* Delete $HOME/.config/blueman/config.
* Delete /var/lib/bluetooth/XX:XX:XX:XX:XX:XX.

* In each phone, ensure the computer is not listed as a Bluetooth device.
* Start the bluetooth service.
* Start blueman-applet.

* Enable my phone visibility.
* Select the blueman-applet Search button.
* Wait for the blueman-applet to stop searching.

* Select the phone in the applet list pane.
* Press the Add button.
* Press the Pair button.
* If the applet returns a Page Timeout error, again press the Pair button. And again. And again.
* Wait for the phone to prompt me to confirm the pairing request.
* Use that prompting clue to move the blueman-applet window so I can see the computer confirmation dialog.
* Try as much as possible to simultaneously accept both dialogs.
* Hold my breath.

The process remains hit-and-miss. Sometimes the devices are listed as cellular devices and other times as Unknown.

Using blueman-applet, I can "right-click" on each phone and the popup context menu matches the known features I previously shared. With the LG235C I am unable to send or browse files. With the LG440G, selecting Browse Files opens my web browser rather than a file manager. Go figure.

I had mixed success using KDE and bluetooth in Slackware. While I was able to pair devices without pain, I could not browse the LG440G files. Konqueror would open but that is far as the process unfolded. Conversely, I could push files from the phone to the computer. The KDE dialog contained a Save As button but otherwise defaulted to saving the files to $HOME. As the push worked with KDE on Slackware I will guess again that my problems with pushing from the phone have to do with using Trinity.

I had mixed success in LMDE using the mate-bluetooth-applet. To my knowledge that tool is not available with the Mate slackbuilds. At least, the tool is not installed with the packages I downloaded. The mate-bluetooth-applet was more user-friendly than blueman-applet. I successfully paired my phones each of several attempts with no errors or time-outs. The mate-bluetooth-applet correctly launched the file manager rather than the web browser to browse the phone files. That said, I was unable to send files to the LG440G from the computer and I could not push files to the computer from the phone. For the latter I always received a "Bluetooth Busy" error message.

In SolydX I had to first install the blueman package, which is not installed by default. Thereafter I was able to use blueman-applet to pair the phones. I could browse the LG440G files. I could push files from the phone to the computer (defaulting to $HOME) but could not send files from the computer to the phone.

All times are GMT -5. The time now is 01:30 AM.