LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-03-2016, 09:20 AM   #1
DarkVision
Member
 
Registered: Jul 2007
Posts: 189

Rep: Reputation: Disabled
Question consolefont and /etc/rc.font


Hi...
I have set a consolefont in /etc/rc.d/rc.font since the default is really small if you have a ultrabook/tablet with a resolution of 1920x1080 and less then 13" screen and KMS enabled.

rc.font will change the consolefont during boot sequence before i login into runlevel 3. Everything is fine for console #1.

I made a similar change for testing in a virtual machine using VirtualBox.

If i switch to console #2 or #3 using [ALT]+[F2]/[F3] in VirtualBox... this font will not be applied. Right now i have to add a consolefont.sh script to /etc/profile.d to set the font when logged into a different console.

I have tested that on my new ultrabook... same behaviour. Without the extra profile script i need to lauch /etc/rc.d/rc.font to set the larger consolefont manually.

Is this a normal behaviour?
If so this would require two scripts to do the same job...

P.S. Looks like i missed to reboot the machine, so issue partly solved , sorry. But one issue is still left that make it necessary to set the consolefont in /etc/profile.d... i'm using ter-124b and without unicode_start the ui of midnight-commander looks ugly on console #2,#3.... So for now i symlink /etc/rc.d/rc.font (which set the font using "unicode_start ter-124b") to /etc/profile.d/consolefont.sh. With this link everything is fine.

Last edited by DarkVision; 04-03-2016 at 09:48 AM.
 
Old 04-03-2016, 10:02 AM   #2
Thom1b
Member
 
Registered: Mar 2010
Location: France
Distribution: Slackware
Posts: 214

Rep: Reputation: 161Reputation: 161
Hi,

I execute rc.font in the beginning of rc.S (so I disable it in rc.M). With this change, my font is set on every tty terminal.
 
1 members found this post helpful.
Old 04-03-2016, 10:37 AM   #3
DarkVision
Member
 
Registered: Jul 2007
Posts: 189

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Thom1b View Post
I execute rc.font in the beginning of rc.S (so I disable it in rc.M). With this change, my font is set on every tty terminal.
Thanks for the hint. I placed the rc.font before rc.modules in rc.s and this will make it much easier to read the boot messages after kernel switched to KMS.

Anyway... when i login to console #1 after a reboot font is OK even when using midnight commander. When switching to console #2 and logging in as root the midnight-commander UI looks horrible. See screenshot#1. If i exit mc and launch unicode_start ter-114b everything is fine, see screenshot #2. And this is what i get if i create the extra symlink to /etc/profile.d...
Attached Thumbnails
Click image for larger version

Name:	slackware64-current-consolefont.png
Views:	38
Size:	34.8 KB
ID:	21355   Click image for larger version

Name:	slackware64-current-consolefont2.png
Views:	37
Size:	29.2 KB
ID:	21356  

Last edited by DarkVision; 04-03-2016 at 10:53 AM. Reason: Fixed typo...
 
Old 04-03-2016, 10:57 AM   #4
Thom1b
Member
 
Registered: Mar 2010
Location: France
Distribution: Slackware
Posts: 214

Rep: Reputation: 161Reputation: 161
I think it's a coding character problem. I use "/usr/share/kbd/consolefonts/ter-112n.psf.gz" font and UTF-8 encoding. So I also modify /etc/profile.d/lang.sh using "export LANG=fr_FR.UTF-8" (because I'm french) but you can use "export LANG=en_US.UTF-8"
 
Old 04-03-2016, 11:04 AM   #5
DarkVision
Member
 
Registered: Jul 2007
Posts: 189

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Thom1b View Post
I think it's a coding character problem. I use "/usr/share/kbd/consolefonts/ter-112n.psf.gz" font and UTF-8 encoding. So I also modify /etc/profile.d/lang.sh using "export LANG=fr_FR.UTF-8" (because I'm french) but you can use "export LANG=en_US.UTF-8"
I have already changed lang.sh to use "export LANG=de_DE.UTF-8"... so i don't think this has something to do with it.
 
Old 04-03-2016, 11:06 AM   #6
Thom1b
Member
 
Registered: Mar 2010
Location: France
Distribution: Slackware
Posts: 214

Rep: Reputation: 161Reputation: 161
Did you set this parameter in lilo.conf (or alternative in grub) : append="vt.default_utf8=1" ?
 
1 members found this post helpful.
Old 04-03-2016, 11:15 AM   #7
DarkVision
Member
 
Registered: Jul 2007
Posts: 189

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Thom1b View Post
Did you set this parameter in lilo.conf (or alternative in grub) : append="vt.default_utf8=1" ?
Yaeh! thanks a lot! That did the trick. By default lilo was using append="vt.default_utf8=0". i switch to append="vt.default_utf8=1" and now everything is fine.

Is this something i missed during setup or is this utf8=0 a default that needs to be set manually if someone want to use utf8?
 
Old 04-03-2016, 11:18 AM   #8
Thom1b
Member
 
Registered: Mar 2010
Location: France
Distribution: Slackware
Posts: 214

Rep: Reputation: 161Reputation: 161
During the install, setup asks if you want to use UTF-8 by default during boot. Maybe you left this question.
 
Old 04-03-2016, 11:59 AM   #9
DarkVision
Member
 
Registered: Jul 2007
Posts: 189

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Thom1b View Post
During the install, setup asks if you want to use UTF-8 by default during boot. Maybe you left this question.
Ah... ok. Well.. i read the message but since the dialog said "No is the safe choice" i always choose "NO" which is the default. So it might be the safe choice but "No" is a bad choice if you will use UTF-8 later.

Thanks, problem solved
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
light glowing around Desktop Text in Menus, Window title font, application font, etc. 1sweetwater! Linux - Desktop 19 08-30-2014 01:43 PM
Emacs - changing default font size and font type? neilcpp Linux - Software 16 05-20-2013 11:29 AM
Default font does not display in applications, e.g. vlc. Shell, e.g. bash shows font jkharris SUSE / openSUSE 0 09-10-2012 10:18 AM
[SOLVED] How to change the default font-family and font-size under kde 4.8.4? kite Slackware 3 07-07-2012 11:55 AM
LXer: Oxygen Font, The New KDE Desktop Font Family, Available For Testing LXer Syndicated Linux News 0 01-06-2012 08:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration