-   Slackware (
-   -   Console Framebuffer (

darkarcon2015 07-16-2005 11:37 AM

Console Framebuffer
I am having a bit of trouble figuring out why my console, at boot, does't have the tux logo in it. Instead I get a really large font an no graphics at all. I am running the kernel and I did build support for the framebuffer. Here is a section from my .config:. Th

# Console display driver support
# CONFIG_FONTS is not set

# Logo configuration

I must have forgot something, but I don't know what. Thanks for any help.

UPDATE: I just followed what this thread said to do and everything worked out.

dcdbutler 07-16-2005 11:50 AM

looks like you compiled support for all three options of the bootup logo in menuconfig and it's defaulting to the standard black and white one. To fix this you could recompile with only the 16-colour or 224-colour options enabled, but there may be an easier fix that I don't know about.

darkarcon2015 07-16-2005 11:53 AM

Heh, I try to be safe and I still mess something up.

mdg 07-16-2005 12:12 PM

You have framebuffer support set as a module, so first check with lsmod to see if the module is loaded, but I think the problem is connected to the bootloader.

If you're using lilo, check in lilo.conf, in the global section, which line is uncommented in the " VESA framebuffer console" part. It's probably set to 640x480.

Mine is set to 1024x768x256 (vga = 773) and tux puts in an appearance at the top.

darkarcon2015 07-16-2005 12:21 PM

It's not a LILO problem because I have the tux logo appear when I boot the 2.4.29 kernel. I checked `lsmod` and I don't see framebuffer. What would I type in to get it loaded? `modprobe framebuffer` didn't work.

maginotjr 07-16-2005 01:17 PM

maybe it can help you.

darkarcon2015 07-16-2005 01:30 PM

Thanks, I'll try that.

egag 07-16-2005 02:35 PM

you must compile frame buffer support, and vesa framebuffer support,
into the kernel.
not as module.

also don't compile other fb support like ati or so.
vesa is what's used in the standard Slackware kernels.


darkarcon2015 07-16-2005 02:37 PM

Okay, I just followed what that post said and everything works now. Thanks a lot everyone.

tmantist 07-16-2005 06:24 PM

Note: You only get the pretty logo if you have the framebuffer. You won't get it if you use agpgart, also if you include support for the VGA text console your screen will be black and won't display nothing until you xserver starts(either from text mode or from entering run level 5 from an init script). Read the tips/comments you get at config time for the kernel.

I am a Jedi in training, Padwon Troye. You will register with the Linux Counter at You will give me your highend graphics card. You will clean my toilet bowl.

All times are GMT -5. The time now is 10:07 PM.