LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-24-2004, 07:16 AM   #1
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Rep: Reputation: 15
connecting to net by pppd - problems


I am using Slackware 9.1 & I have problem getting my computer configured for internet access. I have an external modem(mobile phone connected to usb port) which gets connected but I am unable to browse. I am using the following command to connect to the internet

pppd /dev/modem 115200 debug usepeerdns defaultroute connect '/usr/sbin/chat -v "" at+cta=30 OK "atdt#777" CONNECT' mtu 264

I have checked the /etc/resolv.conf also in /etc/ppp/resolv.conf and found the following entries of my isp dns no:

nameserver 202.138.103.100
nameserver 202.138.96.2

The problem is it gets connected but I am unable to browse. I did ifconfig and got the following output

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:156 errors:0 dropped:0 overruns:0 frame:0
TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11452 (11.1 Kb) TX bytes:11452 (11.1 Kb)

ppp0 Link encap:Point-to-Point Protocol
inet addr:220.226.12.75 P-t-P:97.236.2.14 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:264 Metric:1
RX packets:15 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:167 (167.0 b) TX bytes:119 (119.0 b)

I am using this ppp0 connection only, then what is this lo one?
I have connecting the same way in other distros and it gets connected, its not working in slackware only. I badly need help on this one as I have been trying this for more than an month.
I am using the following options in the etc/ppp/options file.

lock
asyncmap 0
crtscts
modem
defaultroute
usepeerdns
name soman
noauth
/dev/modem 115200

kindly help me.
 
Old 01-24-2004, 10:30 AM   #2
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
check your routes:

route -n

u should have at least one route at the bottom which looks like this:

0.0.0.0 xxx.yyy.zzz.xyz 0.0.0.0 UG 0 0 0 ppp0

ping your DNS servers to see if you can reach them.
 
Old 01-24-2004, 10:53 AM   #3
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Original Poster
Rep: Reputation: 15
pinging to the dns works, so what might be the problem?
I will check up the route one and post
 
Old 01-24-2004, 11:21 AM   #4
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Original Poster
Rep: Reputation: 15
when i did route -n i got the following

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
97.236.2.14 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 97.236.2.14 0.0.0.0 UG 0 0 0 ppp0
 
Old 01-24-2004, 02:19 PM   #5
citrus
Member
 
Registered: Dec 2003
Location: California
Distribution: Kubuntu 6.1
Posts: 548

Rep: Reputation: 30
try adding a search in your resolv.conf file

nameserver (dns)
search (dns)


this is what i just had to do on my slackware machine

it worked for me
 
Old 01-25-2004, 09:02 AM   #6
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Original Poster
Rep: Reputation: 15
i did what you said still the problem is there
What is the problem is cannot find?
 
Old 01-25-2004, 09:15 AM   #7
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
try adding your isp's domain in /etc/resolv.conf:

nameserver 202.138.103.100
nameserver 202.138.96.2
search yourisp.com
 
Old 01-25-2004, 09:48 PM   #8
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Original Poster
Rep: Reputation: 15
nope it still aint working
 
Old 01-26-2004, 03:16 AM   #9
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,882

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
Put the line for search first, then nameserver. Since you have the addresses for the nameservers you can leave out usepeerdns. For static dns /etc/ppp/resolv.conf shouldn't exist. But, if you want to use dynamic dns then leave usepeerdns in there, but you must remove etc/ppp/resolv.conf each time and make a link from /etc/resolv.conf to /etc/ppp/resolv.conf. You may also need to ping the server periodically so the connection stays up.
For usepeerdns to work, put this in /etc/ppp/ip-up:
(ping -i 60 $5 &) >/dev/null 2>&1
ln -s /etc/ppp/resolv.conf /etc/resolv.conf

and put this in /etc/ppp/ip-down:
killall ping 2>/dev/null
rm -f /etc/ppp/resolv.conf
rm -r /etc/resolv.conf

Since you know the addresses maybe it would be easiest just to run pppsetup and then connect/disconnect using the ppp-on/ppp-off scripts. It won't put the MTU references in there, but you can add them later.
If you want to use dynamic dns do a search here for dynamic dns and you'll find my script, which is an adaptation of pppsetup that will set you up for dynamic dns. Actually it would be a great help to me if you tried it, as I've been wanting to know if it works with other setups than my own.
here's the link:
http://www.linuxquestions.org/questi...ht=dynamic+dns

Last edited by gnashley; 01-26-2004 at 03:24 AM.
 
Old 01-26-2004, 08:53 AM   #10
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Original Poster
Rep: Reputation: 15
didnt work neither ur script nor the mod u told me
it gives error in the last line of the script and exits
 
Old 01-26-2004, 09:04 AM   #11
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,882

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
Try running pppsetup and then use ppp-on
You might also check your /etc/hosts file to make sure it agrees with your HOSTNAME
 
Old 01-26-2004, 09:09 AM   #12
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Original Poster
Rep: Reputation: 15
I have tried that pppsetup earlier and it dosent work either same problems.
I will check the Host file and how do i know if it agrees with my HOSTNAME?
The strange thing is this ting works in all other distros, i follow the same in slackware and it dosent work.
 
Old 01-26-2004, 03:53 PM   #13
citrus
Member
 
Registered: Dec 2003
Location: California
Distribution: Kubuntu 6.1
Posts: 548

Rep: Reputation: 30
make sure that your gateway isn't the same as your ip
it should be say if your ip is xxx.xxx.xxx.xxx then your gateway SHOULD be
xxx.xxx.xxx.1
don't quote me on this tho
this is just what i experience with my isps

i hope i am correct on this issue
to change the gateway do
# route add default gw xxx.xxx.xxx.1
 
Old 01-27-2004, 03:46 AM   #14
archish
Member
 
Registered: Apr 2003
Location: India
Distribution: Slackware 9.1
Posts: 94

Original Poster
Rep: Reputation: 15
my hostname is darkster
 
Old 01-27-2004, 08:14 PM   #15
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
can u do a dig first in the console? ie dig mail.yahoo.com if there are answers to your query, try pinging mail.yahoo.com

if you can ping it, then check your browser settings.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to run script after connecting with pppd maginotjr Linux - Networking 1 11-20-2005 08:12 AM
Problems connecting to ADSL (with pppd / pppoatm) gnirtS Linux - Networking 1 03-07-2005 05:34 AM
Problems connecting to server with debian net-install caged Debian 8 01-22-2004 09:24 PM
problems connecting the net scagman Linux - Newbie 1 07-07-2003 02:40 AM
problems on connecting to the net blackstar Linux - Newbie 2 09-20-2001 06:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration