LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-17-2005, 11:02 PM   #1
Mr. Hill
Member
 
Registered: Feb 2005
Location: Pepperland
Distribution: Arch Wombat, FreeBSD Current, OpenBSD 3.7
Posts: 238

Rep: Reputation: 30
Angry Configured my internet stuff yet it refuses to let me use the internet!


I set up all my internet stuff from the terminal. I set it as a DHCP and put in a domain name and everything. I then rebooted Slack, went in and the same thing happens. "Error loading page", and "Could not find page" are just some of my favorites. What's going on? I configured everything correctly, is Slack not seeing my network card or something? I'm typing this from Win right now, I wish I was able to type from Slack though..

Thanks for putting up with me, if I can just get this to work I'll leave you guys alone. Thanks for any help.
 
Old 02-17-2005, 11:04 PM   #2
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
What network card are you using?

You're right. I had the same problem. You need to manually load the network driver or configure it to load at startup.

If your network driver is not already there, you may have to recompile the kernel module for them
 
Old 02-17-2005, 11:11 PM   #3
Mr. Hill
Member
 
Registered: Feb 2005
Location: Pepperland
Distribution: Arch Wombat, FreeBSD Current, OpenBSD 3.7
Posts: 238

Original Poster
Rep: Reputation: 30
eep, doesn't sound too fun..

About that card type ... my dad knows that, but I'll ask him tomorrow what it is.
 
Old 02-17-2005, 11:30 PM   #4
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
why worry so much about kernel compilation? ihihih
just do it if needed...

but I have some more info for you:

disable the current interfaces such as eth0 or stuff like that (just for now)

run "adsl-setup", and follow the very well commented script

after you did that you can do these:
adsl-start (to bring up your dsl link)
adsl-status (to see how the link is)
adsl-stop (to kill the processes pppd and adsl-connect, that is, disconnect :-)

Here I assume you have an ADSL connection as mentioned in previous threads...
if everything's right, you should see the interface ppp0 up when running ifconfig...

if your link is up, try "ping www.google.com" for example and see if it responds something like this:

JOANNES=[Online]=>ping www.google.com
PING www.google.akadns.net (64.233.187.104) 56(84) bytes of data.
64 bytes from 64.233.187.104: icmp_seq=1 ttl=240 time=231 ms
64 bytes from 64.233.187.104: icmp_seq=2 ttl=240 time=231 ms
64 bytes from 64.233.187.104: icmp_seq=3 ttl=240 time=225 ms
64 bytes from 64.233.187.104: icmp_seq=4 ttl=240 time=226 ms

Last edited by JoannesX; 02-17-2005 at 11:32 PM.
 
Old 02-17-2005, 11:30 PM   #5
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
No... fun if you like compiling your custom kernels and kernel modules . Not fun if you want something to "just work". I don't think Slack is one of those distros that "just work".
 
Old 02-17-2005, 11:34 PM   #6
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
I totally agree with you: Slack is not one of those distros that "just work"
 
Old 02-17-2005, 11:45 PM   #7
Mr. Hill
Member
 
Registered: Feb 2005
Location: Pepperland
Distribution: Arch Wombat, FreeBSD Current, OpenBSD 3.7
Posts: 238

Original Poster
Rep: Reputation: 30
I know but I was getting so tired of newbie distros like RH and such. They do everything for you and that's no fun. Sounds kind of confusing but I'll try to figure this out, I'm going to just sleep on it for now ... Literally, it's kind of late.
 
Old 02-17-2005, 11:56 PM   #8
vharishankar
Senior Member
 
Registered: Dec 2003
Distribution: Debian
Posts: 3,178
Blog Entries: 4

Rep: Reputation: 138Reputation: 138
Try Debian. It's neither newbie nor totally difficult.

It has more config tools than slack, but not so many that they get in your way. You have both options.
 
Old 02-18-2005, 07:54 AM   #9
JoannesX
Member
 
Registered: Dec 2004
Location: Brazil
Distribution: Slackware
Posts: 99

Rep: Reputation: 15
not that confusing

Quote:
Sounds kind of confusing but I'll try to figure this out
it's not that hard...
see the steps:

1.disable the interfaces (ethx, pppx...)

2. adsl-setup (adjust everything)

3. adsl-start (to connect)

4 adsl-status (to see the link status: on or off)

5. adsl-stop (to disconnect)

the other parts of my previous post are just tests, they are not necessary
and I assume your IP address and net config are already set up..

Last edited by JoannesX; 02-18-2005 at 07:56 AM.
 
Old 02-18-2005, 07:58 AM   #10
K@rl`
Member
 
Registered: Feb 2004
Posts: 70

Rep: Reputation: 15
Quote:
Originally posted by JoannesX
I totally agree with you: Slack is not one of those distros that "just work"
Slackware isn't supposed to be...
 
Old 02-18-2005, 04:54 PM   #11
cavalier
Member
 
Registered: Feb 2005
Location: Denver, CO
Distribution: Slack 12, tweaked just so (though I'm also a fan of Ubuntu)
Posts: 198
Blog Entries: 1

Rep: Reputation: 30
Not a distro that 'just works'?

Funny that that's the general feeling of this thread. I came back to Slack because it did just work, where others, like Xandros OCE2 didn't. And on a laptop of all things! [Compaq PIII-1Ghz, 320/20, Cabletron Wireless card]

Though I'll probably get burned for being one of the few that it did 'just work' for, as I intend, this weekend, to install it on at least one server for the house and it'll be my first Slackware install on a desktop system since before the Great Version Inflation incident.
 
Old 02-18-2005, 05:10 PM   #12
mcd
Member
 
Registered: Aug 2003
Location: Denver, CO
Distribution: CentOS, Debian
Posts: 825

Rep: Reputation: 33
haha, i agree with the last poster. one reason i love slack is because a default install "just works". i have a dell truemobile 1150, and i've been trying to get it to work in custom kernels, so i've been doing a lot of reading up on it. everyone has problems with this card, across all the distros. in slack 10.0 it worked out of the box. and the best part about slack is that now, i'm trying to figure out why and how by compiling my own kernel. and i can get into the guts of it if i like, or not, as i choose.
 
Old 02-18-2005, 05:54 PM   #13
Mr. Hill
Member
 
Registered: Feb 2005
Location: Pepperland
Distribution: Arch Wombat, FreeBSD Current, OpenBSD 3.7
Posts: 238

Original Poster
Rep: Reputation: 30
Might be awhile before I go with Debain, if I change anything it'll probably be to FreeBSD.

OK I'll run those commands, thanks.
 
Old 02-18-2005, 06:08 PM   #14
Mr. Hill
Member
 
Registered: Feb 2005
Location: Pepperland
Distribution: Arch Wombat, FreeBSD Current, OpenBSD 3.7
Posts: 238

Original Poster
Rep: Reputation: 30
Wait.. punching in commands is just fine but how to do disable the interfaces? And do I need to disable them to get the internet to work? Furhtermore, how/do I/need to put them back on?
 
Old 02-18-2005, 06:54 PM   #15
Mr. Hill
Member
 
Registered: Feb 2005
Location: Pepperland
Distribution: Arch Wombat, FreeBSD Current, OpenBSD 3.7
Posts: 238

Original Poster
Rep: Reputation: 30
I don't know how I did it, but I typing from Slack right now. Guess I just needed to reboot my computer for the settings to go through.

Thanks for the help on the config.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo refuses to connect to internet adamb10 Linux - Networking 5 04-07-2005 09:51 AM
how do i connect to the internet and mount stuff? vajeeh Linux - Newbie 4 01-23-2004 07:14 AM
I think I've configured everything right, but I still can't connect to the Internet Travis86 Linux - Networking 4 12-18-2003 12:11 PM
Mandrake 8.0 actively refuses internet connection Chooco Linux - Networking 0 05-29-2002 11:57 PM
Linux refuses to send packets via Internet tungro Linux - Newbie 11 02-27-2002 02:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration