LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Concerning ALSA and recompiled kernel (https://www.linuxquestions.org/questions/slackware-14/concerning-alsa-and-recompiled-kernel-150295/)

nvn 02-25-2004 06:54 AM

Concerning ALSA and recompiled kernel
 
I was running -current and figured I'd like to get a 2.4.25 kernel, so I got the source from kernel.org and went on to compile. To test things a bit I used the .config from kernel-ide-2.4.24, and only changed a few things (P4 architecture, highmem support, and stuff like that). I didn't bother to remove all unneeded modules - I'll strip the kernel soon enough.

Anyway; after the reboot, ALSA was lost (as I expected). Previously I've been able to remedy this simply by reinstalling ALSA (just installpkg). This time, however, that didn't work. Very odd; alsaconf failed to find any of my soundcards, and alsamixer didn't even run (alsamixer: function snd_ctl_open failed for default: No such file or directory). Seems like the modules just weren't there. To get ALSA up and running again I compiled it from source, and now everything seems to work just the way it should.

I just wonder what happened? :) How come reinstalling the ALSA packages didn't solve the problem? I really like my system, but somehow Slackware 9.1 feels a bit obscure compared to, say, 8.1. By no means I consider myself a Linux expert, but usually I can figure out why certain problems arise and how to solve them...but this one has me stumped. Anyone care to enlighten me? :)

Kovacs 02-25-2004 07:06 AM

Nice signature.

320mb 02-25-2004 07:10 AM

re-compile the kernel with sound support built in, and all the alsa packages built as modules............

davidsrsb 02-25-2004 07:32 AM

Are you running the latest alsa-driver, 1.0.2c-i486-2.tgz? Before I updated, the stock 2.4.25 kernel did not detect my SB Live.

nvn 02-25-2004 08:41 AM

Quote:

Originally posted by Kovacs
Nice signature.
Isn't it? :)

Quote:

Originally posted by 320mb
re-compile the kernel with sound support built in, and all the alsa packages built as modules............
This is kinda the strange thing. I didn't change anything in the sound configuration of the kernel - I left it just the way it was in the kernel-ide-2.4.24 .config (a so to speak "official" configuration), with which ALSA worked flawlessly. If it works with a .config in 2.4.24, shouldn't it work with the same .config in 2.4.25?

Quote:

Originally posted by davidsrsb
Are you running the latest alsa-driver, 1.0.2c-i486-2.tgz? Before I updated, the stock 2.4.25 kernel did not detect my SB Live.
Yes, I was using that and the other ALSA packages from -current, and there were no problems at all when running 2.4.24. For some reason they didn't work at all after I compiled the 2.4.25. Since compiling ALSA from source solved the problem, one can probably conclude that there's nothing wrong with the kernel configuration (and there shouldn't be :)). And since the ALSA packages worked with 2.4.24, there shouldn't be anything wrong with those either. Very odd indeed. Feels like stuff is happening behind my back. :(


Thanks for the replies, guys.

marcelocp 02-25-2004 04:51 PM

This is likely to be because the alsa packega that you tried to install contains kernel modules for your old kernel version, not for 2.4.25

Kernel modules are almost always version-dependent. If you take a look at /lib/modules you might have two directorie, one for the older version, the other for 2.4.25. When you boot 2.4.25, the modules are searched inside that directory.

When I last upgraded my kernel from 2.4.22 to 2.4.24, I even tried copying the alsa modules from the 2.4.22 to the 2.4.24 dir, but that did not work either exactly because of the internal version mismatch between modules and kernel.

Just my 2 cents.

nvn 02-25-2004 05:27 PM

Ah...sounds likely. On closer inspection of my kernel configuration, it seems that I left the "Set version information on all module symbols" in the "Loadable module support" section at "no". I guess saying "yes" to this option would have spared me some confusion? Oh well. Thanks for replying, I'll go rtfm a bit on this. :)


All times are GMT -5. The time now is 03:11 AM.