-   Slackware (
-   -   computer crashes while compiling (

thrice 01-02-2004 07:18 AM

computer crashes while compiling
a little while ago after leaving my computer to compile a new kernel, i came back and my computer was off. i tried turning it back on, but it wouldn't come back on until i held down the power button for 4 seconds then tried turning it on again. the compilation seemed to turn out alright because i'm using it now. But while compiling wine, after about 15 minutes it does the same thing. i have no clue what the problem is. i'm running slack 9.1 upgraded from 9.0 and using a custom kernel. i'd really appreciate any help you all can give me. i'm totally stumped. thanks in advance

jharris 01-02-2004 07:31 AM

Have you checked how hot your cpu is getting? gcc seems to be really hard on the system, which shows any weakness in the hardware. I've had boxes that run fine until you try to compile things and then show cpu/memory problems. Just a thought...

Also, I've noticed that the change from gcc 3.2 to gcc 3.3 (slack 9->9.1) seems to have broken many programs. I'm still looking for a way to work around this, I imagine there is a flag that can be set, I've just go no idea what it is!



Kovacs 01-02-2004 07:40 AM

I have had a similar problem on my old pc. I was compiling fluxbox and it seemed to take an abnormally long time and the mouse started freaking out (the pointer blinking on and off and not moving). I started fluxbox after it was compiled and thought "well this sucks" because it was totally buggy with massive graphic bugs. Well it wasn't fluxbox at all - about 15 seconds later the pc just died, no signal to the monitor, cdrom drawer wouldn't shut, etc - fried motherboard. A real pain in the ass at the time but at least it was motivation to get a nice new pc. :)

poison 01-02-2004 08:06 AM
not exactly the same, but I guess it's the right direction ^^
probably some problem with your hardware...

jharris 01-02-2004 08:15 AM


love your 'Location' :)


oneandoneis2 01-02-2004 08:55 AM

Cheers for that link, Poison - I've been trying to work out why Xwindows keeps crashing on my box.

I'm guessing that, since it was the X series off the latest Slackware CD, the software is fine and it's a hardware problem.

Yet ANOTHER excuse for buying that new pooter I've been contemplating :)

Tho that X/AMD incompatibility thing mentioned halfway down looks worth a try..

thrice 01-02-2004 04:59 PM

yup you were right about the cpu temperature thing jharris. i had thought about it but didn't get around to testing it out till just a few mins ago. i applied some new thermal compound, dissassembled my fan/heatsink and got rid of the chunks 'o dust, and now its working without a hitch. thanks a lot everyone for the quick replies (i got two within 15 mins of posting at like 6:30 am!)

All times are GMT -5. The time now is 02:38 PM.