LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   compiz and Slack 12? (https://www.linuxquestions.org/questions/slackware-14/compiz-and-slack-12-a-566969/)

ramskens 11-01-2007 09:55 PM

Quote:

Originally Posted by urka58 (Post 2944312)
So.. you have to install a window decorator (emerald, kde-window-decorator), otherwise no chances you can get compiz working.
Have you installed all packages I listed ?
If you don't like emerald, install at least kde-window-decorator and replace it into the script.
Your xorg.conf file looks fine, just try removing the line
Option "TripleBuffer" "true"
if your video card has less than 128 MB memory
Ciao

but.. my compiz works..with the title bars and everything, it works perfectly, till it hangs, total hang.

And, i have an nvidia 7300le, wich comes with 256mb, so i shouldn't remove that line?

composite works ok with the stock x11?, i didn't update that...

pappy_mcfae 11-12-2007 02:48 AM

I'm writing this as much to get a subscription link to this thread as I am to say that I finally have compiz working...at least on my new laptop. I am going to do some playing on my other laptop to see what really makes things work as opposed to theories without foundation.

Thanks to all those whose suggestions have brought me to functionality. As soon as I figure out exactly what got me working, I'll be sure to share it with everyone here.

EDIT:The other laptop is now running with compiz. I am using it right now, as a matter of fact. In getting to the point where I could get things working properly, I discovered something really interesting.

If you have added the following lines to your /etc/X11/xorg.conf file,
Code:


Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"

...and you are still coming up with the "No GLXFBConfig..." error, and you have been using a custom kernel, you need to make sure that you change your option under
Code:

Character devices->Direct Rendering Manager-><your_driver>.
Make sure those drivers are set up as modules. If they are compiled directly into the kernel, you will get the error.

Hope that helps some people. It helped me!

Blessed be!
Pappy

pappy_mcfae 11-15-2007 03:26 AM

Quote:

Originally Posted by Nikosis (Post 2832006)
It works Thanks, wow that was easy, can you tell me why it does't work on root
Thx

Compiz does, in fact, work for root users. I am one, and have been for some time now. I have compiz up and running on two laptops. I am root on both. They are both currently operating, running Slackware 12 and the version of compiz that came with it.

Of course, "work" is a relative term when it comes to compiz. It's clear there are some bugs in compiz, some pretty irritating ones. I get most of what I want to happen, and I can turn compiz on and off at will with two scripts I wrote specifically for that purpose. It was truly worth the time it took to get compiz up and running. The desktop cube is the coolest thing in the world!

Blessed be!
Pappy


All times are GMT -5. The time now is 07:05 AM.