LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   compiz and Slack 12? (https://www.linuxquestions.org/questions/slackware-14/compiz-and-slack-12-a-566969/)

T3slider 09-02-2007 11:48 PM

To stop compiz once it's started, type
Code:

$ kwin --replace &
to return KDE to normal.

If you can't enter text in a console (this has happened to me -- if compiz screws up the window decorations upon starting it, sometimes Konsole or other terminals can't get focus) switch to another terminal (if you're using runlevel 3 -- I'm unfamiliar with the terminal setup in runlevel 4), login and enter
Code:

$ DISPLAY=:0.0 kwin --replace &
and that should do the trick (note that if you're doing something odd with X your display may not be 0.0 -- change this accordingly).

To solve this problem you must type
Code:

$ kde-window-decorator &
after starting compiz to get the titlebar etc. back (although this doesn't work 100% of the time for me for some reason -- you may have to play around and start compiz and attempt to use "kde-window-decorator &" to replace the titlebars a few times, use "kwin --replace &" to return to normal and try again. You may also have to restart X if something really screws up).

Overall I've found compiz to be a real pain to set up, but once it's running it does it's job (although if I switch to another terminal and switch back X is rendered unusable and I have to issue "kwin --replace" from another terminal to restore the X session).

Hope that helps -- if not, sorry.

Tux-Slack 09-03-2007 03:42 AM

Quote:

Originally Posted by T3slider (Post 2879224)
Tux-Slack, instead of using
Code:

$ compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom kde-window-decorator &
you should use the following (two DIFFERENT commands):
Code:

$ compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
$ kde-window-decorator &

That should work (after some playing). For some reason compiz doesn't always work the first time for me using the exact same commands, but once you get it running properly it automatically starts upon each KDE session.

BCarey, the pager problem is a KDE bug. There's an attempt at fixing this problem from http://www.kde-apps.org/content/show.php?content=46021 but it is too buggy for me. I personally just start compiz using the "--ignore-desktop-hints" switch (use that switch before the "--replace xxx yyy ..." stuff) and it solves the problem well enough for me (although you can no longer 'Send to desktop x' using that switch -- however, you can drag windows along the cube to another desktop).

Nope, not working:
Code:

compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0


T3slider 09-03-2007 12:49 PM

What is the output of
Code:

glxinfo | grep direct
It looks like you may not have direct rendering properly enabled (although I may be wrong). What video card do you have? If it's ATI you may have to do some fiddling to get dri working. If it's an nVidia card, you'll have to download and install the nVidia drivers.

Dri is enabled in /etc/X11/xorg.conf, so you may have to manually adjust that. There are several other threads on getting dri to work if that is the problem (it may not be).

T3slider 09-04-2007 10:36 PM

I've just (finally) solved all of my compiz problems by installing CCSM, the CompizConfig Settings Manager. I didn't want to install gconf so it took a little while to get things done. The documentation is incredibly crappy and that's why it's taken me so long to actually figure anything out. I upgraded my compiz to the new compiz fusion using packages from here: http://releases.compiz-fusion.org/0.5.2/

I made SlackBuilds for all of it (but I think slacky.eu has slackbuilds for everything also). Install in the following order:

compiz/compiz-0.5.2
libcompizconfig-0.5.2
compiz-bcop-0.5.2
compiz-fusion-plugins-main-0.5.2
compiz-fusion-plugins-extra-0.5.2
compiz-fusion-plugins-unsupported-0.5.2
compizconfig-python-0.5.2
ccsm-0.5.2

I was missing ccsm when I tried before and the ini backend made it very difficult to configure since the plugins had to be in a very specific (and undocumented) order.

Note that for ccsm you need pygobject, pycairo, pygtk and Pyrex (you should install them in that order). There are SlackBuilds for all of those except Pyrex at slackbuilds.org. I made a slackbuild for Pyrex but there is one at slacky.eu.

Then, to start compiz, use the following:
Code:

compiz --ignore-desktop-hints --replace ccp &
The --ignore-desktop-hints is there to avoid the mess that is KDE's pager when working with compiz (you lose some functionality here though -- you can no longer send to a specific desktop [you must drag it instead or use one of the compiz plugins] and applications from ALL desktops [or viewports I guess] are shown on the taskbar). If you lose your title bars and such, type the following:
Code:

kde-window-decorator &
Then open ccsm (it was automatically placed in "K>Settings>CompizConfig Settings Manager" for me, but you can open it from a console by typing "ccsm &").

Play around with all the pretty plugins. The only thing missing from this setup is the 3D plugin which allows the windows to pop off the desktop when rotating. That plugin is apparently being rewritten and is therefore absent from this release. I hope your experiences with compiz are better than mine. :)

1337ln 09-06-2007 10:13 PM

ugh, I have the latest Nvidia driver for my card (Nvidia GeForce2 MX400) and nothing I try here helps, I end up losing window borders and having no effects from Compiz. I am running Slackware 12 and haven't added anything to the means of Compiz just yet, but will if I have to (I hate tainting Slackware =/)

anyway glxgears | grep direct tells me I have direct rendering enabled and my device section of xorg.conf looks like...

Code:

Section "Device"
    Identifier    "Nvidia GeForce2 MX400"
    Driver        "nvidia"
    Option        "AddARGBGLXVisuals"  "true"
    Option        "TripleBuffer"      "true"
EndSection

and the command I'm running looks like
Code:

$ compiz --replace decoration wobbly fade minimize cube move place resize rotate scale switcher water zoom &
$ kde-window-decorator &

and the crap its giving me looks like
Code:

compiz: Another window manager is already running on screen: 0
compiz: No manageable screens found on display :0

i just reset the DISPLAY variable to get borders back like so
Code:

DISPLAY=:0.0 kwin --replace
anyway, any help is great help at this point
thanks a bunchh

T3slider 09-07-2007 12:58 PM

I don't have any concrete advise to give you, but I will say that compiz definitely requires some trial and error and a lot of repetition to get it working. I would recommend restarting your PC and trying again, restarting X, etc. (I don't know if you already tried this multiple times). For some reason the same command works sometimes and not others with compiz (however, once it is set up it basically works permanently). I got compiz working with the stock Slackware 12.0 package using those exact commands with an nVidia card so I know it is possible.

I know for a fact that I have received that exact error message before (when I was still fiddling with compiz), but it just kind of works with a bit of repetition. But then again maybe there is a bigger problem in your case (ie you will have to wait for someone more knowledgeable than I).

1337ln 09-11-2007 09:46 PM

I got it working with help from here
http://slackwiki.org/Compiz

I honestly would be lost without this site.

KhaoSlacker 09-13-2007 12:23 AM

*thanks 1337ln for plugging my slackwiki contribution before I could*

Guys, if anyone figures out how to do something, anything. and there isn't already a wiki about it. Please make one.

T3slider 09-14-2007 07:46 PM

By the way, if you compile compiz fusion like I did, you can get the 3D window effect to work by downloading the proper plugin and compiling it yourself. You CANNOT use the new (rewritten) plugin with compiz-0.5.2 (they moved some files around and modified some of the properties of the include files between 0.5.2 and 0.5.4 preventing the newer 3D windows plugin from compiling).

To do this (if you so wish) download the 3d file from here: http://gitweb.compiz-fusion.org/?p=f...s/3d;a=summary

Make sure you get the one from 2007-08-06 -- the other ones don't work with 0.5.2.

I installed it a while ago, so I don't remember the install process perfectly, but I think you just type
Code:

$ make
$ make install

as a normal user (it installs into ~/.compiz/plugins unless you edit the Makefile to install it somewhere else).

ramskens 10-21-2007 04:44 PM

Quote:

Originally Posted by T3slider (Post 2881500)
I've just (finally) solved all of my compiz problems by installing CCSM, the CompizConfig Settings Manager. I didn't want to install gconf so it took a little while to get things done. The documentation is incredibly crappy and that's why it's taken me so long to actually figure anything out. I upgraded my compiz to the new compiz fusion using packages from here:

I made SlackBuilds for all of it (but I think slacky.eu has slackbuilds for everything also). Install in the following order:

compiz/compiz-0.5.2
libcompizconfig-0.5.2
compiz-bcop-0.5.2
compiz-fusion-plugins-main-0.5.2
compiz-fusion-plugins-extra-0.5.2
compiz-fusion-plugins-unsupported-0.5.2
compizconfig-python-0.5.2
ccsm-0.5.2

I was missing ccsm when I tried before and the ini backend made it very difficult to configure since the plugins had to be in a very specific (and undocumented) order.

Note that for ccsm you need pygobject, pycairo, pygtk and Pyrex (you should install them in that order). There are SlackBuilds for all of those except Pyrex at slackbuilds.org. I made a slackbuild for Pyrex but there is one at slacky.eu.

Then, to start compiz, use the following:
Code:

compiz --ignore-desktop-hints --replace ccp &
The --ignore-desktop-hints is there to avoid the mess that is KDE's pager when working with compiz (you lose some functionality here though -- you can no longer send to a specific desktop [you must drag it instead or use one of the compiz plugins] and applications from ALL desktops [or viewports I guess] are shown on the taskbar). If you lose your title bars and such, type the following:
Code:

kde-window-decorator &
Then open ccsm (it was automatically placed in "K>Settings>CompizConfig Settings Manager" for me, but you can open it from a console by typing "ccsm &").

Play around with all the pretty plugins. The only thing missing from this setup is the 3D plugin which allows the windows to pop off the desktop when rotating. That plugin is apparently being rewritten and is therefore absent from this release. I hope your experiences with compiz are better than mine. :)

Hi, i've been trying to install compiz, and followed your advice. But i have a question, how did you to install the first package, compiz-0.5.2 without installing gconf? when i do the "configure" to install compiz-0.5.2 it stops there.
Thanks

zytsef 10-26-2007 12:04 AM

EDIT: Nevermind. That's what I get for posting before before I check my spelling.

I'm a bit new to compiz and still trying to get a handle on it. I'm losing when it comes to kde-window-decorator. When I try to start it after switching to compiz, I get this:
Code:

$ kde-window-decorator &
 kde-window-decorator: Could not acquire decoration manager selection on screen 0 display ":0.0"

Any clues as to what's going on here? I'd sort of like my window decoration back.

Thanks a bunch.

urka58 10-26-2007 10:59 AM

Stock Compiz coming with Slackware 12 is not very effiecient and almost impossible to configure.
I'd strongly suggest you update to 0.5.2 with this packages (compiz-fusion)
http://www.slacky.eu/repository/slac...-fusion/0.5.2/
and these dependacies (also available @slacky.eu site) or here
http://dagmar.droplinegnome.org/2.18/
libsexy-0.1.11-i686-4as.tgz (optional , but better if installed)
libwnck-2.18.3-i486-1sl.tgz
pycairo-1.4.0-i686-4as.tgz
pygobject-2.12.3-i486-1sl.tgz
pygtk-2.10.6-i486-1sl.tgz
sexy-python-0.1.9-i686-4as.tgz (same as libsexy)
PLEASE NOTE:Compiz-0.5.0 must be unistalled first.
Once everything's installed use the following scripts to start/stop compiz and windows decorators

Start compiz+emerald
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi


Start compiz+kde-window-decorator
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/kde-window-decorator --replace &
else
/usr/bin/kde-window-decorator --replace &
fi


Stop everything (back to KDE)
#!/bin/sh
killall -9 compiz && /usr/bin/kwin --replace &



Xorg configuration file must be set accordingly to your video card (Nvidia, ATI prop, ATI open...)

Mine... on an Nvidia FX 5200 has these options enabled

Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"

Section "Extensions"
Option "Composite" "Enable"
EndSection

Hope this helps
Ciao

trebek 10-26-2007 08:42 PM

Where to these scripts go??
 
Quote:

Originally Posted by urka58 (Post 2937782)
............

Start compiz+emerald
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi


Start compiz+kde-window-decorator
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/kde-window-decorator --replace &
else
/usr/bin/kde-window-decorator --replace &
fi


Stop everything (back to KDE)
#!/bin/sh
killall -9 compiz && /usr/bin/kwin --replace &



................
Ciao

Hi there man, i am following your post here to get compiz working. Like you said, stock compiz gave a lot of problems, one that i couldn't fix (the no window borders problem), so i decided it was time to upgrade and here i am. The only thing i need to know here is where do i put these 3 scripts you mention here?

Thanks for the aid.

urka58 10-27-2007 06:29 AM

So..you have many options. I'd say they should go in /usr/local/bin in order they are in your PATH.
Sorry, I don't know your level of skill, so I'm going to start from the very beginning...
- Copy the script compiz+emerald into your favourite text editor (ie Kwrite) and save as compiz_emerald
- Give execution perm to the file just saved by "chmod a+x compiz_emerald"
- su as root and change owner to compiz_emerald by "chown root:root compiz_emerald"
- stay root and move compiz_emerald to /usr/local/bin by "mv compiz_emerald /usr/local/bin"
Do the same for the remaining two scripts

Once done launch the script in a Virtual Terminal (ie Konsole).
If you like you can also add the scripts to your Kmenu and launch them from there..
Hope this helps
Ciao

PS: Compiz is a little tricky, so if you want to avoid to be started with KDE just do this:
Launch a session of kde with all programs you want to be started with (ie Kmix, Karamba...) but compiz.
Go to Control Center -> Kde Components -> Session manager -> Restore manually saved session.
From Kmenu - > save session.
This avoid compiz to be started when you lanch KDE

mRgOBLIN 10-27-2007 07:24 AM

if you are runlevel 4 then you can also use "~/.xprofile"

Oh and a little tip so you don't have to jump through sed hoops...

Code:

ps ax |grep "[c]ompiz"


All times are GMT -5. The time now is 03:52 AM.