LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   compiz and Slack 12? (https://www.linuxquestions.org/questions/slackware-14/compiz-and-slack-12-a-566969/)

T3slider 09-07-2007 12:58 PM

I don't have any concrete advise to give you, but I will say that compiz definitely requires some trial and error and a lot of repetition to get it working. I would recommend restarting your PC and trying again, restarting X, etc. (I don't know if you already tried this multiple times). For some reason the same command works sometimes and not others with compiz (however, once it is set up it basically works permanently). I got compiz working with the stock Slackware 12.0 package using those exact commands with an nVidia card so I know it is possible.

I know for a fact that I have received that exact error message before (when I was still fiddling with compiz), but it just kind of works with a bit of repetition. But then again maybe there is a bigger problem in your case (ie you will have to wait for someone more knowledgeable than I).

1337ln 09-11-2007 09:46 PM

I got it working with help from here
http://slackwiki.org/Compiz

I honestly would be lost without this site.

KhaoSlacker 09-13-2007 12:23 AM

*thanks 1337ln for plugging my slackwiki contribution before I could*

Guys, if anyone figures out how to do something, anything. and there isn't already a wiki about it. Please make one.

T3slider 09-14-2007 07:46 PM

By the way, if you compile compiz fusion like I did, you can get the 3D window effect to work by downloading the proper plugin and compiling it yourself. You CANNOT use the new (rewritten) plugin with compiz-0.5.2 (they moved some files around and modified some of the properties of the include files between 0.5.2 and 0.5.4 preventing the newer 3D windows plugin from compiling).

To do this (if you so wish) download the 3d file from here: http://gitweb.compiz-fusion.org/?p=f...s/3d;a=summary

Make sure you get the one from 2007-08-06 -- the other ones don't work with 0.5.2.

I installed it a while ago, so I don't remember the install process perfectly, but I think you just type
Code:

$ make
$ make install

as a normal user (it installs into ~/.compiz/plugins unless you edit the Makefile to install it somewhere else).

ramskens 10-21-2007 04:44 PM

Quote:

Originally Posted by T3slider (Post 2881500)
I've just (finally) solved all of my compiz problems by installing CCSM, the CompizConfig Settings Manager. I didn't want to install gconf so it took a little while to get things done. The documentation is incredibly crappy and that's why it's taken me so long to actually figure anything out. I upgraded my compiz to the new compiz fusion using packages from here:

I made SlackBuilds for all of it (but I think slacky.eu has slackbuilds for everything also). Install in the following order:

compiz/compiz-0.5.2
libcompizconfig-0.5.2
compiz-bcop-0.5.2
compiz-fusion-plugins-main-0.5.2
compiz-fusion-plugins-extra-0.5.2
compiz-fusion-plugins-unsupported-0.5.2
compizconfig-python-0.5.2
ccsm-0.5.2

I was missing ccsm when I tried before and the ini backend made it very difficult to configure since the plugins had to be in a very specific (and undocumented) order.

Note that for ccsm you need pygobject, pycairo, pygtk and Pyrex (you should install them in that order). There are SlackBuilds for all of those except Pyrex at slackbuilds.org. I made a slackbuild for Pyrex but there is one at slacky.eu.

Then, to start compiz, use the following:
Code:

compiz --ignore-desktop-hints --replace ccp &
The --ignore-desktop-hints is there to avoid the mess that is KDE's pager when working with compiz (you lose some functionality here though -- you can no longer send to a specific desktop [you must drag it instead or use one of the compiz plugins] and applications from ALL desktops [or viewports I guess] are shown on the taskbar). If you lose your title bars and such, type the following:
Code:

kde-window-decorator &
Then open ccsm (it was automatically placed in "K>Settings>CompizConfig Settings Manager" for me, but you can open it from a console by typing "ccsm &").

Play around with all the pretty plugins. The only thing missing from this setup is the 3D plugin which allows the windows to pop off the desktop when rotating. That plugin is apparently being rewritten and is therefore absent from this release. I hope your experiences with compiz are better than mine. :)

Hi, i've been trying to install compiz, and followed your advice. But i have a question, how did you to install the first package, compiz-0.5.2 without installing gconf? when i do the "configure" to install compiz-0.5.2 it stops there.
Thanks

zytsef 10-26-2007 12:04 AM

EDIT: Nevermind. That's what I get for posting before before I check my spelling.

I'm a bit new to compiz and still trying to get a handle on it. I'm losing when it comes to kde-window-decorator. When I try to start it after switching to compiz, I get this:
Code:

$ kde-window-decorator &
 kde-window-decorator: Could not acquire decoration manager selection on screen 0 display ":0.0"

Any clues as to what's going on here? I'd sort of like my window decoration back.

Thanks a bunch.

urka58 10-26-2007 10:59 AM

Stock Compiz coming with Slackware 12 is not very effiecient and almost impossible to configure.
I'd strongly suggest you update to 0.5.2 with this packages (compiz-fusion)
http://www.slacky.eu/repository/slac...-fusion/0.5.2/
and these dependacies (also available @slacky.eu site) or here
http://dagmar.droplinegnome.org/2.18/
libsexy-0.1.11-i686-4as.tgz (optional , but better if installed)
libwnck-2.18.3-i486-1sl.tgz
pycairo-1.4.0-i686-4as.tgz
pygobject-2.12.3-i486-1sl.tgz
pygtk-2.10.6-i486-1sl.tgz
sexy-python-0.1.9-i686-4as.tgz (same as libsexy)
PLEASE NOTE:Compiz-0.5.0 must be unistalled first.
Once everything's installed use the following scripts to start/stop compiz and windows decorators

Start compiz+emerald
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi


Start compiz+kde-window-decorator
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/kde-window-decorator --replace &
else
/usr/bin/kde-window-decorator --replace &
fi


Stop everything (back to KDE)
#!/bin/sh
killall -9 compiz && /usr/bin/kwin --replace &



Xorg configuration file must be set accordingly to your video card (Nvidia, ATI prop, ATI open...)

Mine... on an Nvidia FX 5200 has these options enabled

Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"

Section "Extensions"
Option "Composite" "Enable"
EndSection

Hope this helps
Ciao

trebek 10-26-2007 08:42 PM

Where to these scripts go??
 
Quote:

Originally Posted by urka58 (Post 2937782)
............

Start compiz+emerald
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi


Start compiz+kde-window-decorator
#!/bin/sh
if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/kde-window-decorator --replace &
else
/usr/bin/kde-window-decorator --replace &
fi


Stop everything (back to KDE)
#!/bin/sh
killall -9 compiz && /usr/bin/kwin --replace &



................
Ciao

Hi there man, i am following your post here to get compiz working. Like you said, stock compiz gave a lot of problems, one that i couldn't fix (the no window borders problem), so i decided it was time to upgrade and here i am. The only thing i need to know here is where do i put these 3 scripts you mention here?

Thanks for the aid.

urka58 10-27-2007 06:29 AM

So..you have many options. I'd say they should go in /usr/local/bin in order they are in your PATH.
Sorry, I don't know your level of skill, so I'm going to start from the very beginning...
- Copy the script compiz+emerald into your favourite text editor (ie Kwrite) and save as compiz_emerald
- Give execution perm to the file just saved by "chmod a+x compiz_emerald"
- su as root and change owner to compiz_emerald by "chown root:root compiz_emerald"
- stay root and move compiz_emerald to /usr/local/bin by "mv compiz_emerald /usr/local/bin"
Do the same for the remaining two scripts

Once done launch the script in a Virtual Terminal (ie Konsole).
If you like you can also add the scripts to your Kmenu and launch them from there..
Hope this helps
Ciao

PS: Compiz is a little tricky, so if you want to avoid to be started with KDE just do this:
Launch a session of kde with all programs you want to be started with (ie Kmix, Karamba...) but compiz.
Go to Control Center -> Kde Components -> Session manager -> Restore manually saved session.
From Kmenu - > save session.
This avoid compiz to be started when you lanch KDE

mRgOBLIN 10-27-2007 07:24 AM

if you are runlevel 4 then you can also use "~/.xprofile"

Oh and a little tip so you don't have to jump through sed hoops...

Code:

ps ax |grep "[c]ompiz"

urka58 10-27-2007 08:46 AM

Quote:

Originally Posted by mRgOBLIN (Post 2938611)
if you are runlevel 4 then you can also use "~/.xprofile"

Oh and a little tip so you don't have to jump through sed hoops...

Code:

ps ax |grep "[c]ompiz"

Nice tip, it works perfectly well, but you woken up my curiosity, how ?
Ciao

trebek 10-27-2007 10:15 AM

Quote:

Originally Posted by urka58 (Post 2938568)
So..you have many options. I'd say they should go in /usr/local/bin in order they are in your PATH.
Sorry, I don't know your level of skill, so I'm going to start from the very beginning...
- Copy the script compiz+emerald into your favourite text editor (ie Kwrite) and save as compiz_emerald
- Give execution perm to the file just saved by "chmod a+x compiz_emerald"
- su as root and change owner to compiz_emerald by "chown root:root compiz_emerald"
- stay root and move compiz_emerald to /usr/local/bin by "mv compiz_emerald /usr/local/bin"
Do the same for the remaining two scripts

Once done launch the script in a Virtual Terminal (ie Konsole).
If you like you can also add the scripts to your Kmenu and launch them from there..
Hope this helps
Ciao

PS: Compiz is a little tricky, so if you want to avoid to be started with KDE just do this:
Launch a session of kde with all programs you want to be started with (ie Kmix, Karamba...) but compiz.
Go to Control Center -> Kde Components -> Session manager -> Restore manually saved session.
From Kmenu - > save session.
This avoid compiz to be started when you lanch KDE

Thanks a lot. I also read somewhere that in order for compiz to be loaded during kde launch, i should be putting some scripts in .kde directory, should i remove them from there? I created them when attempting another manual before the one you suggested.

urka58 10-27-2007 04:03 PM

Is up to you...
Remove the old script from ~/user/.kde/Autostart as I beleive it won't work.
I'd suggest you run the script starting compiz (ie compiz_emerald) manually for a while. Once you see it works properly you can put it to ~/user/.kde/Autostart in order you get it started automatically.
Ciao

trebek 10-27-2007 04:09 PM

I got twinview working here, two monitors connected to the same card. I set up compiz and once i start it, i get a really weird desktop. I get the first screen normally with all the gadgets, but the second screen has a blank page like 3/4's across and the last quarter in black, at the end having like the start of the side face of the cube.

So, my question here is, is there another set of configuration lines i need to add to my xorg.conf file so that compiz works with two screens? Here's an output of the device section of my xorg.conf file so that you can have a clearer idea of what i mean.

Section "Device"
Identifier "VESA Framebuffer"
Driver "nvidia"
Option "TwinView"
Option "MetaModes" "1600x1200"
Option "TwinViewOrientation" "RigtOf"
Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"
#VideoRam 4096
# Insert Clocks lines here if appropriate
EndSection

mRgOBLIN 10-27-2007 04:57 PM

Quote:

Originally Posted by urka58 (Post 2938678)
Nice tip, it works perfectly well, but you woken up my curiosity, how ?
Ciao

because ps doesn't do the shell expansion before displaying the command and displays it as you type it.

Look here.

Code:

mrgoblin@sonic:~> ps ax |grep "[g]rep"                     
17254 pts/8    S+    0:00 grep [g]rep


urka58 10-28-2007 06:12 AM

It took me a while to understand, but at last I got it ...I believe
Thank you
Ciao

ramskens 10-28-2007 01:41 PM

to install compiz-fusion 0.5.2 do i have to install gconf?, is any way to avoid that?

ramskens 10-28-2007 01:52 PM

to install compiz-fusion 0.5.2 do i have to install gconf?
and other question, i read that to install a new version of compiz i have to uninstall the old one (the one that came with slack 12), but, how do i do this?

SqdnGuns 10-28-2007 04:24 PM

Quote:

Originally Posted by ramskens (Post 2940014)
to install compiz-fusion 0.5.2 do i have to install gconf?
and other question, i read that to install a new version of compiz i have to uninstall the old one (the one that came with slack 12), but, how do i do this?

Run pkgtool and select compiz.

Sounds like you need to do some research on Slackware, it will pay off for you in the long run.

urka58 10-29-2007 01:03 PM

No, gconf is not required at all. The package from slacky.eu is compiled without gconf support.
Ciao

ramskens 10-30-2007 09:03 PM

ok, thanks, i have already installed the compiz 0.5.2 and fusion and the other stuff with the package of slacky.
But i still have the same problem before. After a while, and for no reason particurally (i dont know how does that word write, im from argentina..), the system hangs, its not a problem of hardware because before i enable composite that never happens. When i dont call compiz (i mean,, composite enable, but i dont activate "compiz -replace bla bla bla"), it takes a lot more to hang,, but, eventually it does...
Any suggestion?
And thanks for the previous answers

trebek 10-31-2007 02:56 PM

QUESTION!!!

Does anybody know why konqueror would not open when compiz is running? It hasn't opened since i enabled compiz. Every other application opens up just fine. When trying to open konqueror, be it home folder, the trash or konqueror itself, i just get the bouncy icon for like 20 seconds but nothing shows up. By the way, where would the error messages for this problem be in /var/log (dmesg, syslog)?

Thanks for the help.

urka58 10-31-2007 05:27 PM

Quote:

Originally Posted by ramskens (Post 2942915)
ok, thanks, i have already installed the compiz 0.5.2 and fusion and the other stuff with the package of slacky.
But i still have the same problem before. After a while, and for no reason particurally (i dont know how does that word write, im from argentina..), the system hangs, its not a problem of hardware because before i enable composite that never happens. When i dont call compiz (i mean,, composite enable, but i dont activate "compiz -replace bla bla bla"), it takes a lot more to hang,, but, eventually it does...
Any suggestion?
And thanks for the previous answers

Try editing the startup script this way

Start compiz+emerald

#!/bin/sh

export LIBGL_ALWAYS_INDIRECT=1 # add this

if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi

Hope this helps
Ciao

ramskens 10-31-2007 10:42 PM

Try editing the startup script this way

Start compiz+emerald

#!/bin/sh

export LIBGL_ALWAYS_INDIRECT=1 # add this

if ! ps ax | sed '/grep/ d' | grep compiz 1> /dev/null 2> /dev/null ; then
/usr/bin/compiz --replace ccp &
/usr/bin/emerald --replace &
else
/usr/bin/emerald --replace &
fi

Hope this helps
Ciao

------------------------
well... it didnt work. the truth, i installed compiz0.5.2 with fusion, so i dont have emerald. The other thing,,i have that problem without running compiz.

Here is the last part of my xorg.conf

Section "Device"

#VideoRam 2048
# Insert Clocks lines here if appropriate
Identifier "* Generic VESA compatible"
Driver "nvidia"
EndSection
Section "Screen"
Identifier "Screen 1"
Device "* Generic VESA compatible"
Monitor "s"
DefaultDepth 24
Option "AllowGLXWithComposite" "true"
Option "TripleBuffer" "true"
Option "RenderAccel" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

any suggestion?

urka58 11-01-2007 05:56 AM

So.. you have to install a window decorator (emerald, kde-window-decorator), otherwise no chances you can get compiz working.
Have you installed all packages I listed ?
If you don't like emerald, install at least kde-window-decorator and replace it into the script.
Your xorg.conf file looks fine, just try removing the line
Option "TripleBuffer" "true"
if your video card has less than 128 MB memory
Ciao

ramskens 11-01-2007 09:55 PM

Quote:

Originally Posted by urka58 (Post 2944312)
So.. you have to install a window decorator (emerald, kde-window-decorator), otherwise no chances you can get compiz working.
Have you installed all packages I listed ?
If you don't like emerald, install at least kde-window-decorator and replace it into the script.
Your xorg.conf file looks fine, just try removing the line
Option "TripleBuffer" "true"
if your video card has less than 128 MB memory
Ciao

but.. my compiz works..with the title bars and everything, it works perfectly, till it hangs, total hang.

And, i have an nvidia 7300le, wich comes with 256mb, so i shouldn't remove that line?

composite works ok with the stock x11?, i didn't update that...

pappy_mcfae 11-12-2007 02:48 AM

I'm writing this as much to get a subscription link to this thread as I am to say that I finally have compiz working...at least on my new laptop. I am going to do some playing on my other laptop to see what really makes things work as opposed to theories without foundation.

Thanks to all those whose suggestions have brought me to functionality. As soon as I figure out exactly what got me working, I'll be sure to share it with everyone here.

EDIT:The other laptop is now running with compiz. I am using it right now, as a matter of fact. In getting to the point where I could get things working properly, I discovered something really interesting.

If you have added the following lines to your /etc/X11/xorg.conf file,
Code:


Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"

...and you are still coming up with the "No GLXFBConfig..." error, and you have been using a custom kernel, you need to make sure that you change your option under
Code:

Character devices->Direct Rendering Manager-><your_driver>.
Make sure those drivers are set up as modules. If they are compiled directly into the kernel, you will get the error.

Hope that helps some people. It helped me!

Blessed be!
Pappy

pappy_mcfae 11-15-2007 03:26 AM

Quote:

Originally Posted by Nikosis (Post 2832006)
It works Thanks, wow that was easy, can you tell me why it does't work on root
Thx

Compiz does, in fact, work for root users. I am one, and have been for some time now. I have compiz up and running on two laptops. I am root on both. They are both currently operating, running Slackware 12 and the version of compiz that came with it.

Of course, "work" is a relative term when it comes to compiz. It's clear there are some bugs in compiz, some pretty irritating ones. I get most of what I want to happen, and I can turn compiz on and off at will with two scripts I wrote specifically for that purpose. It was truly worth the time it took to get compiz up and running. The desktop cube is the coolest thing in the world!

Blessed be!
Pappy


All times are GMT -5. The time now is 04:05 PM.