-   Slackware (
-   -   Compiz 9.2.1 working with Slack64-13.1, GSB gnome, Alien Multi-Lib, grub 0.98? (

lesechang 11-29-2010 02:58 PM

Compiz 9.2.1 working with Slack64-13.1, GSB gnome, Alien Multi-Lib, grub 0.98?
My system: Compiz 8.6 working with Slack64-13.1, gnome GSB, Alien Multi-Lib and Grub 0.98.

I decided to upgrade Compiz and that's when the trouble started.

I compiled Compiz 9.2.1 (via git installed under /opt/compiz) without error. However, now my windows do not have title bars and it cannot find plugins. I can run ccsm but compiz doesn't see the changes.

I also tried compiling standard (from bz2 files, not git) Compiz 9.2.1 but error out on the compiz core 'make' step.

Is the problem that compiz cannot find plugins because some might be compiled with 64-bit and others with 32-bit?

QUESTION: Has anyone successfully got experimental Compiz 9.2.1 to work under Slackware64-13.1 with GSB Gnome and Multilib installed?

QUESTION 2: If so, can you give me some general hints?


Daedra 11-29-2010 04:29 PM


Originally Posted by lesechang (Post 4175075)
QUESTION: Has anyone successfully got experimental Compiz 9.2.1 to work under Slackware64-13.1 with GSB Gnome and Multilib installed?

QUESTION 2: If so, can you give me some general hints?


I have compiz-0.9.2 working successfully here, I am going to post slackbuilds and instructions later today on how to get it to working.

Daedra 11-30-2010 02:18 AM

I should mention though these packages are not as stable as the 0.8.6 release of compiz. 0.9 is a new version ported to C++ and is not considered stable, although the main developer has called it "stable for everyday use". I am running it on a test partition of 13.1 (32bit) and I would say thus far that it is as stable but not more stable then older version. However it is NOT STABLE for me on current, I haven't figured it out yet since i'm content right now using stable. This project recently got a new life when it was picked up as gnomes compositing window manager for there new unity desktop, however there also maintaining KDE support and some cool compatibility options like the blur plugin have been implemented.

Here are Slackbuilds if interested.
get the source files here

README: (Seriously Please :))
First thing you need to do is get the dependencies, and they are cython and protobuf. Get them at After you install those packages you need to completely remove compiz-0.8.6 and (if installed),

After you remove those packages you then need to delete your ~/.config/compiz file. Now you are ready to install the new version of compiz packages. Using the above builds, build and install in this order
plugins-main, plugins-extra, plugins-unsupported
Once those are installed you need to launch ccsm BEFORE you launch compiz. Open ccsm and enable move,resize window,window decoration,opengl,composite. Now you can launch compiz for the command line using

compiz --replace ccp &

If all went well you should now having compiz running. however you will not have window decorations yet. To enable that you have run "kde4-window-decorator --replace &" from a terminal or run box (or gtk-window-decorator for gnome). You should now having a running compiz-0.9.2 install. Now relaunch ccsm and customize to you liking.

If you are using QtCurve you for window themes then you should know that if you make your windows transparent with compiz enabled then the windows will have problems placing themselves, this is because qtcurve calls for the windows to be drawn way offscreen to allow themselves to "recaptured" by the window manager and placed correctly. However with compiz enabled this "kwin workaround" wont work. I have a patch for this that fixes 90% of all those problems if any one needs it.

Emerald no longer works with the new branch of compiz, however there is a project over at that allows .emerald theme files to be drawn using the native KDE window decorator.

Fusion-Icon has also not been ported thus far. I'm sure this will change though since its a hugely popular add-on.

tomtomjkw 11-30-2010 04:10 AM

I really found this post helpful :)
Thx Daedra!

lesechang 11-30-2010 04:21 PM

Hey, Daedra,

Thanks for the spoon-feed (slackbuilds)! You almost make it too easy! What was the trick here (the ./configure line)?

Daedra 11-30-2010 04:26 PM

Not sure, I would have to see the error log. My guess is you were missing a dependency or something.

BTW, I forgot to mention in my above post, but if your running KDE you can go to System Settings>default applications>Window Manager and you can change this to compiz that way KDE will load it automatically for you when you start KDE.

Daedra 11-30-2010 10:49 PM

We'll guys I got to be honest, I have been using 0.9.2 for a week now but the last few days I have been getting crashes with plasma which is locking up the desktop, this is the same problem I was having on -current. So it looks like it's not there yet, I am switching back to 0.8.6. However this might be more stable with GNOME, but you'll have to try since I am not running it currently.

lesechang 12-01-2010 09:43 PM

Me2. back to 8.6
I use GSB Gnome and not KDE and also had problems with Compiz 9.2.1: when I grabbed the titlebar of a window "shook it" and tried to move it (under Compiz 9.2.1) it didn't go anywhere! I had wobbly windows, move, etc plugins, installed, and yes, there were too many freezes.

I also went back to using Compiz 8.6 for the time being (I like Emerald).

Perhaps I'll try Compiz 9.3 when it comes out.

ozanbaba 02-10-2011 08:15 AM

I followed Daedra's post to build Compiz Ony problem I faced while building is that compizconfig-python falid to build with Cython 0.14. I downgraded to 0.13 and it build fine.

I use gtk-window-decorator and now I can configure it without dealing with gconf now at commandline. But IT had this weirdness; When using metacity themes, it used 0 opacity for the theme. I install gwd.schemas and by default it added 0 to active window opacity and 0.75 to inactive opacity. I changed them and now I'm using without problem.

SO far I no longer needed --indirect-render nor --loose-textures for speed-ups under Nvidia.

All times are GMT -5. The time now is 12:45 AM.