-   Slackware (
-   -   Compiling Problems (error: C preprocessor "/lib/cpp" fails sanity check) (

closetosomethingreal 01-24-2006 09:26 PM

Compiling Problems (error: C preprocessor "/lib/cpp" fails sanity check)
im using slax 5.0.6 (live distribution of slackware 10.2, installed to my hard drive. the reason i did not install the full version of slackware was to keep excess packages to a minimum) and i have gcc 3.4.5 (with c++ support installed also) i cannot compile any packages, it always returns this error when i ./configure: "checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details." i have tried everything, reinstalling gcc, compiling gcc from source (which, ironically, returns the same error) and i have had no luck. any help would be appreciated!

kodon 01-25-2006 02:36 AM

which version of the kernel-headers is installed?

ps, slackware allows minimal install itself...or expert.

closetosomethingreal 01-25-2006 12:48 PM

thanks, i didnt even have kernel headers installed. sorry, im kindof a noob. i might try the slackware minimal install. does it have graphical login and a shutdown option from the k menu? because now you have to login and start x manually and shutdown using the halt command, and the other people using this computer are windows users only, they have a hard time adjusting to that. thanks for the reply.

(that fixed my original problem, sorry if that was unclear)

kodon 01-25-2006 01:22 PM

just install what you need

as for graphical logon, just change to init 4

All times are GMT -5. The time now is 02:44 AM.