-   Slackware (
-   -   Compiling MySql-workbench, MultiLib packages. (

Maris-S 12-16-2010 03:21 PM

Compiling MySql-workbench, MultiLib packages.

Some time ago I tried to compile mysql-workbench, but even with all dependencies installed I got strange errors during compilation. I thought that I missed some dependencies or was doing something wrong, but now, when compilation script is available on, I decided to repeat this compilation. During compilation errors showed up again:


/usr/lib64/../lib/ could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[4]: *** [] Error 1
make[4]: Leaving directory `/tmp/SBo/mysql-workbench-gpl-5.2.29-src/ext/cppconn/driver'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/SBo/mysql-workbench-gpl-5.2.29-src/ext/cppconn'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/SBo/mysql-workbench-gpl-5.2.29-src/ext'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/mysql-workbench-gpl-5.2.29-src'
make: *** [all] Error 2

After some research I found that problem was in "gcc-g++-4.4.4_multilib-x86_64-1alien" package. It's quite strange. I installed original 64 bit package and compilation completed without any errors and MySql workbench works fine. Now I installed back multilib package and repeated compilation, the same error showed up again.

So, i solved my problem and I have MySql workbench installed, but I'm just curious, is it something wrong with multilib package, or did I do something wrong? Maybe I had to pass some compiler flags or something like that when using multilib system? I didn't have anything like that for other compilations I did.

By the way I'm using multilib only because of skype and wine, how can I find out which packages is necessary for them, I would better use only multilib packages I need to run this 2 programs.


Alien Bob 12-16-2010 03:33 PM


Maris-S 12-16-2010 03:51 PM

Thanks Eric for quick reply. I didn't try to use this flag before, but I just tested it and anyway it do not want to compile, still the same error. Part of the slackbuild script:


./ \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --build=$ARCH-slackware-linux \
  --disable-debug \
  --enable-shared=yes \
  --enable-static=no \
  --enable-python-modules \

make -j2

All times are GMT -5. The time now is 07:20 AM.