LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Compiling Motion in Slackware (https://www.linuxquestions.org/questions/slackware-14/compiling-motion-in-slackware-325105/)

sandugo 05-19-2005 03:46 PM

Compiling Motion in Slackware
 
Has anyone compiled Motion software in Slackware? The software is used as a command line control of webcams.

When I typed ./configure, I got this error message:

.....
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

I don't know if I am missing a library or the path is just not right.

HELP PLEASE!!!

black hole sun 05-19-2005 03:55 PM

You need to install gcc (more specifically, g++) / glibc. I'm not sure which ones you have or which you dont, but you appear to be new so download and install all of this stuff.

http://slackware.com/pb/download.php...c-2.3.5-i486-2
http://slackware.com/pb/download.php...c-3.3.5-i486-1
http://slackware.com/pb/download.php...+-3.3.5-i486-1
http://slackware.com/pb/download.php...c-3.3.5-i486-1

sandugo 05-19-2005 04:15 PM

ok. I was missing the gcc-objc*. I installed it but still got the same error message when I run ./configure.

__J 05-19-2005 04:49 PM

by itself, gcc cannot create an executable. mount your install cd ( the first one), or go to a slackware mirror and install the missing packages out of the d/ directory. if your not hurting for space, install most of them, some you will never use, but it will save some headaches in the future. the other thing you will need is the kernel headers package if you don't have it. make sure you get the kernel-headers package that came with your version of slack

sandugo 05-19-2005 06:29 PM

I have a limited hard disk space.... but I got it.... I was missing the kernel headers.

thanks.


All times are GMT -5. The time now is 10:01 PM.