-   Slackware (
-   -   Compiling mjpegtools on Slackware64 14 (

pchristy 10-23-2012 04:51 PM

Compiling mjpegtools on Slackware64 14
Having just upgraded from Slackware64-13.37 to 14.0, I've had to re-install some of my software, and one or two of them are proving problematic - specifically mjpegtools and vobcopy!

I have a standard slackbuild script for mjpegtools-2.0.0 which worked fine under 13.37. However, under 14, gcc produces an error whilst compiling: "Your gcc does not even support i386 for -march and -mtune"

This isn't surprising, as I'm building for x86_64! What is surprising is that gcc then interprets this error message as an instruction to search for a file or directory, and then crashes:

"gcc: error: Your: No such file or directory
gcc: error: gcc: No such file or directory
gcc: error: does: No such file or directory
gcc: error: not: No such file or directory"

and so on!!!

I've never seen anything like this before, and I've been a Slack user for over ten years!

Anyone got any clues as to what is going on?


sycamorex 10-23-2012 05:18 PM

Hi and welcome to LQ.

I've just tried it on my Slackware64 14. No problems here. It must be something with your environment. I don't know, did you use to run -multilib and haven't removed all the packages?

pchristy 10-24-2012 02:25 AM

Hi, and thanks for the quick response!

Its a clean install, pure 64-bit, though I am running a self-compiled kernel (3.6.3). Not sure why or if that should make any difference!

Very odd! Why would gcc complain about i386 on an x86_64 system? Still, if it works for you, it must be something I've missed here - but what?

Any clues much appreciated!


fgcl2k 10-24-2012 02:44 AM

I have also compiled mjpegtools on x86_64 without problems. What is the output of

uname -a
uname -m

Try executing the SlackBuild with the "-x" parameter and log the output. For example:

bash -x mjpegtools.SlackBuild 2>&1 | tee m.log

kingbeowulf 10-24-2012 02:45 AM

First off, you may want to revert to the stock Slackware with 3.2.29 kernel. mjpegtool then should compile. Then add one change at a time.

I run clean stock Slackware64 and Slackware64-multilib and compiling mjpegtool for x86_64 was not a problem.

pchristy 10-24-2012 03:13 AM


I found a new slackbuild script on Slacky and tried that - it worked instantly!

At a quick glance, I can't see anything significantly different in the way its configured, but there's obviously some subtle change in there! I'll have to have a closer look at it later, but for the moment, problem solved!

Many thanks for your help, guys! Just knowing that you all managed to build it persuaded me that it was something unique to the way I was doing things, rather than a generic issue! And that led me to a solution, even if I'm not quite sure why, yet!!!


All times are GMT -5. The time now is 09:57 AM.