-   Slackware (
-   -   compiling conky: tolua_errors not found (

babai 03-13-2010 08:22 AM

compiling conky: tolua_errors not found
I've trying to compile conky 1.7.2 in slack 13 with lua-cairo and lua-imlib2 bindings, have lua 5.1.4 installed and also installed tolua++-1.0.93 from der site installed it through scons..
here's my


## This is the linux configuration file
# This file was adapted to be used with ArchLinux
# Use 'scons -h' to see the list of command line options available

# Compiler flags (based on ArchLinux's installation of lua)
#LINKFLAGS = ['-g']
CCFLAGS = ['-O2', '-ansi', '-Wall' ]

#CCFLAGS = ['-g']

# this is the default directory for installation. Files will be installed on
# <prefix>/bin, <prefix>/lib and <prefix>/include when you run 'scons install'
# You can also specify this directory on the command line with the 'prefix'
# option
# You can see more 'generic' options for POSIX systems on

prefix = '/usr'

# libraries (based on ArchLinux's installation of lua)
LIBS = ['lua', 'dl', 'm']
tolua_bin = 'tolua++5.1'
tolua_lib = 'tolua+5.1'
TOLUAPP = 'tolua++5.1'

and still its giving me tolua_errors missing(i also tried with tolua_bin = tolua++ and so on)

ne ideas whats wrong here?

knudfl 03-13-2010 10:20 AM

' tolua++ ' is not "tolua"
QUOTE: "tolua++ is an extended version of tolua,.."
( Latest tolua++ is 1.0.93, and you have that.)
Latest = tolua-5.1.3

The version available as a package for Slackware 13 :

> >
> home


babai 03-13-2010 11:03 AM

well, i installed it from the link u gave me (thnks for that)


bash-3.1$ ls /var/log/packages/ | grep tolua

but its still giving me the same error :cry:


checking for tolua++... tolua++
checking for library containing tolua_error... no
configure: error: tolua_error not found

knudfl 03-13-2010 11:44 AM

Google .. error: tolua_error not found ..

The hits on the first page all seem to be about conky.

babai 03-13-2010 12:06 PM

ya, but i'm using the same in arch(which is compiled and packaged thru makepkg) without any probs. Following arch's pkgbuild(with suitable mods) i'm trying to compile conky here in slack but no luck.

knudfl 03-13-2010 02:04 PM

error: tolua_error not found
Google .. error: tolua_error not found ..

> >
[Bug 55649] conky, NEW: conky has lua support disabled | bugs ...

I.e. conky 1.7.2 has a bug / or you can say, that lua/cairo is disabled.
Conky can be compiled only without the "lua/cairo" libraries.

This source
> [conky_1.7.1.1.orig.tar.gz], [conky_1.7.1.1-1.diff.gz]
works OK with :
./configure --prefix=/usr/ --enable-imlib2 --enable-lua-cairo


babai 03-13-2010 11:43 PM

k, but here's the archlinux pkgbuild

i guess they are downloading conky 1.7.2 and compiling it with --enable-lua-cairo. So how are they succeeding?

jostber 03-14-2010 08:11 AM

You can try this:

knudfl 03-14-2010 12:13 PM

One more time .. Google ..

The first hit
.. says "solved", by using : LUA51_LIBS='-llua -lm'

.. but so far I haven't been able to make it work.
May be you can ?

babai 03-15-2010 01:09 AM

fsck me! all these time i was compiling with LUA51_LIBS='llua -lm' and not LUA51_LIBS='-llua -lm' (there's an '-' missing) :banghead:

neway got it to succesfully compile, thanks!!!!!

All times are GMT -5. The time now is 03:17 PM.