LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-26-2017, 05:36 AM   #1
oden_odin
LQ Newbie
 
Registered: Mar 2017
Posts: 9

Rep: Reputation: Disabled
compiling 32bit llvm on multilib


Hi, I'm on current with multilib and i need to downgrade llvm to 3.9 to be able to compile an older mesa.
My need for older mesa is to trace if there is a regression on my hardware.
I compiled llvm 3.9.1 as 64bit with no problems at all but i can't seem to compile a 32bit version without errors.


Code:
. /etc/profile.d/32dev.sh
LANG=C ARCH=i586 ./llvm.SlackBuild
it stops with errors.
Code:
-- Check for working C compiler: /usr/bin/32/clang
-- Check for working C compiler: /usr/bin/32/clang -- broken
CMake Error at /usr/share/cmake-3.7/Modules/CMakeTestCCompiler.cmake:51 (message):
  The C compiler "/usr/bin/32/clang" is not able to compile a simple test
  program.

  It fails with the following output:

   Change Dir: /tmp/llvm-3.9.1.src/build/CMakeFiles/CMakeTmp

  

  Run Build Command:"/usr/bin/gmake" "cmTC_be965/fast"

  /usr/bin/gmake -f CMakeFiles/cmTC_be965.dir/build.make
  CMakeFiles/cmTC_be965.dir/build

  gmake[1]: Entering directory
  '/tmp/llvm-3.9.1.src/build/CMakeFiles/CMakeTmp'

  Building C object CMakeFiles/cmTC_be965.dir/testCCompiler.c.o

  /usr/bin/32/clang -O2 -march=i586 -mtune=i686 -o
  CMakeFiles/cmTC_be965.dir/testCCompiler.c.o -c
  /tmp/llvm-3.9.1.src/build/CMakeFiles/CMakeTmp/testCCompiler.c

  Linking C executable cmTC_be965

  /usr/bin/cmake -E cmake_link_script CMakeFiles/cmTC_be965.dir/link.txt
  --verbose=1

  /usr/bin/32/clang -O2 -march=i586 -mtune=i686
  CMakeFiles/cmTC_be965.dir/testCCompiler.c.o -o cmTC_be965

  /usr/bin/ld: skipping incompatible
  /usr/lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libgcc_s.so when
  searching for -lgcc_s

  /usr/bin/ld: skipping incompatible
  /usr/lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.so when searching
  for -lc

  /usr/bin/ld: skipping incompatible
  /usr/lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.a when searching
  for -lc

  /lib/libc.so.6: error adding symbols: File format not recognized

  clang-4.0-32: error: linker command failed with exit code 1 (use -v to see
  invocation)

  gmake[1]: *** [CMakeFiles/cmTC_be965.dir/build.make:98: cmTC_be965] Error 1

  gmake[1]: Leaving directory '/tmp/llvm-3.9.1.src/build/CMakeFiles/CMakeTmp'

  gmake: *** [Makefile:126: cmTC_be965/fast] Error 2

  

  

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:48 (project)


-- Configuring incomplete, errors occurred!
See also "/tmp/llvm-3.9.1.src/build/CMakeFiles/CMakeOutput.log".
See also "/tmp/llvm-3.9.1.src/build/CMakeFiles/CMakeError.log".
So it seems that it reports that clang is broken and can't compile a simple test.
What do i have to do to compile an 32-bit llvm 3.9.1 on current with multilib?

Last edited by oden_odin; 03-26-2017 at 11:20 AM.
 
Old 03-26-2017, 10:17 AM   #2
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,946

Rep: Reputation: Disabled
What mesa GL driver are you using? I think unless you have an amdgpu where llvm is needed or are bisecting the llvmpipe its probably easier to just temporarily disable llvm for the mesa build.

Code:
--disable-llvm
Edit: If you go back far enough you might need this instead, I'm not sure when it was deprecated...

Code:
--disable-gallium-llvm
 
Old 03-26-2017, 10:46 AM   #3
oden_odin
LQ Newbie
 
Registered: Mar 2017
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by orbea View Post
What mesa GL driver are you using? I think unless you have an amdgpu where llvm is needed or are bisecting the llvmpipe its probably easier to just temporarily disable llvm for the mesa build.
I use both R600G and Radeonsi.
I thought llvm is needed for those.
 
Old 03-26-2017, 11:01 AM   #4
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,946

Rep: Reputation: Disabled
In that case I think you would need llvm, my preferred way of building 32 bit packages is to do so in a 32 bit chroot (A vm would work too) and then use Alien Bob's convertpkg-compat32 script to make a multilib package for my 64-bit install.
 
Old 03-26-2017, 11:18 AM   #5
oden_odin
LQ Newbie
 
Registered: Mar 2017
Posts: 9

Original Poster
Rep: Reputation: Disabled
I do compile mesa this way and it works for mesa if it compiles with the llvm version installed and then i use convertpkg-compat32 on the created package.
I thought that /etc/profile.d/32dev.sh was the recommended way to compile 32bit packages on multilib as explained in /usr/doc/compat32-tools-*/README
 
Old 03-26-2017, 12:24 PM   #6
oden_odin
LQ Newbie
 
Registered: Mar 2017
Posts: 9

Original Poster
Rep: Reputation: Disabled
I made an simple hello world and tried to compile it with 32bit clang and it seems like 32bit clang is broken in current multilib.
Code:
LANG=C  /usr/bin/clang-4.0-32 -v hello.c -o hello
clang version 4.0.0 (tags/RELEASE_400/final)
Target: i686-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/bin
Found candidate GCC installation: /usr/bin/../lib/gcc/x86_64-slackware-linux/5.4.0
Found candidate GCC installation: /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0
Found candidate GCC installation: /usr/lib/gcc/x86_64-slackware-linux/5.4.0
Found candidate GCC installation: /usr/lib64/gcc/x86_64-slackware-linux/5.4.0
Selected GCC installation: /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0
Candidate multilib: .;@m64
Candidate multilib: 32;@m32
Selected multilib: 32;@m32
 "/usr/bin/clang-4.0-32" -cc1 -triple i686-pc-linux-gnu -emit-obj -mrelax-all -disable-free -disable-llvm-verifier -discard-value-names -main-file-name hello.c -mrelocation-model static -mthread-model posix -mdisable-fp-elim -fmath-errno -masm-verbose -mconstructor-aliases -fuse-init-array -target-cpu pentium4 -v -dwarf-column-info -debugger-tuning=gdb -resource-dir /usr/bin/../lib/clang/4.0.0 -cxx-isystem /usr/lib64/qt/include -cxx-isystem /usr/lib64/qt/include -internal-isystem /usr/local/include -internal-isystem /usr/bin/../lib/clang/4.0.0/include -internal-externc-isystem /include -internal-externc-isystem /usr/include -fdebug-compilation-dir /tmp -ferror-limit 19 -fmessage-length 110 -fobjc-runtime=gcc -fdiagnostics-show-option -fcolor-diagnostics -o /tmp/hello-bb4e9d.o -x c hello.c
clang -cc1 version 4.0.0 based upon LLVM 4.0.0 default target i686-pc-linux-gnu
ignoring nonexistent directory "/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/bin/../lib/clang/4.0.0/include
 /usr/include
End of search list.
 "/usr/bin/ld" --eh-frame-hdr -m elf_i386 -dynamic-linker /lib/ld-linux.so.2 -o hello /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../crt1.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../crti.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/32/crtbegin.o -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/32 -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0 -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../../x86_64-slackware-linux/lib -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../.. -L/usr/bin/../lib -L/lib -L/usr/lib /tmp/hello-bb4e9d.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/32/crtend.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../crtn.o
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.so when searching for -lc
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.a when searching for -lc
/lib/libc.so.6: error adding symbols: File format not recognized
clang-4.0-32: error: linker command failed with exit code 1 (use -v to see invocation)

Last edited by oden_odin; 03-26-2017 at 12:29 PM.
 
Old 03-26-2017, 03:48 PM   #7
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 8,058

Rep: Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609Reputation: 5609
Quote:
Originally Posted by oden_odin View Post
I thought that /etc/profile.d/32dev.sh was the recommended way to compile 32bit packages on multilib as explained in /usr/doc/compat32-tools-*/README
I don't think it is necessarily *the* recommended way. But without doing anything else, it is the only way supported out of the box (and that's likely why it is documented in the README. I always found it much easier to compile 32bit programs in a VM and then run convertpkg-compat32 on the resulting package.
 
Old 03-26-2017, 04:18 PM   #8
oden_odin
LQ Newbie
 
Registered: Mar 2017
Posts: 9

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bassmadrigal View Post
I don't think it is necessarily *the* recommended way. But without doing anything else, it is the only way supported out of the box (and that's likely why it is documented in the README. I always found it much easier to compile 32bit programs in a VM and then run convertpkg-compat32 on the resulting package.
I wonder if clang like gcc should be compiled on an 64bit system to work correctly but i think i need to get more acquainted on multilib and 32bit compiling.
I'm a bit lost but i try to understand things better so i search information everywhere right now.
 
Old 03-26-2017, 05:26 PM   #9
55020
Senior Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 1,307
Blog Entries: 4

Rep: Reputation: Disabled
Not a lot of people realise this, but Slackware's gcc and clang can both cross-compile for i586 without 32dev.sh or multilib.

On gcc, you need the argument '-m32'.

On clang, either you need the arguments '-integrated-as -target i586-slackware-linux', or you need to call the 32 bit executable '/usr/bin/clang-3.8-32' which Alien Bob provides in the package llvm-compat32-3.8.0-x86_64-2compat32.

If you've built your own 64 bit llvm-3.9.1, then you won't have the option of using /usr/bin/clang-3.8-32.

But although gcc and clang can compile for i586, to link they need to use the 32 bit libraries provided by multilib -- the name 'multilib' is a clue.

In the standard multilib setup, 32dev.sh does only two things. It jiggles with the library paths so the 32 bit libraries are found first, and it jiggles with the executable paths. For gcc, various gcc commands are diverted to the small wrapper script /usr/bin/32/gcc, which calls the real gcc with '-m32' (this wrapper script is the only significant difference between the Slackware gcc packages and the multilib gcc packages). For clang, the clang command is diverted to /usr/bin/clang-3.8-32.

If you don't use 32dev.sh, you will get a version of clang that defaults to x86_64.

Maybe you could provide your own clang wrapper script (similar to the gcc script) that provides the compiler arguments you need. It's also possible that clang will need some more 32 bit libraries that are not currently provided by the core multilib packages.
 
3 members found this post helpful.
Old 03-26-2017, 11:59 PM   #10
oden_odin
LQ Newbie
 
Registered: Mar 2017
Posts: 9

Original Poster
Rep: Reputation: Disabled
Thank you 55020 for this information.
I had already looked at the wrapper script to know what they do but i didn't know about "-integrated-as -target i586-slackware-linux" yet.
I gave it a spin with stock llvm-4.0.0-x86_64-1 package and it didn't work.
Code:
LANG=C  /usr/bin/clang -integrated-as -target i586-slackware-linux hello.c -o hello
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.so when searching for -lc
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.a when searching for -lc
/lib/libc.so.6: error adding symbols: File format not recognized
clang-4.0: error: linker command failed with exit code 1 (use -v to see invocation)
I have compiled 3.9.1 using llvm.SlackBuild already but i didn't have it installed.
If i installed it and tried again i get the same error except version 4.0 is changed to 3.9
Can anyone else compile a simple hello world on current with "/usr/bin/clang-4.0-32" or "/usr/bin/clang -integrated-as -target i586-slackware-linux" so i know if something is broken on my setup or if it just doesn't work on current?
 
Old 03-27-2017, 10:04 AM   #11
55020
Senior Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 1,307
Blog Entries: 4

Rep: Reputation: Disabled
It looks like clang isn't easily able to do cross-linking out of the box. Your easiest option is to use a vm or 32 bit chroot and build your own llvm inside that, and then use convertpkg-compat32. But that llvm will have the same cross-linking limitations as the existing clang/llvm.
 
Old 03-27-2017, 10:47 AM   #12
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,946

Rep: Reputation: Disabled
If all that needs to be tested is mesa, then the 32-bit llvm package made with convertpk-compat32 should be enough.
 
Old 08-27-2019, 06:30 PM   #13
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,946

Rep: Reputation: Disabled
Quote:
Originally Posted by oden_odin View Post
I made an simple hello world and tried to compile it with 32bit clang and it seems like 32bit clang is broken in current multilib.
Code:
LANG=C  /usr/bin/clang-4.0-32 -v hello.c -o hello
clang version 4.0.0 (tags/RELEASE_400/final)
Target: i686-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/bin
Found candidate GCC installation: /usr/bin/../lib/gcc/x86_64-slackware-linux/5.4.0
Found candidate GCC installation: /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0
Found candidate GCC installation: /usr/lib/gcc/x86_64-slackware-linux/5.4.0
Found candidate GCC installation: /usr/lib64/gcc/x86_64-slackware-linux/5.4.0
Selected GCC installation: /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0
Candidate multilib: .;@m64
Candidate multilib: 32;@m32
Selected multilib: 32;@m32
 "/usr/bin/clang-4.0-32" -cc1 -triple i686-pc-linux-gnu -emit-obj -mrelax-all -disable-free -disable-llvm-verifier -discard-value-names -main-file-name hello.c -mrelocation-model static -mthread-model posix -mdisable-fp-elim -fmath-errno -masm-verbose -mconstructor-aliases -fuse-init-array -target-cpu pentium4 -v -dwarf-column-info -debugger-tuning=gdb -resource-dir /usr/bin/../lib/clang/4.0.0 -cxx-isystem /usr/lib64/qt/include -cxx-isystem /usr/lib64/qt/include -internal-isystem /usr/local/include -internal-isystem /usr/bin/../lib/clang/4.0.0/include -internal-externc-isystem /include -internal-externc-isystem /usr/include -fdebug-compilation-dir /tmp -ferror-limit 19 -fmessage-length 110 -fobjc-runtime=gcc -fdiagnostics-show-option -fcolor-diagnostics -o /tmp/hello-bb4e9d.o -x c hello.c
clang -cc1 version 4.0.0 based upon LLVM 4.0.0 default target i686-pc-linux-gnu
ignoring nonexistent directory "/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/bin/../lib/clang/4.0.0/include
 /usr/include
End of search list.
 "/usr/bin/ld" --eh-frame-hdr -m elf_i386 -dynamic-linker /lib/ld-linux.so.2 -o hello /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../crt1.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../crti.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/32/crtbegin.o -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/32 -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0 -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../../x86_64-slackware-linux/lib -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../.. -L/usr/bin/../lib -L/lib -L/usr/lib /tmp/hello-bb4e9d.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/32/crtend.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../crtn.o
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.so when searching for -lc
/usr/bin/ld: skipping incompatible /usr/bin/../lib64/gcc/x86_64-slackware-linux/5.4.0/../../../libc.a when searching for -lc
/lib/libc.so.6: error adding symbols: File format not recognized
clang-4.0-32: error: linker command failed with exit code 1 (use -v to see invocation)
I have not tested compiling a 32-bit llvm on Slackware64 with clang, but I have been able to workaround this issue.

Code:
cd /usr
ln -s lib lib32
With the lib32 symlink clang finds the correct libraries when using -m32 and I was able to confirm it can build a 32-bit version of wine-4.14.

Code:
$ cat hello.c 
#include <stdio.h>
int main()
{
   printf("Hello, World!");
   return 0;
}
Code:
$ clang -m32 hello.c -v
clang version 8.0.1 (tags/RELEASE_801/final)
Target: i386-unknown-linux-gnu
Thread model: posix
InstalledDir: /usr/bin
Found candidate GCC installation: /usr/bin/../lib/gcc/x86_64-slackware-linux/9.2.0
Found candidate GCC installation: /usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0
Found candidate GCC installation: /usr/lib/gcc/x86_64-slackware-linux/9.2.0
Found candidate GCC installation: /usr/lib64/gcc/x86_64-slackware-linux/9.2.0
Selected GCC installation: /usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0
Candidate multilib: .;@m64
Candidate multilib: 32;@m32
Selected multilib: 32;@m32
 "/usr/bin/clang-8" -cc1 -triple i386-unknown-linux-gnu -emit-obj -mrelax-all -disable-free -disable-llvm-verifier -discard-value-names -main-file-name hello.c -mrelocation-model static -mthread-model posix -mdisable-fp-elim -fmath-errno -masm-verbose -mconstructor-aliases -fuse-init-array -target-cpu pentium4 -dwarf-column-info -debugger-tuning=gdb -v -resource-dir /usr/bin/../lib64/clang/8.0.1 -cxx-isystem /usr/lib64/qt/include -internal-isystem /usr/local/include -internal-isystem /usr/bin/../lib64/clang/8.0.1/include -internal-externc-isystem /include -internal-externc-isystem /usr/include -fdebug-compilation-dir /tmp -ferror-limit 19 -fmessage-length 82 -fobjc-runtime=gcc -fdiagnostics-show-option -fcolor-diagnostics -o /tmp/hello-a497c4.o -x c hello.c -faddrsig
clang -cc1 version 8.0.1 based upon LLVM 8.0.1 default target x86_64-unknown-linux-gnu
ignoring nonexistent directory "/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/bin/../lib64/clang/8.0.1/include
 /usr/include
End of search list.
 "/usr/bin/ld" --eh-frame-hdr -m elf_i386 -dynamic-linker /lib/ld-linux.so.2 -o a.out /usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/../../../../lib32/crt1.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/../../../../lib32/crti.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/32/crtbegin.o -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/32 -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/../../../../lib32 -L/usr/bin/../lib32 -L/usr/lib/../lib32 -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0 -L/usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/../../.. -L/usr/bin/../lib -L/lib -L/usr/lib /tmp/hello-a497c4.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/32/crtend.o /usr/bin/../lib64/gcc/x86_64-slackware-linux/9.2.0/../../../../lib32/crtn.o
This old upstream issue report seems to be related.

https://bugs.llvm.org/show_bug.cgi?id=12108

I'm not sure what a better solution would be. It seems gentoo is not affected and they no longer have a lib32 directory or symlink, but I can't figure out why from reading their ebuild.

https://gitweb.gentoo.org/repo/gento...sys-devel/llvm
https://wiki.gentoo.org/wiki/Project...d_not_lib32.3F
https://wiki.gentoo.org/wiki/Project:LLVM/Multilib

Last edited by orbea; 08-27-2019 at 06:46 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] error while compiling llvm : virtual memory exhausted: Cannot allocate memory aashayshah Linux From Scratch 5 03-13-2013 10:04 AM
llvm-config problem in slackware64-current LLVM 3.2 package teeemcee Slackware 0 01-24-2013 02:44 PM
GCC vs LLVM mlpa Slackware 24 05-19-2012 06:01 AM
LLVM,QEMU and More foresst Linux - Software 3 03-12-2011 11:02 PM
What is LLVM? MTK358 Programming 2 03-22-2010 05:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration