-   Slackware (
-   -   compile kernel with radeon hd6950 drivers (

Ongbuntu 09-18-2013 09:04 AM

compile kernel with radeon hd6950 drivers

I tried building a custom kernel to include driver for radeon HD6950 without success.

This is the output for my lspci.
bash-4.2# lspci | grep -i radeon
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cayman PRO [Radeon HD 6950]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cayman/Antilles HDMI Audio [Radeon HD 6900 Series]

On boot, the system hangs for ~60 secs before giving the following error
Failed to load firmware "radeon/CAYMAN_rlc.bin"

I search under the firmware directory in my kernel source, but was not able to find the firmware for my graphic card.
bash-4.2# pwd
bash-4.2# ls
R100_cp.bin.ihex RS600_cp.bin.ihex RV620_pfp.bin.ihex RV710_me.bin.ihex
R200_cp.bin.ihex RS690_cp.bin.ihex RV630_me.bin.ihex RV710_pfp.bin.ihex
R300_cp.bin.ihex RS780_me.bin.ihex RV630_pfp.bin.ihex RV730_me.bin.ihex
R420_cp.bin.ihex RS780_pfp.bin.ihex RV635_me.bin.ihex RV730_pfp.bin.ihex
R520_cp.bin.ihex RV610_me.bin.ihex RV635_pfp.bin.ihex RV770_me.bin.ihex
R600_me.bin.ihex RV610_pfp.bin.ihex RV670_me.bin.ihex RV770_pfp.bin.ihex
R600_pfp.bin.ihex RV620_me.bin.ihex RV670_pfp.bin.ihex

I am running on slackware 14 with kernel version 3.2.29. I have tried downloading a more recent version 3.10.12 from, but the said file does not exist either.

Can someone please help?

Thank you.


serafean 09-18-2013 09:38 AM


A) use the new kernel. Many radeon fixes went in there.
B) radeon firmware goes into /usr/lib/firmware/radeon

you can get firmware files from here Most distros have a firmware package. Slackware's might not be up to date enough.


Ongbuntu 09-18-2013 09:14 PM

hi Serafean,

thank you so much! my problem is solved :)


All times are GMT -5. The time now is 10:21 PM.