LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Slackware (http://www.linuxquestions.org/questions/forumdisplay.php?f=14)
-   -   Compilation error in Slackware 14.0 (http://www.linuxquestions.org/questions/showthread.php?t=4175446511)

aaro 01-20-2013 08:07 PM

Compilation error in Slackware 14.0
 
Recently installed Slackware 14.0 and can't be more happy with it. Only problem is i haven't been able to compile any app. Tried with dzen2 and asclock. Both compilations failing with the same error:

gcc: fatal error: -fuse-linker-plugin, but liblto_plugin.so not found

I've tried using:

-fno-lto -fno-use-linker-plugin

with the same result. I've checked that the LIBRARY_PATH variable points to the right dir and that the requested file is present:

aaro ~ $ echo $LIBRARY_PATH
/usr/libexec/gcc/i486-slackware-linux/4.7.1

aaro ~ $ locate liblto_plugin.so
/usr/lib/liblto_plugin.so
/usr/libexec/gcc/i486-slackware-linux/4.7.1/liblto_plugin.so.0.0.0
/usr/libexec/gcc/i486-slackware-linux/4.7.1/liblto_plugin.so
/usr/libexec/gcc/i486-slackware-linux/4.7.1/liblto_plugin.so.0

aaro ~ $ uname -a
Linux satellite 3.2.29-smp #1 SMP Mon Sep 17 13:02:10 CDT 2012 i686 Intel(R) Core(TM) i5 CPU M 450 @ 2.40GHz GenuineIntel GNU/Linux

Also tried compiling dzen2 with slackbuilds script with same result. So, right now i'm clueless. I'm using Slackware 14.0 i686 (full install). It's running on my 64 bits processor powered laptop (core i5). Any help appreciated. Thanks in advance.

wildwizard 01-20-2013 09:12 PM

Well I don't think you should have a copy of it in /usr/lib as it isn't in the gcc package.

Also what are the file sizes for those files, as in are they actually a file or are they empty.

aaro 01-21-2013 04:43 AM

The one in /usr/lib was my first try for a workaround, it was not originally there.
Here the files and sizes:

aaro /usr/libexec/gcc/i486-slackware-linux/4.7.1 $ ls -l
total 95872
-rwxr-xr-x 1 root root 11411136 Jan 17 23:45 cc1
-rwxr-xr-x 1 root root 11592160 Jun 20 2012 cc1obj
-rwxr-xr-x 1 root root 12410528 Jun 20 2012 cc1plus
-rwxr-xr-x 1 root root 319344 Jun 20 2012 collect2
-rwxr-xr-x 1 root root 3640 Jun 20 2012 ecj1
-rwxr-xr-x 1 root root 12135640 Jun 20 2012 f951
-rwxr-xr-x 1 root root 15573376 Jun 20 2012 gnat1
-rwxr-xr-x 1 root root 12370988 Jun 20 2012 go1
drwxr-xr-x 2 root root 4096 Jun 20 2012 install-tools
-rwxr-xr-x 1 root root 10852596 Jun 20 2012 jc1
-rwxr-xr-x 1 root root 206704 Jun 20 2012 jvgenmain
-rwxr-xr-x 1 root root 993 Jun 20 2012 liblto_plugin.la
lrwxrwxrwx 1 root root 22 Dec 19 07:30 liblto_plugin.so -> liblto_plugin.so.0.0.0
lrwxrwxrwx 1 root root 22 Dec 19 07:30 liblto_plugin.so.0 -> liblto_plugin.so.0.0.0
-rwxr-xr-x 1 root root 68388 Jan 19 01:04 liblto_plugin.so.0.0.0
-rwxr-xr-x 1 root root 403444 Jun 20 2012 lto-wrapper
-rwxr-xr-x 1 root root 10789812 Jun 20 2012 lto1
drwxr-xr-x 2 root root 4096 Jun 20 2012 plugin

wildwizard 01-21-2013 04:52 AM

Well the file size matches the package so it should be ok.

Apart from installing the system what have you done with it before now (questions below :- )

Are these the first programs you have tried to compile?
Have you installed other 3rd party packages?
Did you do a full install or did you skip packages?

aaro 01-21-2013 08:07 AM

Only additional thing i made was add 3rd party repositories and installing some packages from there. I installed slacky.eu and salix repos and used slapt-get to install some packages. Even though i was very careful assigning priorities with official slackware repos with the highest, slacky.eu second and salix 3rd. It's the only thing i can think where something could go wrong. And if nobody else is getting this same error so i can suppose that it's my installation the problem. Many thanks for the help anyway :)

tuxbg 01-21-2013 12:45 PM

I have no problem here building that packages.Slackware64 current


All times are GMT -5. The time now is 11:24 AM.