-   Slackware (
-   -   Command line to GUI (

Jon84 02-27-2003 08:17 PM

Command line to GUI
Hey, I was wondering why I can't switch to a GUI from command line. I tried startx and xconfig and all of this but it doesn't seem to be working properly. I know there is an option when initally installing slackware to which type of X you want to use. I chose KDE but still get command line. I know there's something I'm doing wrong but what?

Thanks, as you can tell, I'm quite new but want to learn.


Excalibur 02-27-2003 08:34 PM

Slackware defaults to runlevel 3 after a new installation. Once your system is configured for X and are able to run it OK, then you can switch to runlevel 4 and you have a graphic login to KDE, etc. But for now leave it until you get X working properly.

When you run the startx command and X attempts to start then fails; there are usually some lines of text at the end of the display that describe the failure. Usually either video or mouse related. Please post what info you are abe to see that you fell may be relevant. That way we may be better able to help you resolve your problem.

Jon84 02-27-2003 09:09 PM

Alright, thanks. I changed my video color depth to 16 bit and that seemed to fix one problem. The other problem it's showing now is "Fatal Error AddScreen/ScreenInit failed for driver 0"

What's usually caused by this? I think I'm probably not checking the wrong monitor type down... well, back to reconfiguring.

Thanks so far.

Oh, and another thing... for my video memory, I have a 128MB ATI Radeon 9700 card. Do I have to be exact with the memory or can I just leave it at 128000KB?

Jon84 02-27-2003 09:36 PM

Well, after browsing the Internet ( I came across something interesting. I found something that said I should upgrade a to a new XFree86 due to my video card being older than December 31, 2001. Does this hold true?

DaOne 02-27-2003 09:36 PM


Oh, and another thing... for my video memory, I have a 128MB ATI Radeon 9700 card. Do I have to be exact with the memory or can I just leave it at 128000KB?
128000 is fine for the memory settings. I have the same card and it works fine. Did you install the ATI drivers? If not, the VESA drivers work fine for X if you don't need acceleration. But...if you install the drivers, you may be able to clear up some of the issues after running fglrxconfig.

Jon84 02-27-2003 09:39 PM

So I need to install the ATI drivers FIRST before starting "startx"?

DaOne 02-27-2003 09:43 PM

That depends...if you are currently using the VESA drivers...then you may have another issue (mouse, monitor). But, some or all of that may be able to be cleared up by installing the drivers and then running fglrxconfig.

DaOne 02-27-2003 09:45 PM

Keep in mind...the monitor refresh rates are very important to know. Incorrect settings can prevent X from starting, or in some cases, damage your monitor.

Jon84 02-27-2003 09:51 PM

OK, how do I go about installing these drivers without Internet connection? I assume they're on the CD?

Thanks so far. Sorry, I'm new!

DaOne 02-27-2003 09:54 PM

In case...

First the kernel must be compiled for at least i586 support instead of the default i386. I have a P4, so I believe it come to i686. Anyway, agpgart must be a Module and not compiled into the kernel. Then I downloaded and unpacked (first you must run rpm2tgz fgl***.rpm) (then tar xzvf fgl***.tgz) the drivers, which made 3 directories...lib, opt, usr, and then I copied all of the files from these directories to the corresponding directories. Once all of the files are copied, I run sh from /lib/modules/fglrx/build_mod. Then I run ./make_install from /lib/modules/fglrx. It says it will taint the kernel but I haven't seen anything that hurts yet. Then I run modprobe agpgart, and modprobe fglrx. Then run fglrxconfig. I had to uncomment /sbin.modprobe agpgart, and add /sbin/modprobe fglrx in /etc/rc.d/rc.modules. That's it.

I hope this helps if you get stuck on installing the drivers.

Jon84 02-27-2003 09:57 PM

That's the thing, I can't get any info off my floppy. I can't access it and I'm logged under "root". I was just wondering if there was an type of driver on the CD.

EDIT: I have this driver downloaded:


Now I'm wondering how would I transfer it to my other computer that's using Slackware.

DaOne 02-27-2003 09:57 PM are not on the CD. you must download them fron ATI's site...

Jon84 02-27-2003 10:04 PM

Downloaded it... read my edited post before this.

DaOne 02-27-2003 10:13 PM

You'll need to put it onto a CD unless you can download it from the Linux machine. Lynx will work from the command line...just type lynx. It's alittle tricky at first but once you spend a few minutes with it you'll get the point. I would however, recommend that you try to get X started to make things easier for you. Try to run /usr/X11R6/bin/XF86Setup. Use the VESA drivers, and make sure the monitor settings are correct.

Jon84 02-27-2003 10:17 PM

I don't have XF86Setup there. Would it be somewhere else? I'll take a look to see if it is.

All times are GMT -5. The time now is 01:35 PM.