LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-18-2018, 04:40 PM   #1
nimbusdin
LQ Newbie
 
Registered: Aug 2018
Posts: 1

Rep: Reputation: Disabled
colord-1.4.3 requires glib2-2.5.6 or greater but slackware 14.2 only ships with glib2-2.46.2


I'm currently having trouble trying to install colord on a slackware64 14.2 system. colord-1.4.3 requires a minimum of glib2-2.5.6 to install correctly but slackware 14.2 only comes with glib2-2.46.2 which is making it difficult to install colord.

I've tried downloading the source files for glib2-2.6.0 and creating a package to install with using makepkg and then using installpkg to install the new package, but the installation of colord does not recognize the new installation of glib2 that I installed and still shows the version of glib2 as 2.46.2.

What do I need to do to be able to upgrade glib2 so that colord will be able to install correctly?

Thank you!
 
Old 08-18-2018, 04:48 PM   #2
Darth Vader
Senior Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 2,727

Rep: Reputation: 1235Reputation: 1235Reputation: 1235Reputation: 1235Reputation: 1235Reputation: 1235Reputation: 1235Reputation: 1235Reputation: 1235
Upgrading of GLIB2 is a very risky endeavor and probably will broke many packages from your system because it has a fundamental role.

I suggest you instead to abandon the idea to install this colord-1.4.3

That's it. Not everything can be installed in a given operating system.

Last edited by Darth Vader; 08-18-2018 at 04:50 PM.
 
Old 08-18-2018, 05:18 PM   #3
55020
Senior Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 1,307
Blog Entries: 4

Rep: Reputation: Disabled
You should use colord-1.3.5, which is available at SlackBuilds.org.
 
Old 08-18-2018, 07:00 PM   #4
chrisVV
Member
 
Registered: Aug 2010
Posts: 342

Rep: Reputation: 154Reputation: 154
Quote:
Originally Posted by nimbusdin View Post
I'm currently having trouble trying to install colord on a slackware64 14.2 system. colord-1.4.3 requires a minimum of glib2-2.5.6 to install correctly but slackware 14.2 only comes with glib2-2.46.2 which is making it difficult to install colord.

I've tried downloading the source files for glib2-2.6.0 and creating a package to install with using makepkg and then using installpkg to install the new package, but the installation of colord does not recognize the new installation of glib2 that I installed and still shows the version of glib2 as 2.46.2.

What do I need to do to be able to upgrade glib2 so that colord will be able to install correctly?

Thank you!
glib2-2.46.2 is later than the minimum requirement of glib2-2.5.6 by 41 minor versions (20 stable minor versions), so it should work fine. What exactly is the difficulty you encounter with glib2-2.64.2? In particular, can you give the error messages that you are getting: they probably have nothing to do with glib.

Edit: The glib dependency for colord-1.4.3 according to meson.build is 2.45.8, so that should be satisfied by slackware-14.2, so that shouldn't be your problem (I am not saying it isn't, just that it shouldn't be).

Last edited by chrisVV; 08-18-2018 at 07:30 PM.
 
Old 08-18-2018, 07:14 PM   #5
chrisVV
Member
 
Registered: Aug 2010
Posts: 342

Rep: Reputation: 154Reputation: 154
Quote:
Originally Posted by Darth Vader View Post
Upgrading of GLIB2 is a very risky endeavor and probably will broke many packages from your system because it has a fundamental role.

I suggest you instead to abandon the idea to install this colord-1.4.3

That's it. Not everything can be installed in a given operating system.
I have colord-1.4.2 installed in slackware-current, and it works fine. Possibly the OP's problem is that it uses the meson build system. Does that come with slackware-14.2? If not he can probably compile meson/ninja with the slackbuild which comes with slackware-current. But from his post it looks as if the problem is something else: who knows, he needs to say what errors he is getting.
 
Old 08-19-2018, 08:50 AM   #6
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,447

Rep: Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711Reputation: 5711
[QUOTE=chrisVV;5893156But from his post it looks as if the problem is something else: who knows, he needs to say what errors he is getting.[/QUOTE]

HE explicitly mentions "colord-1.4.3 requires a minimum of glib2-2.5.6". Seemed a pretty clear statement to me.
 
Old 08-19-2018, 12:53 PM   #7
chrisVV
Member
 
Registered: Aug 2010
Posts: 342

Rep: Reputation: 154Reputation: 154
Quote:
Originally Posted by Alien Bob View Post
HE explicitly mentions "colord-1.4.3 requires a minimum of glib2-2.5.6". Seemed a pretty clear statement to me.
I think you are missing the point. First, that is not a statement of what error he gets, and secondly it cannot possibly be the source of his problem because glib2-2.46.2 meets the requirement for a minimum of glib2-2.5.6. The very topic of his posting contains a contradiction ("colord requires glib2-2.5.6 or greater but slackware 14.2 only ships with glib2-2.46.2").

Plainly his problem is something else. Without knowing what errors he gets it is not possible to say what.

As a side issue, it is not in fact correct that colord-1.4.3 requires glib2-2.5.6. That version would be completely inadequate. It requires glib2-2.45.8, as I said, which is also satisfied by slackware-14.2.

Last edited by chrisVV; 08-19-2018 at 12:54 PM.
 
Old 08-19-2018, 02:03 PM   #8
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,109

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
glibc2 is not the problem of OP.

Native dependency glib-2.0 found: YES 2.46.2
 
Old 08-19-2018, 03:43 PM   #9
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,639
Blog Entries: 3

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
it calls for it. you may want to edit it to call for yours. It is a configure script and he was using his. glibc does not care what you are compiling. edit the config. Your not building against an ABI ok. it is from source.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glib2 and /etc/mtab chrisVV Slackware 2 09-01-2017 01:10 PM
Glib-2.22 (Not glib2). cwizardone Slackware 7 04-17-2012 09:53 AM
glib2 issues Cyber Maid Linux - Software 7 05-01-2007 09:37 PM
Upgrading glib2 jrdioko Linux - Software 10 06-04-2005 05:40 PM
upgrade to glib2.3 wilsnyder Linux - Software 1 07-02-2003 05:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration