LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-08-2013, 07:14 PM   #1
PeterUK
Member
 
Registered: May 2009
Posts: 277

Rep: Reputation: 16
Cmake and configure Help + Sigrok


Before start could anyone point me to info how to do the Cmake configuration for Slackware + ./config?

Before start I would like to say I got going today a logic analyzer for less than 7 pounds, 18 lines upto 48Mhz. and so far tested with sigrock-cli and pulseview and it works highly recommended if you do any digital debugging, the board one of those Chinese boards with a CY7C68013A on board..

Let get back to the topic.

I did the installations manually of:

libsigrok
libsigrokdecode
sigrok-cli
PulseView
sigrok-firmware-fx2lafw

from here

I follow the guide from before:
Code:
git clone .....
./autogen.sh
./configure (I am not sure about this step)
make
make check <-- I added this but its was not doing any test
mkdir /tmp/file..
make install DESTDIR=/tmp/file..
cd tmp/file..
makepkg -l y -c n /tmp/libsigrok_eg-1-i686_SBo.tgz
upgradepkg --install-new /tmp/libsigrok_eg-1-i686_SBo.tgz
But that is how the website say but I am sure I missed something in ./configure step, right?

I know I am missing documentation and desktop link, right?

On pulse view was a bit different I used Cmake so it was a following:

Code:
git clone git://sigrok.org/pulseview
went in the folder
cmake -DCMAKE_C_FLAGS:STRING="-O2 -march=i686 -mtune=i686" -DCMAKE_CXX_FLAGS:STRING="-O2 -march=i686 -mtune=i686"  -DCMAKE_INSTALL_PREFIX=/usr
make
make install DESTDIR=/tmp/pulseview
went to that /tmp/pulseview folder and create the package as before. (makepkg .....) and installed
Code:
I left out "    -DLIB_SUFFIX=${LIBDIRSUFFIX} \
    -DCMAKE_BUILD_TYPE=Release .."
But I think this just dont do anything, right?

I know I am leaving out documentation and desktop link also here.

I tried sigrok-cli with the board and it works also pulseview, but one I am not sure I all went well and two I know like to know more about Cmake and ./config parameters, Thanks
 
Old 07-09-2013, 01:09 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,783

Rep: Reputation: 482Reputation: 482Reputation: 482Reputation: 482Reputation: 482
You need at least --prefix=/usr with configure:
./configure --prefix=/usr
To see more possible options, run './configure --help=short'
 
Old 07-09-2013, 12:12 PM   #3
psionl0
Member
 
Registered: Jan 2011
Distribution: slackware_64 14.1
Posts: 638
Blog Entries: 2

Rep: Reputation: 99
The SlackBuild Templates will give you more information.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cmake error windstory Linux - Newbie 2 11-22-2012 07:01 AM
CMake Strange "Install" behaviour with home-grown software [Linux x86_64, CMake 2.8] ajschaeffer Programming 0 10-24-2011 04:21 AM
cmake configure error ninja master Linux - Software 5 01-06-2011 07:14 AM
cmake: Using find_package(Boost) when FindBoost.cmake is not in the default location damien_d Programming 3 10-27-2010 04:40 PM
Tool to convert configure.ac into CMake baudolino Programming 3 02-18-2010 11:30 AM


All times are GMT -5. The time now is 09:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration