Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 07-08-2013, 06:14 PM   #1
Registered: May 2009
Posts: 277

Rep: Reputation: 16
Cmake and configure Help + Sigrok

Before start could anyone point me to info how to do the Cmake configuration for Slackware + ./config?

Before start I would like to say I got going today a logic analyzer for less than 7 pounds, 18 lines upto 48Mhz. and so far tested with sigrock-cli and pulseview and it works highly recommended if you do any digital debugging, the board one of those Chinese boards with a CY7C68013A on board..

Let get back to the topic.

I did the installations manually of:


from here

I follow the guide from before:
git clone .....
./configure (I am not sure about this step)
make check <-- I added this but its was not doing any test
mkdir /tmp/file..
make install DESTDIR=/tmp/file..
cd tmp/file..
makepkg -l y -c n /tmp/libsigrok_eg-1-i686_SBo.tgz
upgradepkg --install-new /tmp/libsigrok_eg-1-i686_SBo.tgz
But that is how the website say but I am sure I missed something in ./configure step, right?

I know I am missing documentation and desktop link, right?

On pulse view was a bit different I used Cmake so it was a following:

git clone git://
went in the folder
cmake -DCMAKE_C_FLAGS:STRING="-O2 -march=i686 -mtune=i686" -DCMAKE_CXX_FLAGS:STRING="-O2 -march=i686 -mtune=i686"  -DCMAKE_INSTALL_PREFIX=/usr
make install DESTDIR=/tmp/pulseview
went to that /tmp/pulseview folder and create the package as before. (makepkg .....) and installed
I left out "    -DLIB_SUFFIX=${LIBDIRSUFFIX} \
    -DCMAKE_BUILD_TYPE=Release .."
But I think this just dont do anything, right?

I know I am leaving out documentation and desktop link also here.

I tried sigrok-cli with the board and it works also pulseview, but one I am not sure I all went well and two I know like to know more about Cmake and ./config parameters, Thanks
Old 07-09-2013, 12:09 AM   #2
Amigo developer
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,840

Rep: Reputation: 521Reputation: 521Reputation: 521Reputation: 521Reputation: 521Reputation: 521
You need at least --prefix=/usr with configure:
./configure --prefix=/usr
To see more possible options, run './configure --help=short'
Old 07-09-2013, 11:12 AM   #3
Registered: Jan 2011
Distribution: slackware_64 14.1
Posts: 722
Blog Entries: 2

Rep: Reputation: 122Reputation: 122
The SlackBuild Templates will give you more information.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] cmake error windstory Linux - Newbie 2 11-22-2012 06:01 AM
CMake Strange "Install" behaviour with home-grown software [Linux x86_64, CMake 2.8] ajschaeffer Programming 0 10-24-2011 03:21 AM
cmake configure error ninja master Linux - Software 5 01-06-2011 06:14 AM
cmake: Using find_package(Boost) when FindBoost.cmake is not in the default location damien_d Programming 3 10-27-2010 03:40 PM
Tool to convert into CMake baudolino Programming 3 02-18-2010 10:30 AM

All times are GMT -5. The time now is 08:53 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration