-   Slackware (
-   -   Clementine suddenly stopped working for me. (

jon lee 09-26-2013 04:50 PM

Clementine suddenly stopped working for me.
I'm pulling my hair out over this one. It starts but when I try to play a station it says "loading stream" and then locks up. I've tried re-installing it, but it still has the same behavior.

I'm not sure if it's related, but I noticed the problem after upgrading to kde-4.11.1

This is the gdb log:

This is the strace log:

It seems to be locking up on 'gettimeofday' and 'clock_gettime' (as it loops pages and pages of 'resource unavailable' on these two. I have not upgraded the kernel recently and it was working fine.
Everything else on the system seems to be working fine.
Any help would be greatly appreciated.

jon lee 09-27-2013 12:21 AM

Fixed it, for anyone else who comes across this problem. The problem was with glib. I uninstalled the slackware glib2 package and compiled glib2 against my system. I'm sure this may have broke something else- time will tell.

Edit: Also if you do a search for "gettimeofday resource unavailable", this seems to be a fairly common problem with a lot of internet apps, like with FF, Skype, Iceweasel, and there really isn't any answers on why or how to fix it...

All times are GMT -5. The time now is 07:58 PM.