-   Slackware (
-   -   Clementine not detecting ipod on Slack 13.37 (

sterd71 07-16-2011 11:06 AM

Clementine not detecting ipod on Slack 13.37

I'm running a stock 32 bit Slackware 13.37 installation (kernel and I would like to use Clementine as my media player and
sync it with my 2nd gen Ipod nano.

I've installed libtasn1-2.9, libimobiledevice-1.0.6 and
usbmuxd-1.0.7. Libgpod-0.8.0 is installed as default.

I've tried the current stable build of Clementine-0.7.1 and a
development build (0.7.1 r3474) but neither of them detect the ipod
when I plug it in.

I've created the usbmux user and the usbmuxd daemon is running.

Other apps such as Amarok-2.4, Thunar and Dolphin all recognise the
ipod when it is plugged in.

What am I doing wrong or missing to get Clementine to work?


414N 09-17-2011 01:53 PM

I've had your problem too until 10 minutes ago ;)
Clementine uses libgio or DeviceKit (which is split in several modules, like udisks) to connect to the devices.
libgio comes already with the glib package on Slackware 13.37, so Clementine picks it automatically during configuration phase, but, be it either an old gio version or an incomplete implementation on Clementine's side, the thing doesn't work and devices do not get detected.
I compiled and installed udisks (and its dependencies), recompiled and reinstalled Clementine and now it works flawlessly.
I just tested connecting a USB disk drive and my iPod nano 3G and both work.
You can find udisks and dependencies on Remember to rebuild Clementine too after installing udisks.

All times are GMT -5. The time now is 02:20 PM.