-   Slackware (
-   -   clementine [ SlackBuild] (

inman 10-05-2012 07:22 AM

clementine [ SlackBuild]
hi guys,
i have some difficulties building the clementine player using SlackBuild of it for my new x86_64 box. i can not recall at which state of Slackware current developing, but at some point it stops building. so it doesn't build on Slackware 14 either.
it looks like we need a patch or somehow an option to turn something off, i don't know really, but you might have an idea how to solve this.


[ 51%] Building CXX object src/CMakeFiles/clementine_lib.dir/core/player.o
In file included from /tmp/SBo/clementine-1.0.1/src/core/player.cpp:30:0:
/tmp/SBo/clementine-1.0.1/src/internet/lastfmservice.h:30:24: fatal error: lastfm/Track: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/clementine_lib.dir/core/player.o] Error 1
make[1]: *** [src/CMakeFiles/clementine_lib.dir/all] Error 2
make: *** [all] Error 2

I would be pleased if you wouldn't advise me to use Amarok and help me finding a solution for this.

thank you in advance.

ponce 10-05-2012 08:42 AM

clementine builds fine here.

I think you are probably missing liblastfm in your slackware installation.

inman 10-05-2012 09:11 AM


Originally Posted by ponce (Post 4797982)
clementine builds fine here.

I think you are probably missing liblastfm in your slackware installation.

you mean lastfmlib? i had installed already, although it is not mentioned as a dependency.

ponce 10-05-2012 09:28 AM

no, liblastfm, in the standard slackware repository (and part of a slackware full installation).

EDIT: and I just noticed that you're building version 1.0.1, not the one of the build script from for slackware-14.0, so I advise you to build that.

BroX 10-05-2012 09:56 AM

Clementine needs to be patched in order to build with the current liblastfm, see this post.

That said, it segfaults when I attempt to start it.

ponce 10-05-2012 09:58 AM

there's no need, the's version is a git snapshot that includes that patch.

@inman: trying to clarify, assuming that you're building 1.0.1, the error that you reported is probably related to what Brox posted, not to a missing liblastfm.

imitis 10-05-2012 11:26 AM

had the same error. took 1.1rc1 and it built without problems.

ponce 10-05-2012 11:35 AM

imitis, don't misunderstand me, but that build script has been tested (more than once) with the version on (the git snapshot), it just can't give you the same error ;)

inman 10-05-2012 12:48 PM

it's solved.
When PONCE told me that he built this without any problem, it was somehow clear that i had a package conflict there.
so i cleaned up my system as i had tried sometime ago to test my own VLC script and installed some application which i expected to have conflict with some other. at that point clementine was built successfully, but on start i got that segment fault!
so what i did was to go with my gut and remove all gst_plugins and ffmpeg, then Clementine worked, well couldn't play anything. :cool:
i rebuilt the gst_plugin and ffmpeg and its dependencies lame and x264 and tried again, now clementine Rocks!
thank you all, for your help!

EDIT: just for protocol, i tried to built latest clementine and i got the same error, so all i just said above applies for the latest.

All times are GMT -5. The time now is 10:18 PM.