-   Slackware (
-   -   Citrix ICAClient on Slackware (

mostlyharmless 03-14-2014 12:51 PM

Citrix ICAClient on Slackware
Anyone install the Citrix Receiver for Linux (ICAClient) on Slackware 14+ recently? Seems as all the instructions mention a file like en.linuxx86.tar.gz with an instruction including running./setupwfc But most of the instructions are old circa 2010, including the otherwise excellent slackbook description. I removed lesstif for example, and installed Open Motif via SlackBuild

However, links to Citrix now only get you ICAClient- and while one can run rpm2tgz and install the package, it doesn't run, nor is there a setupwfc script/file anymore. There are numerous dependencies (like libxerces) which also don't seem to have recent SlackBuilds. I installed a libxerxes build from ponce,, but it's a 32 bit build, and I'm still getting multiple lib errors. I'm not sure about the libwebkit version I need either.

[EDIT] I see there's a slackbuild for xerces-c not libxerces DOH! under SlackBuilds, well, good, I'll try that.

I run 64 bit with multilib, so I'm thinking about downloading the 32 bit version and installing some of the other dependecies like libjpeg (which it can't find), but if anyone has recently installed this fine program, let me know if you have any suggestions.

beder 03-14-2014 07:01 PM

I have ICAClient installed in a slackware-current machine (already had it in 14.0) and use it daily with no problems (actually better than in a Windows machine)

I believe I used the official version provided in (there is a tarball in there)
Don't remember having any issues installing it. I do remember there was a setupwrc file and that I ran it successfully

I don't think you'll have any problems, just download it and give it a shot!

mostlyharmless 03-15-2014 01:42 PM

Thanks, I see the tar ball is only 32 bit, so I'll give that a try.

mostlyharmless 03-15-2014 11:15 PM

Well, now I've got

/opt/Citrix/ICAClient/selfservice --icaroot /opt/Citrix/ICAClient

libwebkit: cannot open shared object file: No such file or directory
I built and installed from SlackBuilds: openmotif, xerces-c, orc, gstreamer1, gst1-plugins-base, libwebp, webkitgtk, wenkitgtk3

and used linuxx86- for my ICA client build. Perhaps I should try, assuming I know how to uninstall 13, which of course was not a slackware package. Any other ideas?

beder 03-17-2014 07:31 AM

When I launch ICA it's from a link in a webpage, so I don't really launch selfservice. But if I try to launch it, I get the same error you got.

Looks like you need webkitgtk (there is a build in slackbuilds)

Mark Pettit 03-17-2014 08:56 AM

If it's a 32-bit package, and you're running 64-bit Slackware, then no doubt you'll need the multi-lib kit from AlienBob. AND you'll need to build webkit as a 32-bit package.

ponce 03-17-2014 09:28 AM

looks like all 32bit stuff, also the packages (rpms and debs) labeled as 64bit: I tried it a little now and it seems these additional compat32 libraries (I created them from my 32bit packages with convertpkg-compat32) are needed besides the standard ones that Eric provides with its multilib stuff for it to run on slackware64

after installing those you will also need to create a symlink (the horror!) in /usr/lib, as something is looking for, but we have

ln -s /usr/lib/ /usr/lib/

mostlyharmless 03-17-2014 09:30 AM

Yes, well, I had already built webkitgtk and webkitgtk3, as I posted, and I run multilib and have had no problems with it, yet.

Interestingly, if I run


I get


(wfica:2308): Gtk-WARNING **: Error loading icon from file '/opt/Citrix/ICAClient/icons/receiver.png':
        Unable to load image-loading module: /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders/ /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders/ wrong ELF class: ELFCLASS64
(wfica:2308): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

(wfica:2308): Gtk-WARNING **: Unable to locate theme engine in module_path: "oxygen-gtk",

(wfica:2308): Gtk-WARNING **: Error loading icon from file '/opt/Citrix/ICAClient/icons/receiver.png':
        Unable to load image-loading module: /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders/ /usr/lib64/gdk-pixbuf-2.0/2.10.0/loaders/ wrong ELF class: ELFCLASS64

which to mean indicates some sort of multilib problem. BTW, I had already made that soft link, without any change in outcomes. I'll try downloading and installing those compat32 files, thanks.

[EDIT] Nope, installing those packages didn't change things either.

mostlyharmless 03-17-2014 09:53 AM

OK, I tried unistalling and reinstalling citrix 13, no joy, installed but same errors.

I tried uninstalling citrix 13, and tried to install citrix 12, and got


icaclient/./linuxx86/hinst: line 2921: nspluginwrapper: command not found
Do you want to integrate Citrix Receiver with KDE and GNOME? [default y]:
Do you want GStreamer to use the plugin from this client? [default y]:
[ERROR] : machine architecture could not be decided.

So I guess I need ndispluginwrapper for version 12, but dunno about the last error.

[EDIT] OK, installed ndiswrapper, now all I get is the machine architecture warning error.

ponce 03-17-2014 10:15 AM

try repeating the steps for going multilb, and be sure to install also all the compat32 packages that Eric provides (they're in the subdirectories of the slackware64-compat32 one).

FYI, I've tried with the 13.etc tarball and seems to work fine here on slackware64-current.

mostlyharmless 03-18-2014 03:29 PM

OK, thanks, I was coming to the conclusion there must be something wrong with my multilib, and that the next step would be to reinstall it... which I'll try when I get a chance. One thing I did not do is type

. /etc/profile.d/
prior to installing the ICA Client; as I assumed the thing was being installed not compiled. But perhaps I should give that a try first. The other thing I'm not sure about that I should check, now that I'm rereading is whether I picked CONFIG_IA32_EMULATION as one of my kernel options. I'm pretty sure I did, since I started with the generic kernel .config.

bogzab 03-19-2014 04:55 AM

This will not help with any 64-bit / multilib ptoblems because I have a 32 bit only installation.

But I can confirm that version 12 of the citric client (actually has worked fine on Slackware 14.1 since I installed 14.1 and then ran the setupwfc that was provided in the citrix tarball. I used this on the previous version of Slackware and did not bother dowloading a newer citrix client. IIRC I had to install openmotif to get the citrix client dialogs to work, but nothing else. Some messing about with security certificates before I was able to get the citrix apps working.

Agree with beder that it runs more smoothly than a native windows machine so my one day a week from home is more productive than a day in the office.

The only problem I have encountered with this version is that when a lot of citrix apps are running, swapping citrix windows does not always work - multiple clicks on the (KDE) taskbar sometimes required before the desired window appears.

NetNightmare 03-28-2014 06:40 AM

first off lets clear one and for all that ICA client is 32 bit only , also if you find a package build for x86_64 arch doesn't matter since I think those other rpm based system do have 32 bit library while slackware is strictly 64 bit you can check yourself here :
where it state clearly and where you can also check all the required dependency

64-bit systems

The device requirements listed in this topic apply to 32-bit and 64-bit systems. Receiver for Linux is a 32-bit program, and requires 32-bit libraries in the system to operate. You can use the 64-bit package to install the 32-bit version of Receiver on 64-bit systems, but suitable 32-bit system libraries must be available. If they are not, Receiver either does not install or does not function correctly.
Also I dunno why you are installing ndiswrapper ...

I have a multilib setup and I have version 13 ( prior I had 12 as well ) running smoothly , first of course you need a working multilib setup then you need to compile and install these packages :


for HD components other libraries are required like these

As a coclusion openmotif doesn't seem to be anymore a requirement for the ica client version13

mostlyharmless 04-06-2014 08:21 AM

Sorry for not getting back, I was otherwise enmeshed.

@ponce I re-ran all the multilib stuff from Eric's (AlienBob's) site, removed and reinstalled the version 13 tarball and ran ./setupwfc. I've got that likk to libwebkit. Still no joy on the /opt/Citrix/ICAClient/selfservice running; it still has the same error.


lso I dunno why you are installing ndiswrapper ...
Well, because when I tried version 12 it said

icaclient/./linuxx86/hinst: line 2921: nspluginwrapper: command not found
See a few posts back, not that it matters :).

So I decided to concentrate on opening a link on a web page, since beder specifically mentioned that works, and I assume that's what the rest of you do too.

On the bright side, if I go to a web site with the launch.ica link, it gives me the opportunity. From
I put

application/x-ica; /opt/Citrix/ICAClient/ %s; x-mozilla-flags=plugin:Citrix ICAClient
in .mailcap

application/x-ica ica
in .mime.types

which then let wfica open launch.ica (instead of the default notepad)
Of course I was told that the certificate (in my case Rapid SSL CA) was untrusted with error SSL 61 or some such..

I went to Edit/Preferences/Advanced/Certificates and selected the appropriate certificate and Exported it to /opt/Citrix/ICAClient/keystore/cacerts

Success at last!

So I'll mark this [SOLVED] even though there are still clearly issues with the selfservice I haven't worked out, as well as those other pesky errors. Thanks to everyone who contributed.

biocyberman 01-07-2015 12:56 PM

Get the latest version!
It took me a while searching around to solve problem with libwebkit problems. I finally realized that I was trying to install ICA client version 13.0 on Ubuntu 14.04, whereas Citrix already release version 13.1 in September 2014 here: . After downloading .deb files and running following command, Citrix Receiver seems to work out of the box:


sudo dpkg -i icaclient_13.1.0.285639_amd64.deb
sudo dpkg -i ctxusb_2.4.285639_amd64.deb

I should also mention that gdebi complained the following before swithing to dpkg commands:


sudo gdebi ctxusb_2.4.285639_amd64.deb
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Building data structures... Done
Building data structures... Done
This package is uninstallable
Failed to satisfy all dependencies (broken cache)

All times are GMT -5. The time now is 11:15 PM.