LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Cinnamon (https://www.linuxquestions.org/questions/slackware-14/cinnamon-4175455047/)

Woodsman 04-05-2014 05:43 PM

Does anybody have build scripts for Cinnamon 2.0?

willysr 04-05-2014 08:59 PM

I tried to have a look last night and it seems some of it's dependencies (clutter) can't be installed since it requires newer glib than what we have in slackware 14.1.
Although it's easy to upgrade glib using Pat's Slackbuild, there might be side effects and many packages would need to be rebuilt, so i didn't continue looking at it, not until next Slackware releases at least

Woodsman 04-05-2014 09:35 PM

So we wait until glib is updated in Current.

My understanding is Cinnamon 2.0 no longer is strictly tied to GNOME 3.

willysr 04-05-2014 10:34 PM

I tried to start building packages for cinnamon, but probably using an older version of clutter
Hope to publish the slackbuilds soon if it works for me :)

willysr 04-06-2014 12:18 PM

i think i'm stuck with cinnamon-settings-daemon which requires colord and turns out, it requires systemd :(
the cinnamon desktop won't start properly without cinnamon-settings-daemon

saxa 04-06-2014 12:41 PM

I do not remember properly, but I think colord doesnt have a hard dep systemd, in any case you have 2 options, use an older colord, or use Barts systemd packages. Another alternative can be to use or look at the scripts we use to build colord in droplinegnome.

willysr 04-06-2014 12:45 PM

Well, now it does, so yeah, i think i will try to use older version

saxa 04-06-2014 12:47 PM

I do remember something we had to do in the past, so I think we switched back to something like 0.0.26 version before the 1.0.0 , don't take my numbers as 100% correct.

willysr 04-06-2014 01:04 PM

yes, 0.1.26 is the latest one that doesn't depend on systemd :)
i got colord built now, continuing with cinnamon-settings-daemon

saxa 04-06-2014 01:19 PM

Great, you are right, the version is 0.1.26. Good luck.

willysr 04-06-2014 08:43 PM

OK, managed to install cinnamon, but when i logged in, it's blank (black screen), but the DE is loaded
still have to do more debugging :)

saxa 04-06-2014 09:09 PM

Try to set your language to UTF-8 in /etc/profile.d/lang.sh

willysr 04-06-2014 09:49 PM

nope, didn't help

saxa 04-06-2014 10:00 PM

try to start X with startx > mylog.txt 2>&1 maybe it gives you a hint of why is not loading it until the end.

willysr 04-06-2014 10:29 PM

I think it's because of this
Code:

(cinnamon-settings-daemon:54654): color-plugin-WARNING **: failed to get edid: unable to get EDID for output

(cinnamon-settings-daemon:54654): color-plugin-WARNING **: unable to get EDID for xrandr-Virtual1: unable to get EDID for output
Traceback (most recent call last):
  File "/usr/bin/cinnamon-launcher", line 8, in <module>
    from gi.repository import Gtk
ImportError: No module named gi.repository

I think this should be satisfied by pygtk, but eventually not


All times are GMT -5. The time now is 10:15 PM.