-   Slackware (
-   -   CIFS connection problem (

thirteen_engines 02-09-2013 10:06 AM

CIFS connection problem
At work we have several lab instrument computers running Win XP whose data were backed up on a regular basis to a Slackware 12.0 computer. The Slackware 12.0 machine finally packed it in after many years of reliable service and we now have a new machine running Slack 14.0.

The problem that I am having is that I can no longer connect to the Windows machines to transfer data from them. The Windows XP computers each have a data folder that is shared to the network. The scripts that I was running on the old Slackware 12.0 machine were something like:

mount -t smbfs -o username=name,password=xxxxxx //ip_address/data /mount_point
rsync avz /mount_point /backup_folder

"mount -t smbfs" does not work now in Slack 14.0 so I've tried changing to "mount -t cifs". Doesn't work. Here is what I have been trying to use:

mount -t cifs //ip_address/data /mount_point -o username=name,password=xxxxxx

This just does not work and I'm tearing what little hair I have left out trying to figure out why, especially since the same thing seems to work for other people. Any help with this would be much appreciated.

allend 02-09-2013 10:34 AM


mount -t cifs //ip_address/data /mount_point -o username=name,password=xxxxxx
"username" is not a valid option to mount.cifs. Try with

mount -t cifs //ip_address/data /mount_point -o user=name,password=xxxxxx
PS - Keep you hair because I am one of the people for which this does work. :)

Celyr 02-09-2013 10:56 AM

You may also think to switch to nfs.
Windows XP has a nfs service.

thirteen_engines 02-09-2013 03:59 PM

Allend: Thanks. That worked. Took a while to connect but 'df' shows the Windows machine connected now.

Celyr: Thanks for the idea but my experience with nfs has been less than stellar. If I am still having problems with cifs next week I might consider it but I'm really looking for something that is very robust and can run unattended under almost any circumstances. My experience with nfs leads me to believe that if the Windows machine is down for some reason then when the linux computer trys to mount a share using nfs it will choke.

All times are GMT -5. The time now is 04:02 AM.