-   Slackware (
-   -   Change XFCE interface language without changing bash (

m1m 03-25-2013 03:36 PM

Change XFCE interface language without changing bash
I use Slackware 14 with XFCE 4.10. How can I change interface language to polish and leave bash langage set to english?
This is my /etc/profile.d/ right now

export LANG=pl_PL.utf8
export LC_CTYPE="pl_PL.utf8"
export LC_NUMERIC="pl_PL.utf8"
export LC_TIME="pl_PL.utf8"
export LC_MONETARY="pl_PL.utf8"
export LC_MESSAGES="en_US.utf8"
export LC_PAPER="pl_PL.utf8"
export LC_NAME="pl_PL.utf8"
export LC_ADDRESS="pl_PL.utf8"
export LC_TELEPHONE="pl_PL.utf8"
export LC_MEASUREMENT="pl_PL.utf8"
export LC_IDENTIFICATION="pl_PL.utf8"
export LC_ALL=

I have english bash (program messages, man etc) and english XFCE. When I change LC_MESSAGES to pl_PL, both bash and XFCE are set to polish language.

Didier Spaier 03-25-2013 03:53 PM

"export" in /etc/profile.d/ make the settings valid system wide.

If you you want another setting for some command, just launch it like this "LANG=<other locale> <command>".

Of course this can be used as well for other shell variables.

m1m 03-25-2013 05:46 PM

Yes, I know that, but how it can be done in my particular situation?
I want to have polish interface in XFCE but in bash I want to use en_US, I don't want to prefix every command with LANG= ...

gargamel 03-26-2013 03:47 AM

My knowledge may be incomplete, but as far as I know:

1. As a workaround you could try to define an alias for your console program (xterm, xfce-terminal or whatever) setting LANG to US English whenever the program is invoked. Put this alias definition into, eg, ~/.profile, and see if it does the job. I haven't tried it myself, though.

2. The only desktop environment I know that does exactly right what you want is KDE (I can't comment on Gnome --- maybe equally good here). Which is one major reason for me to stick with it as my preferred desktop environment, although I like Xfce and e17 a lot, too.


m1m 03-26-2013 03:41 PM

Thanks for answer gargamel!
I thought it could be done globally, but for now I set default shell command in Tilda preferences to "env LANG=en_US bash" and I get what I wanted.

All times are GMT -5. The time now is 06:02 AM.