-   Slackware (
-   -   'cdrecord -scanbus dev=ATAPI:' does not work with udev (

beolach 06-11-2004 01:48 AM

'cdrecord -scanbus dev=ATAPI:' does not work with udev
I run Slackware-current w/ kernel 2.6.6 & the udev-025-i486-6 package (from the Slackware-current tree). Before I installed the udev package, or when I reboot without the rc.udev startup script, I am able to use 'cdrecord dev=ATAPI:" to record CDs on my IDE-ATAPI CD-RW drive, without using ide-scsi and with no problem at all. However I have noticed that when I am running udev to manage /dev, cdrecord is not able to find the ATAPI CD-RW drive. When I run 'cdrecord -scanbus dev=ATAPI:' whith udev, I get:


bash-2.05b$ cdrecord -scanbus dev=ATAPI:
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
scsidev: 'ATAPI:'
devname: 'ATAPI'
scsibus: -1 target: -1 lun: -1
Warning: Using ATA Packet interface.
Warning: The related libscg interface code is in pre alpha.
Warning: There may be fatal problems.
cdrecord: No such file or directory. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Has anyone else experienced this problem, or know of a way to fix it?

Thanks in advance,

Andrew Benton 06-11-2004 05:07 AM

Cd burning works for me with the 2.6.7-rc3 kernel and Udev-025. I had to edit /etc/udev/udev.permissions to change the permissions on /dev/hdc to 0666. The line for disks read

Ichanged it to


It's possible Udev's config files may be somewhere else on your system. I hope this helps.

beolach 06-14-2004 12:22 AM

Thanks for the suggestion, but unfortunatly it does not resolve my problem. My CD-RW drive (/dev/hde) already had 0666 permission. Sorry for not making that clear in my first post.


brw-rw-rw-  1 root cdrom 33, 0 2004-06-11 23:31 hde
Also I forgot to mention, I have the same problem when running cdrecord as root or a normal user. Any other suggestions welcome.

lems 06-14-2004 02:15 AM

Same problem here. :(
So I now use cdrecord -scanbus dev=/dev/hdc (ugly, I now, but it works).

keefaz 06-14-2004 03:03 AM

I don't know if it can help but on my bootloader (grub) I added 'hdd=ide-cd' in the line with kernel parameters (/dev/hdd is my burning device)

All times are GMT -5. The time now is 04:28 PM.