-   Slackware (
-   -   Cat input output error (

zaicheke 12-22-2004 09:07 PM

Cat input output error
I'm trying to back up some cds on to my harddrive. The first cd worked fine when i did cat /dev/hdc > cd1.iso but when i tried to do this again i got the following error. cat: /dev/hdc: Input/output error. I'll tried several other cds but none of them will work. I wasn't aware that i changed anything. What could cause this error?

cythrawll 12-22-2004 09:12 PM

I have had "hang" issues on my cdroms after moving Large files from them to the hard drive,, after a few minutes they work fine again.

could dd also work for you needs?

dd if=/dev/hdd for=/home/user/cd.iso

zaicheke 12-22-2004 09:16 PM

dd if=/dev/dvd of=~/cd2.iso
dd: reading `/dev/dvd': Input/output error
3216+0 records in
3216+0 records out

same thing. So are you saying this is a temporary issue?

zaicheke 12-22-2004 09:17 PM

/dev/dvd is linked to /dev/hdc.

Just another bit of information. It also stops in the same place for each disk i've tried. The one i really need copied always stopped at 1.6M.

cythrawll 12-22-2004 09:19 PM

well it happened to me when i was moving the large files from doom3 disks onto my hard drive for the linux version... The cd rom would become inaccessible for anywhere from about 10 to 30 mins. and then worked again. I could still read from the disk tho (with ls never tried cat.)

**edit** could it be a memory problem?

zaicheke 12-22-2004 09:20 PM

i'm just going to shut it down and let it sit. When yours was inaccessible did it give the same errors as mine?

cythrawll 12-22-2004 09:22 PM

well, i got a different error, but I was trying to unmount it, and it gave me a "could not umount drive is busy" when it wasnt. Im not saying that these incidences were related, but it could be??

*edit* after doing some research, this might be caused by a disk error, i would check you dmesg log

zaicheke 12-22-2004 09:32 PM

I tried it on a smaller disk image and worked (after i let it sit with the power off for a while).

EDIT: I was able to copy the 100M to an iso but i can still cannot copy the 610M one. Is this a problem that will be solved just by waiting?

cythrawll 12-22-2004 10:17 PM

i just tried to do a cat of my dvd the same way as you are trying to do...

i get the same error, is there a file size limit for this method??

I tried using K3b to save the iso, and i get a:

error reading sector number 481, error

jschiwal 12-22-2004 10:26 PM

Sounds to me like the CD's themselves have a defect. You could try one of the CD repair kits.

Do you need to boot up these disks, or could you try backing up the files on the discs rather than doing an image backup?

zaicheke 12-22-2004 11:01 PM

could it be copyright protection. It's a game (which i own). The one i copied was the second cd.

zaicheke 12-22-2004 11:06 PM

i'm fairly sure it's copy right now. I have no idea why they wouldn't put copy right protection on the second of a two disk set.

gnashley 12-23-2004 07:00 AM

This seems to me to be a problem with using 'cat'. If you use cat for a /dev it will continue to cat forever sometimes. And if you are able to kill the process at all, your console has 'binary', strange looking characters. You can type 'reset' to fix that. But sometimes you can't even kill the process beacuse the keyboard doesn't respond, or perhaps it does let you swith to another tty and kill the process from there.
Don't use 'cat' on binaries or on /dev's.
dd doesn't care what the data is -it just writes it directly without reading it. Don't mount the drive your dd'ing from, or to, if theat's the case
BTW, the -R option(not -r) for 'cp' keeps it from reading the data it copies -sometimes cures a data corruption when using 'cp'.

zaicheke 12-23-2004 11:45 AM

I think i'm just going to use mkisofs for now. If somone could tell me why this doesn't work for most games that would be great. The size of the disk doesn't matter, i made an iso of a home made dvd (which was 3.7G). Plus the only way i've ever been able to copy this stuff on windoze was wth Alcohol 120%, which gets by safedisk. I don't you think you can copy it with Nero.

minm 12-26-2004 04:46 AM

Yeah im getting an input output error as well

Is it because of cd protection?

I don't get how it can be done on windows though..?

All times are GMT -5. The time now is 12:05 PM.