-   Slackware (
-   -   Can't Run KDE 4.5.5 in VirtualBox (

Woodsman 03-05-2011 09:49 PM

Can't Run KDE 4.5.5 in VirtualBox
I installed Current (Feb. 28) in VirtualBox. The install went fine.

I can boot into Xfce and Fluxbox with the startx command. KDE bombs, somewhere just after the fourth icon of the startup display.

In my first attempt I installed the VB guest additions. I figured that might be the problem. I wiped the virtual machine and tried again. In my second attempt I did not immediately install the guest additions. Same result.

I copied xorg.conf-vesa to xorg.conf. No help, same result as with no xorg.conf. I am not booting the system with any framebuffer, just normal vga. Without the VB guest additions, the system is at 800x600 resolution.

Because of the tiny screen, I cannot read all of the error messages. The scrollback buffer is to small to read all of the messages. Some of the messages make no sense to me. For example, there is a message that plasma-desktop cannot find the dbus session server. Yet rc.messagebus is enabled and running, and a file in ~/.kde/dbus/session-bus exists. I see messages about fatal errors with references to *.cpp files at /tmp/kde-4.5.5.

The Xorg.0.log says there was a segmentation fault at address (nil), but there are no (EE) errors in the log. There is no xsession-error log.

I started xfce. From there installed the VB guest additions. Rebooted. No framebuffer (vga=normal). I was able to run Xfce and fluxbox in a nice 1664x929 display resolution. Mouse and keyboard worked transparently. I edited lilo.conf for vga=791 to enlarge the console screen size.

I rebooted, tested X again, then exited. I changed to KDE. Same results. Bomb.

This time I saw two (EE) error messages in Xorg.0.log regarding vboxvideo and disabling DRI.

Here is part of the xorg log:


[  533.067] (EE) [drm] drmOpen failed.
[  533.067] (EE) VBoxVideo(0): DRIScreenInit failed, disabling DRI.
[  533.067] (II) VBoxVideo(0): visual configurations initialized
[  533.068] (==) VBoxVideo(0): Backing store disabled
[  533.068] (II) VBoxVideo(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  533.071] (==) VBoxVideo(0): DPMS enabled
[  533.073] (II) VBoxVideo(0): The VBox video extensions are now enabled.
[  533.073] (--) RandR disabled
[  543.133] 0: /usr/bin/X (xorg_backtrace+0x3b) [0x80e72fb]
[  543.133] 1: /usr/bin/X (0x8048000+0x5dbf5) [0x80a5bf5]
[  543.133] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe40c]
[  543.133] 3: /usr/lib/xorg/modules/ (fbBlt+0xbe) [0xb72c392e]
[  543.134] 4: /usr/lib/xorg/modules/ (fbBltStip+0x73) [0xb72c46d3]
[  543.134] 5: /usr/lib/xorg/modules/ (fbGetImage+0x199) [0xb72c9a39]
[  543.134] 6: /usr/bin/X (0x8048000+0x15f0af) [0x81a70af]
[  543.134] 7: /usr/lib/xorg/modules/extensions/ (0xb74c0000+0x37d5b) [0xb74f7d5b]
[  543.134] 8: /usr/lib/xorg/modules/dri/ (0xb4bfc000+0x10a5d) [0xb4c0ca5d]
[  543.134] 9: /usr/lib/xorg/modules/dri/ (0xb4bfc000+0x10aa7) [0xb4c0caa7]
[  543.134] 10: /usr/lib/xorg/modules/extensions/ (0xb74c0000+0x37cbd) [0xb74f7cbd]
[  543.135] 11: /usr/lib/xorg/modules/extensions/ (0xb74c0000+0x34412) [0xb74f4412]
[  543.135] 12: /usr/lib/xorg/modules/extensions/ (0xb74c0000+0x3528a) [0xb74f528a]
[  543.135] 13: /usr/lib/xorg/modules/extensions/ (0xb74c0000+0x3727f) [0xb74f727f]
[  543.135] 14: /usr/bin/X (0x8048000+0x27e87) [0x806fe87]
[  543.135] 15: /usr/bin/X (0x8048000+0x1aec5) [0x8062ec5]
[  543.135] 16: /lib/ (__libc_start_main+0xe6) [0xb7560db6]
[  543.137] 17: /usr/bin/X (0x8048000+0x1aaa1) [0x8062aa1]
[  543.137] Segmentation fault at address (nil)
[  543.138]
Fatal server error:
[  543.138] Caught signal 11 (Segmentation fault). Server aborting
[  543.138]
[  543.138]

I see some old threads about mesa, but after these many months I doubt they still apply.

Otherwise I have had no other problems in VB.



mlangdn 03-06-2011 03:24 PM

Google has been no help so far on this. That said, since xfce and fluxbox seem to run fine, I am wondering if you have enough memory allocated to run kde. The last time I had Slackware in VBox, I allocated 1500mb for that machine. But that's been over a year ago.

Woodsman 03-06-2011 03:32 PM


Google has been no help so far on this.
Same here, which is why I posted. :)

Per your suggestion I tried 1.5 GB RAM and 128MB video. No go. :(

disturbed1 03-06-2011 03:51 PM

It's been posted in this forum and hinted to in the changelog :)

You have to disable composite.


x/mesa-7.9-x86_64-1.txz: Upgraded.
I was on the fence with this upgrade, and in fact it sat in /testing for
days with mesa-7.8.2 queued instead. But it seems the Intel driver really
does need this version of Mesa or there are major problems with compositing
(most of them leading to an X server crash).
If X crashes at start, try disabling compositing. Create a file named
/etc/X11/xorg.conf.d/disable-composite.conf with this in it:
Section "Extensions"
Option "Composite" "Disable"
The machine that had issues here was using an onboard nVidia 6150SE.
Using the nv, nouveau, or even the vesa driver, X crashed at start unless
compositing was disabled. However, everything works perfectly when using
the binary nVidia drivers, and odds are that most users with decent nVidia
hardware are doing just that. So, that's the situation with nVidia and
Mesa as observed here for now. Hopefully the defaults will work better
soon, but meanwhile if you have nVidia hardware you may have to either
disable compositing or obtain and use nVidia's binary drivers.

Woodsman 03-06-2011 05:08 PM


It's been posted in this forum and hinted to in the changelog
You have to disable composite.
Yay! :D

The challenge with "hints" is that those of us who are clueless are not always quick to recognize the instructions as a hint. :scratch: :)

Thank you!

disturbed1 03-06-2011 07:22 PM

Another thing is that mesa had flipped flopped a couple of times in current since then, so that text is pretty far down the line.

It just so happened I had the same issue. I downgraded mesa, until someone else posted the correct solution.

All times are GMT -5. The time now is 01:10 AM.