-   Slackware (
-   -   can't reboot xen in slackware 12 after compiling glibc (

sysslack_linux 10-01-2007 05:07 PM

can't reboot xen in slackware 12 after compiling glibc
#This is my menu.lst:

title Xen
root (hd0,1)
kernel /boot/xen-3.0-unstable.gz dom0_mem=262144
module /boot/vmlinuz- root=/dev/hda11
module /boot/xen.gz

#and I have copied xen.gz and xen-3.0-unstable.gz to /hda2/boot

#This message I got at reboot (xenproblem or slackware 12-problem?)

** WARNING: Currently emulating unsupported memory accesses **
** in /lib/tls glibc libraries. The emulation is **
** slow. To ensure full performance you should **
** install a 'xen-friendly' (nosegneg) version of **
** the library, or disable tls support by executing **
** the following as root: **
** mv /lib/tls /lib/tls.disabled **
** Offending process: init (pid=1) **
#Followed sugggestions below from the link

#edit glibc.Slackbuild

# old
# new
CFLAGS="-g $OPTIMIZ -mno-tls-direct-seg-refs" \

#compiled glibc
installpkg glibc-2.5-i486-4.tgz

#Still same message:

#Then I did like this:

mkinitrd ? -m jbd:ext3 -s /boot/xen-tree -o /boot/xen.gz this message

NO /sbin/init found on rootdev
kernel panic

#Any suggestions would be deeply apprecitated!

gnashley 10-03-2007 04:18 AM

Does the directory /boot/xen-tree exist? Your initrd is apparently faulty.
If you recompile glibc then you'll probably need to re-compile your whole system in order for the binaries to run.

sysslack_linux 10-05-2007 05:10 PM

thank you for your reply
maybe I should compile glibc back then just by installing the original pkgtool packet glibc-2.5-i486-4.tgz?
Yes the tree does exist.
I have solved part of the problem.

mkinitrd -c -k -m jbd:ext3:ide-cd:ide-disk:ide-generic:libata:jfs -o /boot/xend.gz -s

Still get the same message, but it loads zen after a pause in 5 countdown seconds.

All times are GMT -5. The time now is 05:07 PM.