-   Slackware (
-   -   Can't mount USB memory stick/pen drive (

wellmt 06-22-2004 03:19 PM

Can't mount USB memory stick/pen drive
Hi all

New to linux and the Slackware distro but loving every minute so far. I'm running 10RC1 with a custom compiled 2.6 kernel (easier to support Nvidia nforce hardware). USB is working fine as far as I can tell as my Microsoft USB mouse is working great. When I plug in my Belkin memory USB pen/stick thing it doesn't seem to be 'seen'.

If type lsusb I get the following:

Bus 003 Device 004: ID 0ea0:6828 Ours Technology, Inc. OTI-6828 Flash Disk
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 045e:0047 Microsoft Corp.
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

Bus 003 Device 004 is the memory stick.

Now I know this USB device works OK under Linux as it worked just fine under SuSE9.1 and it is specifically Linux compatible.

I've created a mount point /mnt/usbpen

but how the hell do I mount the device? It's not seen as /dev/sda1 or /dev/sda2 etc as these devices don't exist as far as I can tell?

Any gurus out there that can help me?


acid_kewpie 06-22-2004 03:27 PM

you'll need certain modules to be loaded in order for it to be correctly recognised, suitable candidates include sr_mod, uhci_hid i *think* but if you do an lsmod on Suse if it's still around you'll be able to see what modules rely on the others just fine.

blk96gt 06-22-2004 03:39 PM

So you've tried doing a mount -t vfat /dev/sda1 /mnt/usbpen?

wellmt 06-22-2004 04:32 PM

Thanks for the replies.

>> So you've tried doing a mount -t vfat /dev/sda1 /mnt/usbpen? <<
Yep. All I get is special device /dev/sda1 does not exist...which is not surprisingly considering there is no /dev/sda1 device.

acid_kewpie: I couldn't find those kernel options in gconfig. Any idea where they lurk? I've tried enabling MTD support and MTDCFI but no joy.

Any more ideas anyone?

acid_kewpie 06-22-2004 05:26 PM

the modules you need are scattered around the palce as they do different things, you need usb mass storage support (so in USB somewhere) but the device is identified on the scsi bus, i.e /dev/sdXY so requires those....

usercsr 06-22-2004 05:39 PM

My usb flash drive is detected as /dev/hdb1, you might want to try mounting that

wellmt 06-22-2004 06:33 PM

>> the device is identified on the scsi bus <<

Even with Kernel 2.6.7? Aha...that might explain something...I've seen the following two errors during startup:

fatal: ide_scsi not found
fatal: agpgart not found

(the agpgart error might explain some strange x problems with the NVIDIA drivers)

Thanks I'll check it out.

wpyh 06-22-2004 08:20 PM

I thought no scsi emulation is necessary.. or does it only apply to cd writers?

wellmt 06-23-2004 03:58 AM

Yep looks like SCSI support is required. Recompiled the kernel with SCSI suuport and enabled SCSI_Emulation and I can now see my USB pen on /dev/sda1 and mount on /mnt/usbpen!

(Oh and I removed MTD support as this wasn't required)

Thanks a lot for the pointers

acid_kewpie 06-23-2004 07:43 AM

This isn't related to scsi emulation, that's, as you say for ide cd wriiters. but usb pen's are ide in the first place... all usb devices i've used like this are identified as scsi. i don't know much about the technology involved, but i'd guess it's likely that they actaully do use scsi interfaces, so while they aren't connected to a physcial scsi bus, they are real scsi devices.

HuMJohn 06-24-2004 10:26 PM

I hope you compiled in support for usb-storage and have done a modprobe for usb-storage. Then you could mount your /dev/sda1 to wherever you want it to show up.


eelriver 06-25-2004 02:10 AM

Do: tail --lines=50 /var/log/messages
Plug in pen drive, see how kernel deals with it, in my case it was mounted to /dev/sda and I added: " /dev/sda /mnt/flash vfat noauto,user 0 0" to my fstab. Works great.

All times are GMT -5. The time now is 08:22 PM.