-   Slackware (
-   -   cant login (keyboard dead) (

fwee 05-30-2003 08:48 AM

cant login (keyboard dead)
Ive had a search and cant find anything to point me in the right direction.

Ive just re-installed slack 9.0 all ran smoothly but when it reaches the login prompt my keyboard suddenly wont work and I cant type a thing.

Now it was working before and it works up untill the login prompt then nothing.

I cant think of anything todo as I cant check logs or find errors due to the keyboard death.

Any suggestions?

itsjustme 05-30-2003 10:40 AM

I had a dead keyboard issue, but it was way at the beginning of the install, at the point where it asked if I wanted to define the keyboard other than US.

My problem was that it was a USB keyboard. And at that point USB wasn't doing anything.

I disconnected that keyboard and connected a regular PS/2 type keyboard and the problem disappeared.

Is your keyboard USB? You may need to tweak your USB settings somehow.

Just a thought. Hopefully others can help more.

fwee 05-30-2003 10:45 AM

no unfortunatley my kb is ps/2 :/

Azmeen 05-30-2003 11:00 AM

This is a maybe... but I've witnessed quite a number of problems solved using this method...

Go into your BIOS settings and remove Plug and Play OS option.

Anyway, the minimum advantage here is that if you can get into BIOS it means that your keyboard is working fine... ;) We'd just need to tweak slack a bit.

webtoe 05-30-2003 11:05 AM

hmmmm, can you drop into single user mode? and have it working there? its a bit difficult to fix anything if you can't use a keyboard.......

sounds like something in one of the start up scripts (probably either rc.modules or rc.local or rc.keymap) is doing something dodgy.

when at the login prompt, does jabbing the numlock/capslock keys doing anything to the little lights on the keyboard?


fwee 05-30-2003 01:20 PM

I re-installed 2 more times, and '3rd time lucky' the kb worked.

I just didnt setup my network from slack setup. weird.

Back to gettin it runnin again :>

Thx for the input.

hikizume 06-01-2003 05:26 AM

this seems to be a recurring issue, maybe one of youz that had a problem should mail slack?

sharkze 10-12-2003 08:06 PM

can't login
I have exact same problem. I cant logn and use the keyboard a the login prompt. I have a new hp laptop 4420. I will check settings and suggestion to see if it works.

Zeratool Box 10-12-2003 11:40 PM

I ran into this problem too once. For me it happened to be gpm. I just had to edit /etc/rc.d/rc.gpm and change either the -m option or -t option. I forget which, but one of the options was wrong. Changing that fixed it for me.

All times are GMT -5. The time now is 10:41 AM.