LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't login after fresh install (https://www.linuxquestions.org/questions/slackware-14/cant-login-after-fresh-install-4175649825/)

pettijohne 03-08-2019 05:33 PM

Can't login after fresh install
 
I successfully installed 14.2 on an apu2. It boots and brings me to the login screen. However, it won't let me login. I tried adding the -a root switch to the agetty line in inittab without luck. I guess I'm going to try adding the -n switch instead. This doesn't seem like a good long term plan security wise. Feels like I'm hitting a /bin/login bug or a /sbin/agetty bug. Any suggestions welcome.

pettijohne 03-08-2019 05:53 PM

sorta solved
 
I created the following:

/bin/nlogin
#!/bin/bash
exec /bin/bash -l

Then added the following to the agetty line in /etc/inittab
-l /bin/nlogin -n

Still would prefer to actually supply a password to login.

Alien Bob 03-09-2019 04:14 AM

You think this is a bug in login or agetty? Why do you think that? Countless others installed Slackware before you and did not have this issue. To me the most probably cause seems to be the way you installed and some action you did (or forgot) there.
Can you tell more about how you installed, and as what user you are trying to login?

pettijohne 03-09-2019 06:55 AM

steps taken
 
1. rsync "source" using examples from `mirroring guidelines`
2. edit isolinux/isolinux.cfg
Adding `serial 0 115200` as the first line. Then adding `console=ttyS0,115200` to the append line
3. Made the iso following instructions from isolinux/README.TXT
4. Boot the apu2 https://pcengines.ch/apu2d2.htm
5. Partition the disk and install
Since the harddrive is only ~30g I only installed a/ ap/ d/ l/ n/ sets
6. chroot /mnt /bin/bash
7. make an initrd in the typical slackware fashion
8. edit lilo.conf
9. install lilo
10. Edit the new inittab by uncommenting the serial line
11. exit from chroot && Boot the fresh install
12. lots of output till the login prompt pops up.
13. Login: root
Password: thepassword

Login failed. (or something similar)

Login:

This continues till I pull the plug.

hazel 03-09-2019 07:04 AM

I can't see any reference in your very detailed account of the install to your having set a root password. Did you do that? If not, you need to chroot back into the system and do it now.

Alien Bob 03-09-2019 07:13 AM

OK, thanks for providing this feedback. Without input, no output :-)

I assume then that you did not create a 'regular' user and are trying to login as root.
Slackware's shadow authentication reads /etc/login.defs for configuration. In there you will find this text:

Code:

#
# If defined, either full pathname of a file containing device names or
# a ":" delimited list of device names.  Root logins will be allowed only
# upon these devices.
#
CONSOLE        /etc/securetty
#CONSOLE        console:tty01:tty02:tty03:tty04

Now, looking at /etc/securetty:
Code:

# This file defines which devices root can log in on.

# These are the ttys on the physical console:
console
tty1
tty2
tty3
tty4
tty5
tty6

# These are some remote ttys, and uncommenting them might be less than fully secure:
#ttyS0
#ttyS1
#ttyS2
... and it goes on like this...

Which shows that the serial consoles are not accepting root login by default, unless you edit /etc/securetty and uncomment the line for your serial console.

Does this solve your login issue?

pettijohne 03-09-2019 07:58 AM

[SOLVED]
 
That did the trick.

Alien Bob 03-09-2019 08:05 AM

Good! Now can you please also mark this thread as [SOLVED] using the thread tools? That will inform other readers of this forum.


All times are GMT -5. The time now is 07:20 PM.