-   Slackware (
-   -   Cant load matrox mga driver (

genix 11-11-2007 11:59 PM

Cant load matrox mga driver
Running slackware current with an nvidia card and as usual it works like a charm.
However just the other day i found literally, a matrox millenium card on the side of the road.I pulled it out of the box it was in and went home and put it in a spare PCI slot in my box. I plugged in another monitor into this extra card and turned on the machine. So i have TWO video cards and two monitors in my slackware current at this stage, the old working card and monitor ( Nvidia 128 mg ram ), and the, found on the side of the road matrox card and spare monitor.

While booting my box the NEW card and monitor displayed the boot procedure, and i was instantly pleased to see the new ( when i say new i mean recent, as this cards an oldy) card works. As i dont boot into X straight away i was sitting there looking at my login prompt on the new monitor and card.
I then logged in and typed in startx. Now as my monitor and Nvidia card is already well setup, the new monitor and matrox went black, (as to be expected ) and the second monitor came to life and KDE loaded up nicely.
So i thought excellent, both cards work and both monitors work, now i would like to make them both work together. So i found that the driver for the old matrox card is call mga, so i set up a new monitor and device section in my xorg.conf using "mga" as the driver in the new device section, but alas it did not work, the /var/log/Xorg.conf.log says

(II) LoadModule: "mga"
(WW) Warning, couldn't open module mga
(II) UnloadModule: "mga"
(EE) Failed to load module "mga" (module does not exist, 0)

So i thought maybe if i try to modprobe this driver as im using a monolithic kernel and pat has probably built this driver, and
no problem, i CAN modprobe mga, but alas i cannot use this driver in X.
Is the driver im modprobing the same driver as X cant find.
I have setup my linux headers and setup /usr/src/linux for kernel building. And when setting up my NVIDIA card i built a new nvidia kernel module ( the proprietary kind ).
Do i have to do the same with the matrox millenium card.
Any help would be really appreciated on this issue as it would be nice to have dual monitors again on this box.

acummings 11-12-2007 02:22 PM

Just a simple setup with a single CRT monitor here.

I do use a Matrox G400 or G450 AGP video card.

Through Slack 11.0 the xorgconfig worked fine.

But in Slack 12.0 there was absolutely no mga driver listed by xorgconfig for me to choose.

After I nearly created my own module/driver from download from Matrox WWW site, I then decided to try Slack 12.0's


That auto created and it had mga in the xorg.conf

now just as good if not better video in Slack 12 than in Slack 11

BTW relatively recently, Xorg and the older Matrox (mga) do have an issue of some sort as far as questionable as to whether Xorg continue to support this one. (relevant google/linux/ searches will show you).

Why the xorgsetup worked in my case, I do not know.

xorgcfg xorgconfig xorgsetup

each with varying levels of sanity or so I heard.


genix 11-12-2007 06:08 PM

Ok i got my hands on the driver here
I then built the driver, ./configure, make
then copied the driver from src/.libs/ into /usr/X11R6/lib/modules/drivers/.
I then setup a new Device, Monitor, and Screen section in xorg.conf, and changed the Server Layout section to
Screen "Screen0" 0 0
Screen "Screen1" leftOf "Screen0"
and now i have a dual monitor slackware box.

All times are GMT -5. The time now is 05:17 PM.