-   Slackware (
-   -   Can't lilo triple boot(XP,Slack,Fedora)??? (

DaVenom 03-16-2004 09:55 AM

Can't lilo triple boot(XP,Slack,Fedora)???
This is how my hard disk looks like

hda1* hda2 hda3 < hda5 hda6 hda7 hda8 hda9>

hda1 = XP Boot partition
hda2 = fedora /boot
hda3 = common swap
hda5 = fedora /
hda6 = fedora /home
hda7 = fat32 XP partition
hda8 = slackware9.1 /
hda9 = slackware9.1 /home

I installed them in this order XP, Fedora, Slackware. During slackware installation, lilo replaced grub(this was intentional). But lilo cannot load fedora properly, it loads the other two fine.

my lilo.conf(the fedora part) reads like this

image = /boot/vmlinuz
root = /dev/hda2
label = fedora

with this it said 'kernel panic, use init'

now i modified lilo.conf to read like this

image = /boot/vmlinuz
root = /dev/hda2
label = fedora
initrd = /boot/initrd.img

and reinstalled, lilo.

but the same error continues. I tried, most options from reading the man pages on lilo and lilo.conf, but haven't been successful yet. Maybe i'm doing it wrong.

somebody plz, throw some light.

yelo 03-16-2004 10:12 AM

try passing the option to fedora(at the menu where you pickyour OS) init=/dev/hda2, or if that doesn't work, init=/dev/hda5

aaa 03-16-2004 01:16 PM

Don't pass init options. Change the 'root=' line to /dev/hda5 bacause that is where the Fedora root (/) is. If Fedora needs an initrd, put the path to it relative to Slack. If your fedora /boot (hda2) is mounted at /mnt/fedoraboot in Slack, the path to it in Slack will be /mnt/fedoraboot/initrd.img . Also, change the path to kernel image file accordingly.

DaVenom 03-18-2004 10:49 PM

thanx aaa....

That worked like a charm...

Now, i'm more confident of lilo... thanks to that tip...

bashrc2 03-18-2004 11:18 PM

yes its possible here is my lilo.conf for reference:

# new slack kernel
image = /boot/bzImage-2.6.4
root = /dev/hda10
label = Slackware-9.1
# old slack kernel
image = /boot/vmlinuz.bak.old
root = /dev/hda10
label = SlackFailSafe
# winxp
other = /dev/hda1
label = Windows-XP
table = /dev/hda
# new redhat kernel
image = /mnt/rh/bzImage-2.6.4
root = /dev/hda5
label = RedHat-9
# old redhat kernel
image = /mnt/rh/vmlinuz-2.4.20-8
root = /dev/hda5
label = RHFailSafe

murray_linux 06-18-2004 01:44 PM

Hmm, I'm trying to do basically the same thing and I'm running into the same error message. I have WinXP, Slackware and Redhat installed, with Slackware installed last. Slack and XP load fine, when I try to get redhat goin, I get the same error as DaVenom.

I've followed the steps in this thread (mounted my redhat /boot into slack, and added the root and images to my lilo.conf and ran lilo)

my partitions are like this:

hda1 = WinXP
hda2 = Redhat /boot
hda3 = redhat /
hda4 = logical drive partition
hda5 = swap
hda6 = Slackware /

Here is my lilo.conf:

# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
boot = /dev/hda
timeout = 300
vga = 773

image = /boot/vmlinuz
root = /dev/hda6
label = Slackware
read-only # Non-UMSDOS filesystems should be mounted read-only for checking

other = /dev/hda1
label = WinXP
table = /dev/hda

label = RedhatSMP
root = /dev/hda3
initrd = /mnt/rhboot/initrd-2.4.21-4.ELsmp.img
append="hdc=ide-scsi root=LABEL=/"

label = Redhat
root = /dev/hda3
initrd = /mnt/rhboot/initrd-2.4.21-4.EL.img
append="hdc=ide-scsi root=LABEL=/"

Thanks for your help!

murray_linux 06-18-2004 05:02 PM

commenting out

append="hdc=ide-scsi root=LABEL=/"

solved the problem :D

All times are GMT -5. The time now is 03:16 PM.